Banda Ancha EU

Comunidad de usuarios
de fibra, móvil y ADSL

[Solucionado] Problema conexion WiFi a AP conectado por PLC

lokonai

Hola a todos y gracias por adelantado!!!

Mi problema es el siguiente: Tengo la entrada de ADSL en la planta baja de un adosado, allí conecto el router de Movistar (Homestation Observa), de este saco un cable a un PLC Belkin que conecto también en el salón (donde no llega la red WiFi) y al PLC del salón conecto un antiguo Comtrend ar5387un como Access Point para tener conexión en la TV y red WiFi en el salón. Hasta aquí todo sencillo. Al Comtrend le desactivo DHCP, le doy una IP diferente a la del Homestation pero dentro de rango y....voila!!! Tengo internet en el salon...por cable

Por WiFi la cosa cambia, es un poco raro para mi, por eso os consulto: si conecto tablet, iPad, teléfono o laptop por WiFi a la red del Comtrend, se conecta perfectamente y tengo internet bien....pero....si ese mismo dispositivo lo llevo a la planta baja y lo conecto a la red WiFi del Homestation, (se conecta bien y tiene también internet), si vuelvo al salón, ya no vuelve a conectar a la red WiFi del Comtrend, como si no le diese IP...

He probado de todo....poner el Comtrend como router principal y el Homestation en el salón, he probado también con un ZTE h108n que tenía por ahí en el salón y como principal...mismo nombre a la red WiFi pero con diferente canal, con el mismo canal , con diferentes nombres....y el resultado es siempre el mismo, en cuando conecto algo al WiFi del router principal, no puedo conectarlo ya a la red WiFi del salón...

A ver si alguien me puede ayudar!! Gracias por adelantado!!!

BocaDePez
BocaDePez

quizas el router principal guarda algun tema de mac....

has probado en vez de usarlo como AP a usarlo como router? es decir, le das una ip fija por el puerto WAN, que es donde conectas el PLC, pero que tenga DCHP y asigne ips en otro rango a los dispositivos conectados, de esta forma, el router principal no sabe nada de los otros dispositivos conectados y solo ve el router secundario

🗨️ 2
lokonai

Gracias por la respuesta!!!

Me imaginaba que iba por ahí algo, pero no sabía el que...la verdad que he leido en muchos foros y hay muchos post sobre como usar estos routers "viejos" para esto...y en general funcionan...lo que me extraña es que si conecto por cable ethernet, funciona perfectamente todo, el problema de conexión es solo por WiFi.

Sobre lo que me dices de usarlo como router, debo cambiar los rangos de IP de ambos supongo...por ejemplo, al principal desde 192.168.1.1 hasta 192.168.1.128, y al Comtrend desde 192.168.1.128 hasta 192.168.1.254?

¿La IP que asignaría al Comtrend, debe estar dentro del rango del principal?

🗨️ 1
lokonai

Solucionado!! El problema eran los PLC Belkin Powersurf F5D4077 v1...que deben ser antiguos y no valen para esto, lo miré por todas partes y no pueden ser configurados como Bridge. Los cambié por unos TP-Link AV500 nano sencillitos, que fue conectarlos y todo funcionando perfectamente.

Gracias a todos por la ayuda!!! Saludos.

BocaDePez
BocaDePez

Estas usando un aparato (router ADSL) con una función para la que no está preparado.

No me extraña en absoluto que pase lo que describes: el problema se llama "caché de ARP".

El Comtrend de repente se encuentra con que la MAC del dispositivo móvil (tableta, teléfono, etc) ya tiene una IP en su caché, proporcionada por el router Homestation de la planta baja, pero propagada por el "cable" del PLC hasta su switch.

vukits

hmmm...

de partida, pon el mismo nombre de red, canal, tipo de seguridad y contraseña en ambos routers..

a ver si cuela y hace roaming