BandaAncha.eu

Comunidad de usuarios
de fibra, móvil y ADSL

Problema conexión NAS y XBMC por SAMBA

pericay

Hola, Hace cerca de 2 meses me he comprado un NAS, un D-Link DNS-345, una maravilla, al menos para mi ya que por lo que me costo deberia serlo, pues bien, le tengo metidas infinidad de peliculas en diferentes formatos y estas las veo en la TV por el XBMC a traves de SMB, vale ahora viene el problema. Resulta que un dia me pongo a ver una pelicula y todo bien hasta que al rato de estar visualizandola se para, como si le diera al STOP y me sale al menu de peliculas, le vuelvo a dar para seguir viendola y me dice que no la encuentra, le vuelvo a dar y no me hace nada, asi hasta unos 5 minutos que le doy al PLAY y me sigue la reproduccion desde donde se quedo, a lo mejor al rato se me vuelve a parar o a lo mejor ya la veo del tiron, otro dia me veo otra pelicula y no se me para. En el menu del NAS he desconectado lo del ahorro de energia y varias cosas mas como la hibernacion de los HDD, yo ya nose que mas tocar, pero sigue sin solucionarse. He buscado por foros pero sobre este NAS no hay apenas nada de informacion, estoy ya un poco desesperado ya que no le encuentro el fallo y la verdad es que molesta bastante, estan conectados con un swich TP-LINK TL-SG1005D y los 2 pc tienen red gygabite conectados con cable Cat5e, IP's son estaticas. Antes de tener el NAS las peliculas las tenia en otro pc y las compartia al pc del XBMC e iba perfectamente, entonces me supongo que sera algo del NAS. El error que pone en el NAS en el historial es el siguiente: Nov 6 23:55:22 CIFS: [192.168.1.133] closed the connection to service [Volume_4] ( la IP 192.168.1.133 es la del pc del XBMC) El NAS tiene otra acabada en 129. Perdonar por el tocho, pero cualquier idea o algo que se os pase por la cabeza me seria de gran ayuda. Un saludo y muchas gracias.

BocaDePez
BocaDePez

¿Los discos están en RAID 5? ¿Tienes en los logs algo relacionado con recuperación de sectores? ¿Qué marca y modelo de discos tienes metidos?

Podría ser que no tuviese nada que ver con los discos y solo se cayese la sesión SMB, pero es raro que tras reintentar durante 5 minutos, no siga... como si el NAS no respondiese a las peticiones SMB justamente por estar ocupado en otras cosas (¿restaurando el RAID?).

BocaDePez
BocaDePez

Solucionado, cambie el Switch y probe peliculas, no se para ninguna, diferentes calidades y peso y como si nada.

El problema es que el Switch que quite tiene lo del ahorro de energia o el sistema Green y no va fino, al menos a mi, lei de otro chico que le pasaba mas o menos igual y despues de hacer pruebas dio con lo mismo, cierra puertos y por H o por B me cerraba el de la pelicula que se estaba transmitiendo.

Llevo probadas unas 10 peliculas enteras y no se para.

Gracias.

🗨️ 1
BocaDePez
BocaDePez

Pues gracias por volver al foro a comentarlo; es la primera vez que oigo de un switch con ahorro de energía.

BocaDePez
BocaDePez

Si en las caracteristicas lo pone Green Ethernet, pero me vuelve a pasar otra vez, como ya dije quite el switch y tengo el router de Jazztel, el modelo AR-5387un ADSL 2+ 10/100 al NAS, el NAS a su vez a un switch 10/100 basico y este al PC del XBMC y a la TV, asi la tele tambien la tengo con cable en vez de Wifi, pues me vuelve a pasar, se me paran tanto en el XBMC por SMB o en la TV por DLNA.

Puede ser el router que no pueda? es decir, que le este pidiendo demasiado? Como ya tiene su tiempo...

En la TV cuando se para pone Fallo del Servidor.

Es que la putada es que nose por donde tirar, si es fallo del router o del Nas.

Antes de tener el NAS, en el PC Principal tenia 5 HDD con las peliculas y trasmitia igual por red y no se paraban en el XBMC, pasa que se empezaron a joder los HDD porque estaba saturando demasiado el PC y al final obte por el NAS pero maldita sea la hora porque no acabo de dejar el tema fino.

Si es verdad que estubo una temporada sin fallar, pero sigue igual.

Otra opcion antes de cambiar o devolver el NAS es comprarme un Router Giga de la marca CISCO que son la leche, dicen que estan preparados para streaming en HD, haber si asi se solucionase.

Haber si alguien sabe o le ha pasado y me puede arrojar algo de luz en el asunto porque empieza a ser bastante desesperante ya.

Muchas gracias.