BandaAncha.eu

Comunidad de usuarios
de fibra, móvil y ADSL

Problema al capturar impresora con cliente de terminal serve

BocaDePez
BocaDePez

Hola, pues os situo.
Dos oficinas conectadas con vpn funcionando perfectamente, accedo a la oficina 1 a traves de terminal server y no me captura ninguna impresora que tengo instalada en mi pc, lo he probado con los 4 pc que hay en la oficina y nada, he intentado probarlo quitando la vpn y tampoco.
Desde otra oficina que no tiene vpn, a 3 usuarios les captura sus impresoras perfectamente.
EL sistemas operativo del servidor es el Windows 2003 Server Standard Edition, los drivers de todas las impresoras estan configurados en el servidor y por si acaso se ha probado con dos adsl que hay en la oficina 2.
Por favor si alguien me puede hechar un cable se lo agradeceria.
Un saludo.

Este tema está cerrado a nuevas respuestas. Abre un nuevo tema para retomar la conversación.
KATOR

Y los drivers de las impresoras los tienes instalados en los clientes ..???

Si trabajas con una VPN, lo mas sencillo es que compartas la impresora y luego la instalas en los equipos remotos.

Tambien tienes la opcion cuando te conectas por terminal server de conectar las impresoras remotas pero para ello como te he comentado al principio tienes que tener instalados los drivers de las impresoras en la maquina que se conecta.

Es importante que tengas habilitada la redirección de impresora en el cliente y en el servidor.

Yo las impresoras de red las tengo configuradas con IP, y de esta forma no hay ningún problema, en el cliente al instalar el driver le dices que el puerto apunte a la IP de esa impresora y listo.

Chao.

🗨️ 3
saxsalas

Eso no te soluciona gran cosa...

Por ponerte un ejemplo sencillo: tienes un documento de word de apenas 150Kb y lo envías a imprimir a cualquier láser normalita y te genera un archivo de impresión de unos 3-5Mb. A ver quien es el guapo que pasa eso de forma rápida por un adsl.

No todas las impresoras van bien con TS. A veces una láser funcionan bien con los drivers PCL5 y no con los PCL6. A mi me ha pasado de todo un poco...

Hay impresoras que sin instalarlas en el servidor funcionan bien. Otras necesitas instalarlas. Otras depende de la versión del driver. Es todo un mundo...

Me he llegado a encontrar con situaciones imposibles de resolver y entonces he utilizado WIN2PDF TSE. Es una aplicación que te instala un driver de impresora para imprimir PDFs, compatible con Terminal Services (Adobe no lo es) y te lo envía de forma automática a una dirección de e-mail predefinida. Al llegarte el mail lo imprimes en local a la velocidad del rayo con la misma calidad que estaba en el original.

También me he encontrado con algunas Canon láser que instalan el driver cada vez que conectas por TS y muestra una ventana de notificación en el server. Hasta que alguien no pulsa Aceptar en la dichosa ventanita, se paraliza la sesión del cliente. Al cerrar hace lo mismo y no finaliza el cierre de la sesión hasta haber pulsado Aceptar.

Como decía... todo un mundo...

Suerte.

Saludox.

🗨️ 1
KATOR

Pues mira, a mi me da la impresión que lo que tu sugieres, sí que en verdad no soluciona nada.

Por la sencilla razón de que no aportas nada en absoluto que trate de solucionar o ayudar a solucionar el problema, simplemente das tu impresión desde tu experiencia personal.

Chao.

BocaDePez
BocaDePez

Muchas gracias, pero todo lo que me dices ya lo he hecho.

saxsalas

A ver... yo primero comprobaría que el usuario creado en el server tiene privilegios para crear/instalar nuevas impresoras. Es fácil, prueba desde el mismo equipo a entrar con un usuario que te funcione correctamente en otro ord.

Otra cosa curiosa es que a veces no puedes capturar una impresora local si ya la tienes compartida en la red o la tienes vinculada por red a través de otro equipo. TS soporta la mayoría de las impresoras solo cuando están conectadas directamente al equipo, y algunas por USB dan problemas también.

Por cerrar un poco el círculo, comprueba el tema de cortafuegos. Los dispositivos en red necesitan un par de puertos para funcionar correctamente. Creo que uno de ellos era el 445 pero no te lo puedo asegurar... te hablo de cabeza. De todos modos yo iría probando a desactivar los cortafuegos que tengas, aunque solo sea para delimitar el problema.

Suerte.

Saludox.

🗨️ 4
BocaDePez
BocaDePez

Hola, los usuarios les tengo provilegios de administrador, los firewall los tengo desactivados.
Probare a no compratir la impresora en ningun equipo.
Gracias

KATOR

A ver, el usuario del AD, o del server, no tiene porqué tener privilegios para instalar impresoras, las impresoras las instala el administrador de la red.

Las impresoras tienen que estar instaladas en el local desde el que se esta ejecutando el usuario contra el dominio, necesariamente no tienen porque estar instaladas en el server, de hecho yo no tengo ninguna impresora instalada en el server, las tengo en red y con IP.

Sí podria ser problema de firewall, o incluso de puertos en el router.

Chao.

🗨️ 1
BocaDePez
BocaDePez

A ver, los firewall estan desactivados, y por los router no creo que sea, se ha pedido una adsl aparte solo para esta conexion, y tampoco funciona.

BocaDePez
BocaDePez

Compañeros esto de las impresoras en terminal services es realmente complicado, dejenme decirles que en donde trabajo tenemos el mismo problema con las impresoras, TS tiene problemas con impresoras compartidas, cuando importas tus recursos locales unicamente te importa las impresoras que estan instaladas por Paraleleo y activas en ese momento, asi pues cualquier impresora que se encuentre compartida no la reconocera el Terminal solo si abre un puerto en el terminal. Eso se hace asi por si alguien quiere intentarlo En agregar impresoras le dicen que van a agregar una impresora local y le dicen que use el puerto siguiente: hai seleccionan el puerto del usuario que va a tener el servicio de la impresora instalan los drivers y listo el usuario podra imprimir desde cualquier parte del mundo de donde se conecten por medio de la VPN y el terminal. Si quieren que otros usuarios usen esta impresora lo unico que tienen que hacer es compartirla asi los demas usuarios la veran.

Aqui viene el Pero, para toda solucion hay un pero y es aqui en doden estoy atorado, cada vez que el usuario cierra sesion en Terminal y la vuelve a iniciar el servidor le asigna un puerto diferente a la impresora por lo tanto el puerto que con antelacion habiamos designado queda inactivo y hay que nuevamente asignarlo al que este activo.

Si alguien sabe como fijar este pouerto le agradeceria mucho su ayuda y si alguien necesita ayuda me pongo a sus ordenes en gassip@hotmail.com o por skype busquenme por el n}Nick nme de gassip espero que sea de utilidad

🗨️ 1
JoeDalton

Compartir una impresora asignada es una ñapa de categoría 15, por eso no te funciona, sigue las indicaciones que doy en el link de arriba.

Por cierto las respuestas en el foro.