BandaAncha.eu

Comunidad de usuarios
de fibra, móvil y ADSL

problema actualizando de lenny a squeezze

dnight

hola buenas,

tengo una vps que quiero actualizar a debian 6.. cuando hice el apt-get dist-upgrade, hizo todo bien.. pero al intentar migrar al nuevo sistema de boot de debian 6 me dice:

Unable to migrate to dependency-based boot system
Tests have determined that problems in the boot system exist which
prevent migration to dependency-based boot sequencing:
insserv: warning: script 'S10vzquota' missing LSB tags and overrides,
insserv: warning: script 'vzquota' missing LSB tags and overrides,

¿alguna idea para solucionar esto y poder acavar de migrar el sistema?

saludos.

vukits

antes de hacer dist-upgrade, mejor hacer upgrade , o algunos lo llaman soft-upgrade

🗨️ 1
dnight

buenas.

claro, hice primero apt-get update para actualizar los repos.. luego upgrade, y luego dist-upgrade

saludos.

vukits

hmm..

actualiza manualmente vzquota..y así con cada paquete que te de error.

aptitude install vzquota

saludos

🗨️ 5
dnight

buenas.

instalado, el script s10 no lo encuentra.. y asi lo instale, el tio sigue con esos dos errores

saludos.

edit: el kernel que lleva es antiguo, no sé si compilar yo uno o instalarle el más nuevo

saludos.

🗨️ 4
vukits

pues...

desinstala lo que te de conflicto.. apuntatelo y luego reinistalalo..

se desinstala completamente

dpkg --purge vzquota

sobre el kernel... el que lleva Debian Squeeze está bien.. al menos que quieras parchearlo, en cual caso sí necesitarías recompilarlo.

saludos

🗨️ 3
dnight

buenas.

es que no tiene el que lleva squeeze, tiene uno raro de 2010

saludos.

dnight

buenas.

el que tiene es: 2.6.18-194.8.1.el5.028stab070.5

es una versión mas vieja que.... por eso la quiero cambiar, si pongo apt-get install linux-image- y la version del kernel, se baja los 4 que encuentra y los mezcla en uno

¿cómo puedo actualizar el kernel mediante apt-get o aptitude?

saludos.

🗨️ 1
vukits