BandaAncha.eu

Comunidad de usuarios
de fibra, móvil y ADSL

Posible fallo de driver WiFi en Linux? (Atheros AR9485)

Sokiev

Buenos días a todos, a ver si alguien sabe qué puede suceder con el controlador de este dispositivo...

Describo el caso: Tengo un portátil, marca Asus (y modelo "desconocido" ahora mismo, pero que para el caso no importa), que integra un WiFi marca y modelo Qualcomm Atheros AR9485, usando el controlador ATH9K.

El caso es que, use la distro que use (Ubuntu, Fedora, Arch e incluso ReadyCloud (versión de Chrome OS), versiones x64 obviamente) todas reconocen el dispositivo, y funciona, es decir, detecta todas las redes wifi existentes, pero nunca se conecta. El proceso es tal que así:

Voy al panel wifi -> selecciono un SSID -> Meto la contraseña -> El sistema se queda 1 minuto "conectándose" -> Me vuelve a pedir la contraseña; y así entramos en bucle: pidiendo la contraseña -> "conectándose" -> pidiendo contraseña -> "conectándose"; hasta el infinito.

Ya he probado varias cosas, como buscar por Google posibles soluciones, y entre las soluciones que no han solucionado nada están:

1.- Cambiar los parámetros del wifi (en vez de AES+TKIP, usar sólo uno de ellos). Cambiar WPA-PSK2 por otra opción. Probar con otro wifi diferente.

2.- Abrir la terminal y teclear sudo rfkill list all para ver el resultado, siendo el siguiente:

0: phy0: Wireless LAN
    Soft blocked: no
    Hard blocked: no
1: asus-wlan: Wireless LAN
    Soft blocked: no
    Hard blocked: no

3.- Modificando /etc/network/interfaces poniendo lo siguiente:

auto wlan0
iface wlan0 inet dhcp
wpa-ssid
wpa-psk

Y nada, que no hay manera. Aclarar que en Windows 10 el WiFi va sin problemas de ningún tipo. No sé, ya me reconcome saber a qué se debe esto.

Y para más inri, el WiFi Atheros AR9485 está certificado por Canonical en múltiples dispositivos (ordenadores portátiles) certificados, así que entiendo que debería de funcionar correctamente. www.ubuntu.com/certification/catalog/com … i/168c:0032/

Gracias por posibles consejos/ideas/ayuda. Saludos.

BocaDePez
BocaDePez
2

Deja el wifi abierto, sin contraseña, a ver si se conecta.

Si lo hace, ve intentando con contraseña .

BocaDePez
BocaDePez

Mira en /var/log también pero tiene pinta de que la clave es errónea.

Alex B

Te reporto que esa targeta tiene muy buen soporte en linux y por eso rebusqué en el mercado de 2º mano para ponerselo a mi portátil.Yo la tengo con Gentoo y funciona perfectamente, tanto el wpa_supplicant bajo una WPA2 AES como sobre una WPA2 de eduroam que antes me solía dar problemas con la intel que tenía mi portátil.

Mi wpa_supplicant es v2.4 el driver ath9k es el del kernel 4.4.1 de gentoo (tiene ciertas modificaciones respecto al kernel 4.4.1 original), pero imagino que el driver está igual que el vanilla, porque no hay ningún parche del kernel para eso.

description:    Shared library for Atheros wireless 802.11n LAN cards.
author:         Atheros Communications
depends:        ath9k_hw,cfg80211,ath
intree:         Y
vermagic:       4.4.1-gentoo SMP mod_unload modversions

¿Que versiones tienes tú?

Spyd

Has probado con otro punto de acceso? Igual el problema sea tu punto de acceso que igual por algún bug o algo no conforma al 100% con los estándares (y eso implicaría que el driver de Windows es más permisivo con las conexiones y el de Linux más severo).

También deberías probar a deshabilitar la seguridad de la Wifi a ver si así te conecta.

Si con otro PA si funcionara, intenta actualizar el firmware de tu PA o si es de operadora, diles que no funciona y que te envíen uno nuevo.

vukits
1

Ve probando LiveCD's ...

¿Has probado Debian Jessie?

¿EliveCD Beta? (ese, para instalarlo, hay que pagar 15€ .. pero es muy bueno)

¿Sabayon?

¿Foresight?

🗨️ 13
Alex B

Para pagar por Elive mejor utilizar bodhi linux que es un primo hermano , no sé si lo has probado.

A mi también me gusta enlightenement si la desarrollan(el gestor de archivos es muy simple) y compatibilizan/integran mas yo creo que triunfaría.

El terminology es la leche y aunque uso xfce en todos mis gentoo instalo terminology porque me gusta los efectos.

🗨️ 12
vukits

ainss.. esta comprensión lectora :P ..

se paga por instalarlo ... no usarlo desde el LiveCD..

EliveCD es mucho más que Enlightenment ;)

🗨️ 11
Alex B

¿Puede ser que seas el tali-apple que se queda sin argumentos y lo hace sin mostrar el nombre?

Según lo que vi en su web cuando lo pusiste es lo mismo que cualquier otra distro pero con enlightenment por defecto como lo es bodhi linux.

¿Que tiene de especial?

🗨️ 10
vukits
🗨️ 4
Alex B
🗨️ 3
vukits
🗨️ 2
mceds
1
🗨️ 1
Alex B
BocaDePez
BocaDePez
🗨️ 4
Alex B
🗨️ 3
BocaDePez
BocaDePez
-1
🗨️ 2
Alex B
🗨️ 1
BocaDePez
BocaDePez
-1