Banda Ancha EU

Comunidad de usuarios
de fibra, móvil y ADSL

¿Es posible configurar VPN passthrough en el router Technicolor TC7230.L?

  • Fibra/Cable

    [Editado]

    BocaDePez BocaDePez

    ¿Es posible configurar VPN passthrough en el router Technicolor TC7230.L?

    Necesito usar la VPN de la empresa desde casa y compruebo que el router bloquea la conexión. Por lo que he leído es necesario que el router permita activar "VPN passthrough".

    He entrado en la config "modo experto" (juas!) del TC7230.L y no encuentro nada parecido. ¿Tengo que morir a un router neutro? ¿Alguna sugerencia?

    Gracias!

      • BocaDePez BocaDePez

        Uso OpenVPN y aparentemente se conecta bien (getting client…

        Uso OpenVPN y aparentemente se conecta bien (getting client configuration .... the connection has been established), pero cuando quiero acceder a páginas de la empresa p.ej. http://192.168.0.25/Intranet/Acceso.aspx no carga y salta "The connection has timed out". Tampoco resuelve URLs normalitas tipo www.elpais.es, el navegador (Firefox 52.8.1) se queda en "looking up..." hasta que salta "Server not found".

        Sin embargo realizando los mismos pasos anteriores con tethering desde móvil funciona perfectamente (tarjeta de datos DIGImobil)

        Gracias por tu ayuda.

        • Por casualidad la red local de tu casa no será 192.168.0.0/24…

          Por casualidad la red local de tu casa no será 192.168.0.0/24 ... ¿verdad?

          También ten en cuenta que el cliente de OpenVPN hay que ejecutarlo como Administrador en Windows ... y no vale con que 'seas administrador' ... cierralo y ejecuta el UI de OpenVPN con 'botón derecho -> Ejecutar como administrador'

          Lo de que las URL normales no te vayan, puede ser porque si en la config desde la oficina te mandan un 'enrutar todo el tráfico por el tunel', cosa pelín estúpida ... pero puede pasar, y como no te está funcionando el routing normal del tunel (probablemente por el tema de que no estas ejecutando el openvpn como administrador), pues tampoco te funciona eso.

          • BocaDePez BocaDePez
            En mi caso utilizo Shrew. Establece tunel pero no conecto por…

            En mi caso utilizo Shrew. Establece tunel pero no conecto por Termial server. Si hago ping tampoco tengo respuesta, no hay acceso a recursos compartidos, etc.

            ¿Por qué puede ser el problema en el que rango de IP será 192.168.0.0/24 ?

            Gracias

            • Hola. Porque si tu rango de IP's local es el mismo que el…

              Hola.

              Porque si tu rango de IP's local es el mismo que el remoto…¿Como sabe el sistema si la IP que necesitas está en tu red local o debe "pasar por el túnel"? El problema no es el rango 192.168.0.0/24 en sí, sino tener las dos redes en el mismo rango. ;)

              Esto es una forma simplificada de explicarlo, para los "puristas".

              • Que ya de por sí me parece absurdo montar túneles VPN en…

                Que ya de por sí me parece absurdo montar túneles VPN en rangos tan usados como ese 0.0 (típico en Vodafone-Ono) como 1.0 (el resto).

                Mira que es extenso el 192.168.0.0/16 y sobretodo el 10.0.0.0/8 para montar los túneles en donde más por culo da 🤦🏻‍♂️

                • Hola. Tienes toda la razón…imagino que como todos los "tutos"…

                  Hola.

                  Tienes toda la razón…imagino que como todos los "tutos" y "videotutos" usan esos rangos, al final todos caemos en lo mismo. ;)

                • Y otra cosa que me mata…llegas a una empresa a pegarte con su…

                  Y otra cosa que me mata…llegas a una empresa a pegarte con su red y ves que los equipos se llaman así como "servidor", "gerencia", "admon1", "recepcion", etc.

                  Coges al pobre currante que, como sabe instalar un Windows, han puesto a llevar la red y le dices "A ver, alma de cántaro…imagina que accedo a tu red con ánimo malicioso…¿A que equipo crees que atacaré? ¿al que se llama "recepcion" o al que se llama "servidor"? Si quiero tus datos contables…¿puede que elija atacar al que se llama "admon1" en lugar de perder el tiempo atacando a "gerencia"?".

                  Cuando un administrador de redes llama a los equipos con nombres de lunas del sistema solar (por ejemplo), es por algo (aparte de por frikismo, claro). ¿Ataco a Caronte o a Ganímedes? ¿me pego con Phobos o con Deimos?

                  Y así todo el rato… XD

              • BocaDePez BocaDePez
                Ok, eso sí lo tenía claro. No sé por qué me establece…

                Ok, eso sí lo tenía claro. No sé por qué me establece conexión pero no me hace ping a ninguna máquina.

                En la oficina utilizo para las máquinas: 192.168.4.0/24

                En casa: 192.168.0.0/24 ( Desde aquí no consigo enlazar) Creo que es problema del router.

                Y en la VPN 192.168.10.0/24

                En el router de casa tengo:

                • Activado UPNP.
                • Desactivado Nas trasversal.
                • Activdo DMZ y hacer una redirección hacía la IP del ordenador cliente.

                El router no tiene opción de:

                + Lista de ALGS

                Para descartivar: IKE, RTSM o SIP O poder desactivar IPSEC, por ejemplo.

                Alguna idea??

                Gracia!

                router-lowi.jpg
                • BocaDePez BocaDePez
                  "Ok, eso sí lo tenía claro. No sé por qué me establece…

                  "Ok, eso sí lo tenía claro. No sé por qué me establece conexión pero no me hace ping a ninguna máquina."

                  Eso suele suceder en OpenVPN cuando usas una configuración de compresión de datos diferente a la del servidor.

                  Revisa el parámetro compress o comp-lzo

                    • Si es OpenVPN, no debes tener problemas con este router, de…

                      Si es OpenVPN, no debes tener problemas con este router, de hecho con ese mismo router suelo conectarme al OpenVPN del trabajo y tengo cero problemas. Así que hay algo mal configurado por el lado del servidor.

                      Si aún con fallas consigues establecer una conexión con la VPN, entonces tienes conectividad a la VPN, con lo que ahí el router no puede filtrar absolutamente nada por ser tráfico encapsulado, con lo que el problema viene ya de algo interno de vuestra red. Comprueba en la consola de OpenVPN client si se está estableciendo correctamente todos los PUSH con las rutas, DNS y gateway. También fijate bien si las opciones que estás activando por parte del cliente están implementadas en el lado del servidor, si no, te van a dar problemas.

                      Sobre las opciones del router, ten activado NAT trasversal y deshabilita UPnP si no lo usas, ya que esta última opción es un problema de seguridad.

                • [Editado]

                  BocaDePez BocaDePez
                  Puede que si te conecta a la red remota y no te de ping, el…

                  Puede que si te conecta a la red remota y no te de ping, el firewall del equipo bloqueé paquetes icmp srgun el tipo de red que tengas, privada o publica.

                  Usa como gateway el de la red local asi podras navegar:

                  geeknetic.es/Noticia/10486/Como-usar-una…cal.amp.html

                  si no te conecta a la vpn revisa no sea que tanto cliente como servidor estén detrás de NAT:

                  support.zyxel.eu/hc/es/articles/360003503440