BandaAncha.eu

Comunidad de usuarios
de fibra, móvil y ADSL

Fibra

¿Podéis confirmarme si esto es CG-NAT o no?

Virutas

Hola,

Desde hace unas semanas tengo problemas para lanzar VPNs y me ha dado por hacer algunas comprobaciones y ya no estoy seguro si estoy en CG-NAT o no. He hecho un tracert a la IP pública. ¿Podéis confirmarme si estoy en CG-NAT o no?

cgnat.webp

Gracias!

BocaDePez
BocaDePez
2

Intentando averiguarlo desde un tracert puede llevar a error. La manera infalible de averiguarlo es viendo cual es la IP WAN que tiene asignada el router.

De todos modos, si no eres capaz de saber si tienes CG-NAT o no, es porque no lo necesitas y no vas a notar ninguna diferencia.

🗨️ 1
Virutas

He entrado al router y aparece esa misma IP del tracert:

ip-router.webp
vukits

como Moderador, veo que tu IP empieza por 188 y acaba en 193 …

igual que en las capturas…

i.e. NO estás detrás de CG-NAT.

¡disfruta!

🗨️ 1
Virutas

Ok, gracias por la ayuda!!!

BocaDePez
BocaDePez
1

Diría que no.

Las IP de rango 10.x.x.x las suelen usar las operadoras para sus routers internos.

En Vodafone es muy habitual pasar por varias 10.x.x.x e incluso al router te asignan dos IPs: la pública que es la que tienes y otra 10.x.x.x para cosas de Vodafone (por lo menos en HFC). Puede ser perfectamente la IP del router de la central de la que cuelgas.

Bajo CG-NAT, la IP que tendrías en el router (IP WAN o así suele poner) suele ser de tipo 100.64.x.x - 100.127.x.x y es la que aparece en el router (normal, al router le han asignado esa IP, seguramente el router desconozca con cual IP sale a internet, tendrías que comprobarlo en alguna web tipo cualesmiip).

🗨️ 1
Virutas

Lo que me descolocaba era la 10.x.x.x que comentas, por eso me he rayado pensando en lo de CG-NAT.

Curro1

Lo mejor es que pruebes a apagarle el IPv6 al router y lo reinicies, así sales de dudas.

A un amigo también le salían las IPs 10.x cuando estaba en CG-NAT, y también le salía aumentada la latencia al pasar por la máquina del CG-NAT (como pudiera ser tu caso).

Lo normal es que te salga la IP pública con <1ms siempre, no con varios milisegundos. Eso ya te da una pista de que hay un problema (que pudiera ser de otra cosa).

🗨️ 10
el-xalso

Las IPs 10.x no suelen ser de CG-NAT, esas son las 100.x

Las 10 suelen ser routers internos de la compañía por donde pasan tus paquetes.

Aquí una traza desde Vodafone HFC a google.es. Como puedes ver, paso por 5 routers con IP 10.x.x.x

Y no estoy en ningún CG-NAT ni nada

captura-pantalla-2020-07-12-12-23-03.webp
🗨️ 9
Curro1

Sí, tienes razón, cada ISP usará las 10.x para lo que consideren necesario.

En este caso comentaba que he llegado a ver en Jazztel indirecto una conexión a la que pasaban por la máquina de CG-NAT con una 10.x (y le lastraba bastante, estaba saturada), y luego ya no le salía la 10.x tras salir del CG-NAT. Con esto quiero indicar que sí pueden utilizarse para CG-NAT si el ISP quiere, sin darte una IP 100.x. Hablo de algo que he visto en persona. Vamos, que posible es, aunque sea raro de ver.

🗨️ 8
rbetancor

Las máquinas de CG-NAT no usan IP's privadas, PARA NADA, ni 10.x, ni 100.x … , lo que verías en ese caso de Jazztel que comentas, son diferentes rutas, en función de si salías o no por el CG-NAT … que además, que yo sepa, Jazztell no ha usado CG-NAT jamás.

🗨️ 7
Curro1
🗨️ 2
BocaDePez
BocaDePez
🗨️ 1
Curro1
el-xalso
🗨️ 3
rbetancor
1
🗨️ 2
Virutas
🗨️ 1
dj-niko

mi traceroute:

MacBook-Pro-Niko:~ niko$ traceroute 95.*.*.252
traceroute to 95.*.*.252 (95.*.*.252), 64 hops max, 52 byte packets
1 252.*.*.95.dynamic.jazztel.es (95.*.*.252) 2.252 ms 0.891 ms 0.883 ms
MacBook-Pro-Niko:~ niko$

Aqui tienes otro:

MacBook-Pro-Niko:~ niko$ traceroute 37.*.11.*
traceroute to 37.*.11.* (37.*.11.*), 64 hops max, 52 byte packets
1 *.11.*.37.dynamic.jazztel.es (37.*.11.**) 2.204 ms 0.951 ms 0.981 ms

El tuyo me parece bastante raro, los saltos.

🗨️ 7
Curro1

Aporto también el mío:

$ traceroute 90.94.*.*
traceroute to 90.94.*.* (90.94.*.*), 64 hops max
1   90.94.*.*  0,294ms  0,188ms  0,168ms

Lo habitual es que sólo salga el router y la IP pública, nada más. Con el firmware que le tengo puesto ahora al router Asus, ni siquiera sale ya 😂

Sale casi 0,3ms porque tengo bastante carga en la conexión ahora.

Y desde Windows 10:

tracert 90.94.*.*

Traza a la dirección ******.ddns.jazztel.es [90.94.*.*]
sobre un máximo de 30 saltos:

  1     <1 ms    <1 ms    <1 ms  ******.ddns.jazztel.es [90.94.*.*]

Traza completa.
🗨️ 6
rbetancor

No des "por normal", algo que no lo es … para que te conteste tu router cuando haces un tracert desde dentro, este ha de soportar NAT-Loopback, además de que depende de la configuración de cortafuegos del router, sino obtendrás un bonito "tiempo de espera agotado"

🗨️ 1
Curro1

OK, gracias.

Virutas

¿El firmware es el último de Jazztel?

🗨️ 3
Curro1

No, hablaba del firmware Merlin para el Asus que utilizo. Lo indico arriba para no crear confusión, gracias por avisar.

Como router uso un Asus RT-AC68U conectado al ONT ZTE F601, y va muy bien.

El router ZTE h298n sólo lo tengo para el teléfono y gestión de la DDNS de Jazztel tras el Asus, pero lo he llegado a conectar alguna vez directamente al ONT para que se actualice su firmware automáticamente, y he visto lo del CG-NAT con él, y que deshabilitándole el IPv6 salía del CG-NAT de inmediato.

🗨️ 2
BocaDePez
BocaDePez
🗨️ 1
Curro1