Banda Ancha EU

Comunidad de usuarios
de fibra, móvil y ADSL

Fibra

Pfsense O2 no pasa de 90 Mbps con los 300 megas

BocaDePez
BocaDePez

Hola, tengo O2 o movistar que al caso es lo mismo.

He puesto el router the O2/movistar en modo bridge y conectado a pfsense, en pfsense configuro el PPPoE con usuario y contraseña, si le asigno la vlan6 no me va, pero simplemente con configurar el PPoE si.

El único problema es que la prueba de velocidad me va a 85/90 Mbps y si configuro el router the O2/Movistar en modo normal me las velocidades que me dan son de 300/300.

Cual puede ser el problema? de HW no es, tiene 6 nucleos asignados y la CPU practicamente no sube, además de 3 GB de RAM asignados.

Que puede estar impidiendo que cuando lo ponga a través de pfsense no me llegue a la máxima velocidad? antes tenía Orange y con pfsense me hacia lo 100/100 y ahora no pasa de 85/90

BocaDePez
BocaDePez

Es una VM? Prueba de meterle otra tarjeta de red.

BocaDePez
BocaDePez

VirtIO + 64 bits.

Y no necesitas 6 núcleos ni de lejos. En virtualización más de 2 núcleos casi siempre significa peor rendimiento.

🗨️ 3
BocaDePez
BocaDePez

No tienes muy claro los conceptos.

🗨️ 1
BocaDePez
BocaDePez

Por favor, explícate.

BocaDePez
BocaDePez

Estoy haciendo passthrough de 2 NiCs de Intel, que es mucho mejor

BocaDePez
BocaDePez

En el poor no estas poniendo la mtu a 1492

🗨️ 3
BocaDePez
BocaDePez

PPPoE , mtu 1492

🗨️ 2
BocaDePez
BocaDePez

pfsense configura la MTU correctamente.

Y los problemas de MTU no se manifiestan con velocidades bajas, sino con cosas que cargan y otras que no, o sesiones TCP que se paran por completo.

🗨️ 1
BocaDePez
BocaDePez

Y si pierdes muchos paquetes la descarga en un test parecerá que la velocidad es baja.

BocaDePez
BocaDePez
1

Yo también uso pfsense con movistar 600 y sin problemas. Lo tengo en una VM con 2 cores y 512 de ram, y me alcanza sin problemas los 600/600, incluso con el pfblocker ng.

Lo de la VLAN 6, si tienes un HGU, es normal que no tengas que etiquetar en la interfaz del pfsense.

Lo que te recomiendo para pfsense si lo tienes virtualizado, utiliza VirtIO en KVM o vmxnet en esxi para las interfaces de red. Y desactiva todas las funciones de aceleración HW de la tarjeta de red del pfsesnse (system > advanced > networking > network interfaces TODO EN OFF) aunque suene contrasentido.

🗨️ 1
BocaDePez
BocaDePez

Estoy haciendo passthrough de las 2 NICs de todos modos al final he tenido que desabilitar el checksum offloading, el resto está por defecto

BocaDePez
BocaDePez
1

Gracias a todos, al final el problema era que la LAN me estaba sincronizado a 100 Mbps, por algún misterio.

Al final lo he arreglado cambiando el cable porque cuando forzaba 1Gbps ente la tarjeta el el switch todas las luces se apagaban, luego he tenido que desabilitar el checksum offload porque estaba forzando a la LAN a syncronizar a 100 Mbps

Ahora está funcionado como debe.

Debería poner el mtu en 1492 o dejándolo en blanco se configura bien?

Me gustaría reemplazar el router por una ONT, cuál estais utilizando vosotros? Qué cosas hay que configurar?

BocaDePez
BocaDePez

¿Y no es más fácil (y económico en consumo) pillarse un Edgerouter Lite o un Mikrotik hEX?

🗨️ 2
BocaDePez
BocaDePez

Más económico que pfsense? xD

O no has entendido la pregunta o no sabes de que estás hablando.

🗨️ 1
BocaDePez
BocaDePez
1

No creo que esas sean formas de contestar a la gente que intenta ayudar.

pfSense puede ser gratis pero el equipo sobre el que lo montas (6 núcleos y 3GB de RAM) va a consumir más electricidad que un sistema dedicado como los que vende Mikrotik.

Así que lo que te ahorras en licencias lo acabas pagando con el tiempo en la factura de la luz.