Banda Ancha EU

Comunidad de usuarios
de fibra, móvil y ADSL

Fibra/Cable

Perdida de paquetes

BocaDePez
BocaDePez

Buenas noches.

Tengo un problema desde hace tiempo con los juegos p2p en xbox (ahora tengo la one antes la 360)

El fabricante del juego me recomendó hacer un tracer con uo tracer y me he dado cuenta que tengo un host que me pierde paquetes. Además bastantes. un 60% es el 10.254.9.193.

A ver si me podeis ayudar en que puedo hacer para resolver esa perdida... llamando a ONO que es mi ISP me dicen que ellos no puede hacer absolutamente nada... mal empezamos.

Gracias de antemano.

ivimail

un tracert puede no darte respuesta en algun punto y no significa que pierdas paquetes. puede ser que ese salto en concreto forme parte de una ruta dinamica y que unas veces responda el servidor y otras no. en cualquier caso comprueba si pierdes paquetes directamente con el host de destino, usando ping -t direccion_del_host

C:\>ping -t bandaancha.eu

Haciendo ping a bandaancha.eu [89.248.106.100] con 32 bytes de datos:
Respuesta desde 89.248.106.100: bytes=32 tiempo=16ms TTL=55
Respuesta desde 89.248.106.100: bytes=32 tiempo=16ms TTL=55
Respuesta desde 89.248.106.100: bytes=32 tiempo=16ms TTL=55
Respuesta desde 89.248.106.100: bytes=32 tiempo=17ms TTL=55
Respuesta desde 89.248.106.100: bytes=32 tiempo=17ms TTL=55
Respuesta desde 89.248.106.100: bytes=32 tiempo=17ms TTL=55
Respuesta desde 89.248.106.100: bytes=32 tiempo=17ms TTL=55
Respuesta desde 89.248.106.100: bytes=32 tiempo=17ms TTL=55
Respuesta desde 89.248.106.100: bytes=32 tiempo=18ms TTL=55
Respuesta desde 89.248.106.100: bytes=32 tiempo=17ms TTL=55
Respuesta desde 89.248.106.100: bytes=32 tiempo=18ms TTL=55
Respuesta desde 89.248.106.100: bytes=32 tiempo=17ms TTL=55
Respuesta desde 89.248.106.100: bytes=32 tiempo=17ms TTL=55
Respuesta desde 89.248.106.100: bytes=32 tiempo=17ms TTL=55
Respuesta desde 89.248.106.100: bytes=32 tiempo=17ms TTL=55
Respuesta desde 89.248.106.100: bytes=32 tiempo=17ms TTL=55
Respuesta desde 89.248.106.100: bytes=32 tiempo=17ms TTL=55
Respuesta desde 89.248.106.100: bytes=32 tiempo=17ms TTL=55

Estadísticas de ping para 89.248.106.100:
Paquetes: enviados = 18, recibidos = 18, perdidos = 0 (0% perdidos),
Tiempos aproximados de ida y vuelta en milisegundos:
    Mínimo = 16ms, Máximo = 18ms, Media = 16ms
txuspe

¿En la traza observas pérdida de paquetes en ese host o en todos a partir de ese? Si solamente los pierde ese, suele ser porque se da muy baja prioridad a este tipo de paquetes. Si se pierden en todos los hosts a partir de ese, entonces podría haber un problema.

🗨️ 1
BocaDePez
BocaDePez
-1

A mi esa ip en concreto también me pierde el 63% de los ping, lo que ya no se es si es normal por su configuración o no.

BocaDePez
BocaDePez

no será el bf4 que tienes perdida de paquete

BocaDePez
BocaDePez

Soy el creador del hilo.

Gracias a todos por vuestras respuestas e interes.

Os explico más detalladamente por si alguien puede iluminarme, y como sé que algún técnico de ONO hay por aquí, pues a ver si me pueden ayudar.

El problema que tengo se me da solo y exclusivamente en juegos que utilizan el protocolo p2p donde uno hace de anfitrion y otro se conecta a este otro usuario para poder jugar. El que más uso es FIFA.

Otros juegos tipo Battelfield o CoD donde el juego tiene un servidor donde se aloja la partida, no me dan ningun tipo de problema.

He probado mil y una cosas (configuraciones de router, incluso ponerlo a cablemodem, llamadas a ONO a Microsoft y Electronics Arts)... hasta que me decidi a hacer una prueba con la consola en casa de un amigo con fibra de telefónica y la consola iba perfectamente. Nada que ver con lo que me pasa en casa.

Una vez llegado a la conclusión de que el problema solo se da en mi casa y por tanto es la conexion a internet lo que lo provoca, llamé para que me miraran todo lo que fuera posible para dar con la "avería"... No conseguí nada excepto descuentos y visitas de técnicos que cambiaron toda la instalación dentro de mi casa, mi router etc etc etc...

La impresión que tengo es que mi conexión desprioriza cierto tipos de datos y eso provoca ese retraso en el juego... a ciertas horas del día debe haber un colpaso importante (ya que la velocidad de descarga hay veces que se ve afectada) y debe pasar algo como lo que alguien me escribió aquí:

"El problema de usar IPv6 en entornos IPv4 y que el "parche" de usar Teredo encapsule paquetes TCPv6 en paquetes UDPv4 es que los datagramas UDP no están orientados a conexión. Ono podría tener packet-shapers que no diesen excesiva prioridad a paquetes UDP, de ahí los retardos observados. No estamos hablando de que los cape, puesto que llegar, llegan los paquetes... pero podría no tratarlos al mismo nivel que el tráfico TCP."

Este forero escribió esto en contestación aun escrito que me pasó Microsoft, del funcionamiento de los juegos que utilizan protocolo p2p. Si quereis verlo integro está aquí. Problemas Xbox One - Technical information on P2P Networking Behavior

Obviamente esto es una suposición y es algo que tendrían que aclarar desde Ingeniería de Red en Ono... incluso sería posible que el fallo fuese de la zona y no global del proveedor.

Gracias y saludos.

BocaDePez
BocaDePez

Soy el autor del hilo.

Adjunto tracer:

* Unknown Host * 10.254.1.149 4 11ms 16ms 71% 29 / 100 10ms / 37ms
* Unknown Host * 10.254.11.249 5 18ms 23ms 17% 83 / 100 17ms / 87ms

* Unknown Host * 10.254.11.218 6 18ms 19ms 0% 100 / 100 17ms / 94ms
xe-5-1-4-xcr1.max.cw.net 213.38.241.229 7 23ms 24ms 0% 100 / 100 18ms / 130ms
ae5-xcr1.mad.cw.net 195.2.30.57 8 19ms 24ms 0% 100 / 100 17ms / 81ms
* Unknown Host * 195.2.9.122 9 18ms 24ms 0% 100 / 100 18ms / 85ms
ae7-xcr1.lsw.cw.net 195.2.10.25 10 58ms 60ms 0% 100 / 100 54ms / 98ms
ae2-xcr1.lnt.cw.net 195.2.30.54 11 53ms 54ms 0% 100 / 100 51ms / 75ms
* Unknown Host * 0.0.0.0 12 0ms
unknown.prolexic.com 72.52.60.35 13 50ms 51ms 1% 99 / 100 49ms / 60ms
* Unknown Host * 0.0.0.0 14 0ms
unknown.prolexic.com 209.200.168.132 15 125ms 127ms 0% 100 / 100 124ms / 170ms
* Unknown Host * 159.153.93.2 16 124ms 100% 0 / 100
* Unknown Host * 159.153.225.30 17 123ms 126ms 0% 99 / 99 120ms / 241ms
meav5-pub.pt.iad.ea.com 159.153.226.105 18 120ms 121ms 0% 99 / 99 119ms / 149ms

Como veis hay dos que tengo muchisima perdida de datos... Necesito saber que puedo hacer.

Gracias, y saludos,.

🗨️ 14
yomimmo

Yo no veo perdida de datos por ningún sitio, veo puntos de ruta que no responden a paquetes ICMP, ni es lo mismo ni se le parece.

🗨️ 13
txuspe

+1

BocaDePez
BocaDePez

Estonces ese descarto que sea el problema de que tengo problemas al jugar online no?

🗨️ 11
yomimmo

Mas de 120 ms para jugar online son muchos, suponiendo que ese sea el servidor del juego y no la pagina donde se aloja el frontend del jugo (login, descargas de actualizaciones etc)

djnacho

Es un problema de peering entre la propia cw y entre cw y los servidores de EA.
Aquí tienes mi tracert a la misma dirección que haces tu tracert:

C:\Users\Nacho>tracert meav5-pub.pt.iad.ea.com
Traza a la dirección meav5-pub.pt.iad.ea.com [159.153.226.105]
sobre un máximo de 30 saltos:
  1    <1 ms    <1 ms    <1 ms  192.168.1.1
  2     7 ms     4 ms     6 ms  10.232.64.1
  3    11 ms     6 ms     6 ms  10.239.240.69
  4    17 ms    12 ms    14 ms  10.239.240.46
  5    24 ms    14 ms    10 ms  10.239.240.185
  6     *       12 ms    38 ms  10.254.2.153
  7    16 ms    12 ms    13 ms  10.254.11.214
  8    14 ms    12 ms    14 ms  xe-5-1-4-xcr1.max.cw.net [213.38.241.229]
  9    55 ms    45 ms    46 ms  ae5-xcr1.mad.cw.net [195.2.30.57]
 10    56 ms    48 ms    59 ms  195.2.9.122
 11    43 ms    46 ms    42 ms  ae7-xcr1.lsw.cw.net [195.2.10.25]
 12    47 ms    45 ms    49 ms  ae2-xcr1.lnt.cw.net [195.2.30.54]
 13     *        *        *     Tiempo de espera agotado para esta solicitud.
 14    42 ms    37 ms    36 ms  unknown.prolexic.com [72.52.60.35]
 15     *        *        *     Tiempo de espera agotado para esta solicitud.
 16   113 ms   115 ms   113 ms  unknown.prolexic.com [209.200.168.132]
 17   154 ms   116 ms   124 ms  159.153.93.2
 18   114 ms   120 ms   116 ms  159.153.225.30
 19   115 ms   116 ms   118 ms  meav5-pub.pt.iad.ea.com [159.153.226.105]
Traza completa.

Como ves las cosas empiezan a ir mal dentro de la propia cw (es un carrier de internet) entre los saltos 8 y 9 (pasamos de 14 a 55 ms, y eso que no hemos salido aún de España)
Pero aún va peor cuando salimos de cw para entrar a la red de Akamai (prolexic es un servicio de akamai para evitar ataques de todo tipo a servidores). Los servidores de EA se encuentran detrás de ese "muro", y el tiempo se acumula de 40 o 50 ms a 115 ms. Como ves, no es cosa de tu conexión. Hay dos problemas, con dos carriers (cw y akamai).

Un saludo :)

🗨️ 9
BocaDePez
BocaDePez
🗨️ 1
djnacho
dnight
🗨️ 1
djnacho
txuspe
🗨️ 4
djnacho
🗨️ 3
txuspe
🗨️ 2
djnacho
🗨️ 1
txuspe