BandaAncha.eu

Comunidad de usuarios
de fibra, móvil y ADSL

ADSL

No puedo conectar con mi VPN desde la red móvil, pero si por WiFi

BocaDePez
BocaDePez

En la empresa tenemos móviles con Pepephone. En mi casa acabo de poner la fibra 300 de Pepephone y ya me han dado una IP pública (Estaba detrás del CG-NAT).

Me pusieron un ZTE F680 éste no tiene para configurar una VPN, y configuré la DMZ para dirigir todo el tráfico a un router Asus RT-AC87U el cual con Ono tenía configurada una VPN para poderme conectar a todos los servicios que tengo montados en casa (Servidor TV, archivos, línea backup etc)

El problema es que desde la red de telefonía móvil no me puedo conectar a la VPN, si miro el registro del Asus me pone:

Sep 20 12:10:04 pptp[2648]: pppd 2.4.7 started by VPNUser, uid 0
Sep 20 12:10:04 pptp[2648]: Connect: ppp10 <--> pptp (176.83.xxx.xxx)
Sep 20 12:10:34 pptp[2648]: LCP: timeout sending Config-Requests
Sep 20 12:10:34 pptp[2648]: Connection terminated.
Sep 20 12:10:34 pptp[2648]: Modem hangup
Sep 20 12:10:34 pptpd[2647]: CTRL: EOF or bad error reading ctrl packet length.
Sep 20 12:10:34 pptpd[2647]: CTRL: couldn't read packet header (exit)
Sep 20 12:10:34 pptpd[2647]: CTRL: Fatal error reading control message in disconnect sequence

En cambio si con el móvil me conecto a través de qualquier wifi no tengo problemas para conectar a la VPN, escribí con esto a la operadora y no he recibido respuesta, ¿sabéis si en mi mano está la solución? Yo creo que es cosa de la operadora y no tanto de mi red doméstica.

BocaDePez
BocaDePez

Hola,

Has probado a dejar el router de fibra en modo brigde y dejar el asus como router?

He tenido fibra con movistar y lo tenia así.

🗨️ 2
BocaDePez
BocaDePez

Hola, gracias por contestar, así lo tenía antes con Ono, el problema del router que me han dado es que no se puede configurar el modo brige (o no lo he encontrado en google) y tampoco configurar una VPN

🗨️ 1
nightsking

Lastima, puedes probar a sustituir el ZTE por una ONT de segunda mano....

vukits

no entiendo por qué no estás usando OpenVPN en el Asus..

rbetancor

Tiene pinta de problema de fragmentación de paquetes. Tendrás que usar un protocolo que te permita controlar eso, el pptp, sino ajustas correctamente los valores en el cliente ... estás puteado, como atravieses algún router que tenga fragmentación. Cosa bastante habitual en las redes móviles.

🗨️ 7
pepejil

Yo he tenido Pepephone bajo la red de Movistar (vamos, lo que hay ahora mismo) y bajo OpenVPN y L2TP/IPSec, funcionaba perfectamente en su 4G.

Así que apuesto que algo deben tener mal configurado en el servidor VPN.

🗨️ 6
rbetancor
1

OpenVPN tiene parámetros que puedes ajustar para controlar la fragmentación, IPSec, tres cuartos ... pero PPPTP, es una castaña de M$ que fue diseñada pensando en el RAS de NT Server ... y que es probable que la implementación del Asus no esté gestionando bien el reensamblado de los paquetes, usando redes móviles vas a tener fragmentación, sí o sí ... por huevos

🗨️ 5
pepejil
1

Aún así, usar PPTP a estas alturas de siglo, es tenerlos cuadrados.

🗨️ 2
rbetancor
1
🗨️ 1
pepejil
BocaDePez
BocaDePez

Me pasa lo mismo con las redes 3G

Cuando hablas de ajustar la fragmentación, ¿te refieres al valor de MTU? ¿Cual seria el correcto para poder usar el vpn por wifi y 3G?

🗨️ 1
vukits
pepejil

¿Que tipo de VPN usas? Bajo Pepephone he llegado a hacer funcionar dos sistemas de VPN sin problemas (OpenVPN y L2TP/IPSec).

Mira a ver que configuración tienes metida en el VPN server.

BocaDePez
BocaDePez
1

jaja muchísimas gracias por vuestras respuestas, como mucho soy el friki y el primo que arregla quatro cosas de los ordenadores, me habéis abierto camino y con OpenVPN no he tenido problemas en configurar y conectar una VPN, el único problema es que no me mapea las unidades y carpetas compartidas del servidor, voy a investigar y mirar de aprender probando cosas a ver si lo puedo solucionar, también probaré con el protocolo L2TP/ISec, de nuevo muchas gracias a todos.

🗨️ 1
BocaDePez
BocaDePez
1

ya me mapea las unidades y carpetas compartidas, la solución radicaba en crear reglas en el firewall del servidor que monta un windows 10, hay que poner el rango de ip's asignadas por el OpenVPN del router Asus, sería 10.8.0.0/24 (en mi caso no coincide con el rango de ip's fijas internas que tengo configurado), y reglas de entrada y salida de todos los puertos.

Lo escribo por si a alguien le es de ayuda, saludos y gracias de nuevo. también recuerdo que los problemas los tenía con el smartphone con Android 6.0.1

BocaDePez
BocaDePez

Buenos días,

Yo con este problema también, con un router Asus detrás de un F680 de MasMovil. Pero el problema no es de los router, son las líneas móviles de MasMovil, desde cualquier otro movil que son sean una de mis líneas conecto por PPTP a la primera. Me volví loco hasta que probé con el teléfono del trabajo ( Orange), no he probado por OpenVPN, pero probare haber que pasa. Lo que esta claro es que MasMovil tiene un problema con las líneas móviles. Un saludo y gracias.