BandaAncha.eu

  • 🔍 en 📰 artículos ⏎
  • 🔍 en 💬 foros ⏎
  • 🔍 en 👇 este 💬 foro ⏎
  • 🔍 en 👇 este 💬 tema ⏎
Regístrate Regístrate Identifícate Identifícate

Pensando en pasar de O2 a Digi NEBA con dudas sobre router, VoIP, CG-NAT y capado datos móviles

Neophyte X360

Veo muchos post acerca de todas estas preguntas pero en ninguna veo nada que deje claro mis cuestiones. Sé que gente ha podido cambiar el router, pero tampoco hay mucha info acerca del VoIP y si es posible sacar los datos a dia de hoy con los firmwares nuevos, el cual necesito.

Estaba valorando el cambio puesto que va a ser una conexión que no se va a usar extremadamente para cosas "importantes" y si se puede ahorrar algo y el servicio es "bueno" me vale. Aquí dejo algunas cuestiones que me interesan a ver si alguien lo tiene así:

En mi zona solo hay NEBA, por lo que la red sigue siendo Movistar.

  • Router: Usar ONT + Router propio, ¿es posible sin complicaciones? ¿Digi proporciona los datos necesarios o se pueden sacar de manera fácil? En mi caso tengo una ONT Nokia y un Mikrotik RB4011, si es así, ¿en NEBA las VLAN son las mismas que Movistar?
  • VoIP: ¿Es posible usar el VoIP con router propio? (igual, ¿Digi proporciona los datos y se pueden usar fácilmente? Tengo un SPA112 y sí se va a usar el fijo bastante, por lo que esto sería imprescindible poder usarlo con el Mikrotik. No se si alguien lo ha conseguido, en O2 lo tengo funcionando sin problemas. Actualmente ¿alguien ha sacado los datos del SIP del router, o Digi se los ha dado por teléfono?
  • CG-NAT: ¿En un principio te meten en CG-NAT y hay que solicitar el cambio a IP propia? ¿o al ser NEBA va sin CG-NAT?
  • DATOS: Los datos móviles Ilimitodo ¿se sabe cual es el límite real del uso de la conexión para evitar el abuso?
  • 5G: ¿Alguno ha cogido o llegado a coger 5G?
  • STREAMING: Y por último, el capado del streaming en la red móvil, ¿se puede pedir que te lo desactiven y no se vuelva a activar solo?
Solospam
1

Router: Usar ONT + Router propio, es posible sin complicaciones? Digi proporciona los datos necesarios o se pueden sacar de manera fácil? En mi caso tengo una ONT Nokia y un Mikrotik RB4011, si es así, en NEBA las VLAN son las mismas que Movistar?

Los datos para configurar tu mikrotik te los dan sin problema

VoIP: Es posible usar el VoIP con router propio? (igual, Digi proporciona los datos y se pueden usar facilmente?, Tengo un SPA112 y sí se va a usar el fijo bastante, por lo que esto sería imprescindible poder usarlo con el mikrotik, no se si alguien lo ha conseguido, en O2 lo tengo funcionando sin problemas). Actualmente alguien ha sacado los datos del SIP del router, o Digi se los ha dado por telefono?

Hasta donde yo se no te facilitan los datos sip, la forma de conseguir mantener el teléfono es convertir tu mikrotik en proveedor de ethernet en etherX y conectar a esa boca el router de Digi para tener teléfono

CG-NAT: En un principio te meten en CG-NAT y hay que solicitar el cambio a IP propia? o al ser NEBA va sin CG-NAT?

Tienes que pagar un euro más para salir de CG-NAT, básico para poder usar VPN

Del resto de preguntas no te puedo indicar

Saludos

🗨️ 10
Neophyte X360

El tema VoIP con el mikrotik y detrás el router Digi, se puede con todos los router que proporcionan o solo con algunos? Es posible entrar como admin a los routers o los han "capado"?

🗨️ 9
Solospam

Yo te hablo de lo que leo por ahí, los datos sip no hay forma conocida de levantarlos, y la solución que más resuena en foros de mikrotik es poner el mikrotik de servidor de internet y el router de Digi de cliente, de esa forma el router de Digi piensa que está conectado directamente y el teléfono funciona.

Yo lo que tengo montado es o2 con un 4011 también

Saludos

vukits

El tema VoIP con el mikrotik y detrás el router Digi, se puede con todos los router que proporcionan o solo con algunos? Es posible entrar como admin a los routers o los han "capado"?

se puede hacer… pero no está documentado…

de partida, NO cuentes con que te va a funcionar el SIP con router propio. Lo digo para que no te lleves un chasco

🗨️ 7
Neophyte X360

Bueno, en verdad con que me pueda funcionar levantando un servidor PPPoE y poner detrás el de Digi me valdría, aunque tendría que estar seguro que funciona antes de cambiar nada

🗨️ 6
Solospam
🗨️ 5
vukits
🗨️ 4
Solospam
🗨️ 3
sudokun
🗨️ 2
Solospam
1
🗨️ 1
sudokun
Weikis

Puedes montarte un servidor SIP y enchufar el router de Digi para que valide la conexión.

Weikis

Ya no hay capado de streaming. No hay 5G en Digi ni tampoco VoLTE ni VoWiFi.

Ikaro1968

La VLAN que usan en NEBA es la 20/0. Y si quieres que te saquen del CG-NAT tienes que pagar 1€/mes suplementario.

BocaDePez
BocaDePez

Soy el que abrió el post.

Definitivamente me cambié a Digi. Hoy he recibido las SIM. (ya tengo el router y ONT en casa a la espera de la portabilidad). Sabeis cuanto suelen tardar desde que se reciben las tarjetas?

Como tengo el mikrotik, ya iré comentando si puedo definitivamente poner el servidor PPPoE con el router de Digi detrás para tener el VoIP. Si veo que funciona bien ya me curraré algun manual o aunque sea un post

BocaDePez
BocaDePez

Estoy exactamente en tu mismo caso y acabo de solicitar la portabilidad (O2 → Digi). Ahora que la permanencia es de sólo tres meses quiero probar (son unos euros menos al mes y algún giga más). Iré contando…

BocaDePez
BocaDePez
3

Soy el mismo que creó el post. Ya tengo Digi, y tengo todo funcionando, inclusive el VoIP.

Actualmente uso un Mikrotik RB4011 y el Zte de Digi conectado detrás para el VoIP. Para los teléfonos he usado la config que mandó un compañero mas arriba:

  1. En Interfaces→VLAN→Add New crea una nueva VLAN con VLAN ID 20 e interface, el puerto donde vayas a conectar el router (yo lo tenía conectado en el puerto ether5, separado del bridge de LAN).
    • Name: vlan_router_digi
    • VLAN ID: 20
    • Interface: ether5 (En este caso yo he puesto directamente Bridge para poderlo conectar a cualquier puerto)
  2. En IP→Pool→Add New creamos un pool de direcciones para el servidor
    • Name: pool_pppoe_server
    • Addresses: 10.0.1.200-10.0.1.250
  3. Crear servidor PPP, en PPP→Profiles→Add new creas un nuevo perfil
    • Name: pppoe_server_digi
    • Local Address: 10.0.1.1
    • Remote Address: pool_pppoe_server (el de antes)
  4. PPP→Secrets→Add new vamos a añadir el user/passwd
    • Name: *******@digi (el usuario)
    • Password: ********* (la clave)
    • Service: PPPoE
    • Profile: pppoe_server_digi (el de antes)
  5. Crear servidor final, PPP→PPPoE Servers→Add New
    • Service Name: servicio_router_digi
    • Interface: vlan_router_digi (el primero que creamos, seleccionar de la lista)
    • Default Profile: pppoe_server_digi (el último que hemos creado, seleccionar de la lista)

Importante para saber que el Zte conecta al mikrotik: "Después de conectar el router Digi deberías ver aparecer una nueva conexión de tipo "PPPoE Server Binding" en la lista de Interfaces"

Haciendo todo al pie de la letra, funcionando sin problemas, Al principio no funcionaba (supongo que por ser portabilidad nueva), por lo que conectado el Zte directamente a la ONT he reseteado hasta que funcionase el tlf, luego he cambiado los cables como estaban y voilá, hacer y recibir llamadas sin problemas.

Saludos y espero que a alguien le sirva para la próxima (o mejor, a ver si Digi empieza a dar ya los datos SIP)

La config que usé en el mikrotik (encontrada en otro foro, gracias al usuario que la colgó). Poned vuestra mac en las primeras líneas y pegar en la consola:

/interface bridge
add admin-mac=XX:XX:XX:XX:XX:XX auto-mac=no comment=defconf name=bridge \
    protocol-mode=none
/interface vlan
add interface=ether1 name=vlan20 vlan-id=20
/interface pppoe-client
add add-default-route=yes disabled=no interface=vlan20 name=pppoe-out1 \
    use-peer-dns=yes user=XXXXXXXXX@digi
/interface list
add comment=defconf name=WAN
add comment=defconf name=LAN
/interface wireless security-profiles
set [ find default=yes ] supplicant-identity=MikroTik
/ip pool
add name=dhcp ranges=10.10.2.10-10.10.2.254
add name=vpn ranges=192.168.89.2-192.168.89.255
/ip dhcp-server
add address-pool=dhcp disabled=no interface=bridge name=defconf
/ppp profile
set *FFFFFFFE local-address=192.168.89.1 remote-address=vpn
/interface bridge port
add bridge=bridge comment=defconf interface=ether2
add bridge=bridge comment=defconf interface=ether3
add bridge=bridge comment=defconf interface=ether4
add bridge=bridge comment=defconf interface=ether5
/ip neighbor discovery-settings
set discover-interface-list=LAN
/interface l2tp-server server
set enabled=yes use-ipsec=yes
/interface list member
add comment=defconf interface=bridge list=LAN
add comment=defconf interface=ether1 list=WAN
add interface=pppoe-out1 list=WAN
/interface pptp-server server
set enabled=yes
/interface sstp-server server
set default-profile=default-encryption enabled=yes
/ip address
add address=10.10.2.1/24 comment=defconf interface=bridge network=10.10.2.0
/ip cloud
set ddns-enabled=yes
/ip dhcp-client
add comment=defconf interface=ether1
/ip dhcp-server network
add address=10.10.2.0/24 comment=defconf gateway=10.10.2.1 netmask=24
/ip dns
set allow-remote-requests=yes servers=8.8.8.8,8.8.4.4
/ip dns static
add address=10.10.2.1 comment=defconf name=router.lan
/ip firewall filter
add action=accept chain=input comment=\
    "defconf: accept established,related,untracked" connection-state=\
    established,related,untracked
add action=accept chain=input comment="allow IPsec NAT" dst-port=4500 \
    protocol=udp
add action=accept chain=input comment="allow IKE" dst-port=500 protocol=udp
add action=accept chain=input comment="allow l2tp" dst-port=1701 protocol=udp
add action=accept chain=input comment="allow pptp" dst-port=1723 protocol=tcp
add action=accept chain=input comment="allow sstp" dst-port=443 protocol=tcp
add action=drop chain=input comment="defconf: drop invalid" connection-state=\
    invalid
add action=accept chain=input comment="defconf: accept ICMP" protocol=icmp
add action=accept chain=input comment=\
    "defconf: accept to local loopback (for CAPsMAN)" dst-address=127.0.0.1
add action=drop chain=input comment="defconf: drop all not coming from LAN" \
    in-interface-list=!LAN
add action=accept chain=forward comment="defconf: accept in ipsec policy" \
    ipsec-policy=in,ipsec
add action=accept chain=forward comment="defconf: accept out ipsec policy" \
    ipsec-policy=out,ipsec
add action=fasttrack-connection chain=forward comment="defconf: fasttrack" \
    connection-state=established,related
add action=accept chain=forward comment=\
    "defconf: accept established,related, untracked" connection-state=\
    established,related,untracked
add action=drop chain=forward comment="defconf: drop invalid" \
    connection-state=invalid
add action=drop chain=forward comment=\
    "defconf: drop all from WAN not DSTNATed" connection-nat-state=!dstnat \
    connection-state=new in-interface-list=WAN
/ip firewall nat
add action=masquerade chain=srcnat out-interface=pppoe-out1
add action=dst-nat chain=dstnat dst-port=5000,5001 in-interface=pppoe-out1 \
    protocol=tcp to-addresses=10.10.2.50 to-ports=5000-5001
add action=dst-nat chain=dstnat dst-port=80 in-interface=pppoe-out1 protocol=\
    tcp to-addresses=10.10.2.50 to-ports=80
/ppp secret
add name=vpn
/system clock
set time-zone-name=Europe/Madrid
/tool mac-server
set allowed-interface-list=LAN
/tool mac-server mac-winbox
set allowed-interface-list=LAN
🗨️ 12
vukits

Magnifico.

Muchisimas gracias por el código.

Lo enlazo en el F.A.Q y pondré nota corta en portada.

Tech
1

He seguido los mismos pasos con un Zyxel pero no llega a funcionar el teléfono.

Hay sincronía, incluso puedo navegar, pero no funciona el teléfono.

Sin embargo si lo conecto directamente a la ONT si

Dexter91tracker

Buenas!

He probado la configuración para la VoIP y no me funciona, puedo navegar a través del router pero no conectala VoIP. ¿Te sigue funcionando? O han cambiado algún parametro Digi.

Tapion1985

@BocaDePez quiero usar VoWiFi con Digi y parece que la unica solución factible de momento hasta que lo habiliten oficialmente es comprar un Router Mikrotik RB4011 y hacer la configuración que comentas, me puedes confirmar si sigu funcionando para plantear comprear el router y probar?

🗨️ 8
superllo

BocaDePez murió hace tiempo.

🗨️ 2
Tapion1985

Vaya, espero que no sea literal, ¿Alguien mas ha conseguido tener VoWiFi con Digi?

🗨️ 1
pepejil

No es lo mismo VoIP que VoWiFi.

Partiendo de esa base, si conectas un servidor SIP desde tu móvil será exclusivamente para llamadas desde/al fijo, eso si Digi te deja.

🗨️ 4
Tapion1985

Lo que yo quiero es VoWiFi, es decir que pueda mejorar la calidad de mis llamadas desde el movil en vez de con la cobertura movil con mi red WiFi de casa, eso entiendo que a dia de hoy Digi no lo permite, lo que no se si de alguna manera se puede conseguir o hay que cambiarse de proveedor de servicios.

🗨️ 3
kaleth
pepejil
Akel0ver

Muchas gracias.

Quiero jubilar AE9000 y con esta guía podre utilizar el fijo que no se lo puedo quitar a mis padres.

Están desplegando red propia en Cornellà y mi calle hay en la acera de enfrente

BocaDePez
BocaDePez
1

Esto está bien, pero ahora hay 3 cacharros que enchufar…

BocaDePez
BocaDePez

Los mismos que si tienes ONT+Router+SIP

DDrDark

Disculpa, la ONT de Alcatel funciona con Digi o necesitas otra? Los datos para la ONT te los han dado sin problema? Es PPPoE o otro tipo de conexión? He buscado en su web pero no veo información sobre la configuración.

Muchas gracias!

🗨️ 1
pepe75

Hola BocaDePez yo estoy en Digi tambien esa configuracion te sigue funcionando es que me voy a comprar el MicroTik hAP ac3 y me gustaria estar seguro.Gracias

BocaDePez
BocaDePez

El router de los 10GB de fibra Pro-Digi tiene ONT incorporada,y todos los conectores del router Digi de 1GB.

🗨️ 1
Aokromes

el router de 10 Gbps de Digi tiene 1 boca de 10 Gbps.

ElSisso

buenas, este metodo aun funciona?

🗨️ 2
Neophyte

Yo lo sigo teniendo funcionando

🗨️ 1
txintxigorri

Sabéis si funciona en otros operadores? Igual me animo a pillar un Mikrotik y colgarle el SERCOM H500s como caja de voz.

Migueldeblas

Alguien que haya realizado la configuración del RP-PPPoE server con OpenWrt y Digi?

ordenator

Este tema me parece muy interesante, os pongo en antecedentes.

Ayer conseguí sustituir el router Zte H298A y la ONT de fibra Digi por el Fritz 5590 conectando directamente el laguitillo de fibra al Fritz.

En el Fritz coloqué el número de serie de la ONT. Después configuré los datos de internet con el usuario y contraseña PPPoE que proporciona Digi y por si acaso metí también el ID de la ONT que extraje directamente de la ONT.

Servicio PPPoE levantado y funcionando a internet sin problemas, pero ahora viene cuando la cosa se tensa.

He leído cómo se crea un servidor PPPoE en el Mikrotik y quiero hacer algo parecido en el Fritz, el cual tiene una opción que es "PPPoE Passthrough" que lo que hace es permitir que los dispositivos conectados establezcan conexiones adicionales a Internet PPPoE. El tema es que no encuentro la forma de que, conectando el Zte a una boca LAN del Fritz, levante conexión PPPoE y se habilite la línea de fijo que está conectada al mismo.

Algo no estoy haciendo bien o, directamente, no se puede. A ver si algún compañero arroja un poco de luz sobre el Fritz y ojalá descubramos una nueva forma de tener el fijo de Digi funcionando.

Por cierto, hoy volví a llamar a Digi pero nada, que los datos SIP los siguen sin soltar. Saludos ^_^

txintxigorri
-1

Doy fe. Que gozada son los Mikrotik por Diossss!!! Funciona en red Vodafone NEBA con un SERCOM H500s como caja de voz. Me iba a pillar un Fritzbox pero al final caí en Mikrotik y que suerte la mía, creo que he dado en el clavo. Router OS es la lecheeee!!!

Migueldeblas

Yo estoy conectar el router de Digi a un Xiaomi AX3600 con OpenWrt del mismo modo que con el Mikrotik, pero nada.

Conecto el router de Digi (WAN) al OpenWrt del AX3600 (lan3) que tengo conectado a la ONT. aunque me indica que está conectado y con IP, el problema es que el router de Digi no pilla acceso ni DNS /etc/config/network:

config device
        option name 'br-lan'
        option type 'bridge'
        list ports 'lan1'
        list ports 'lan2'

config interface 'lan'
        option device 'br-lan'
        option proto 'static'
        option ipaddr '192.168.1.1'
        option netmask '255.255.255.0'
        option ip6assign '60'

config interface 'wan'
        option device 'wan.20'
        option proto 'pppoe'
        option username 'xxxxxxxx@digi'
        option password 'yyyyyy'
        option ipv6 'auto'

config interface 'wan6'
        option device 'wan'
        option proto 'dhcpv6'

config device
        option type '8021q'
        option ifname 'wan'
        option vid '20'
        option name 'wan.20'

config device
        option type '8021q'
        option ifname 'lan3'
        option vid '20'
        option name 'lan3.20'

config interface 'srvPPPoE'
        option proto 'static'
        option device 'lan3.20'
        list dns '1.1.1.1'
        list dns '1.0.0.1'
        list ipaddr '192.168.2.1'
¿Como hago para que lan3.20 / srvPPPoE obtenga DNS y acceso a internet?

device lan3.20 (puerto físico lan3 con VLAN 20)

interface srvPPPoE (192.168.2.1) interface donde escucha el servidor PPPoE . Asigna rango IP 192.168.2.x

He probado ponerle gateway y DNS pero no funcionan.

🗨️ 1
Migueldeblas

Buenas.

Ya conseguí levantar el servidor PPPoE correctamente en el router neutro Xiaomi AX3600 con OpenWrt.

Conecto el router Digi (puerto WAN) a un puerto LAN del AX3600 (lan3.20) y se establece la conexión.

El router de Digi obtiene IP, datos del DNS y tengo acceso a internet. Conecto un portátil al router de Digi y puedo navegar por internet.

Para que funcione he tenido que desplegar el servidor PPPoE poniendo las mismas credenciales PPPoE y metiendo la interfaz ppp1 (Que se crea en el momento de realizar la conexión entre ambos router) en la zona LAN del Firewall. si alguien quiere más detalles puedo ponerle configuración.

Pero la puñetera VozIP sigue sin funcionar. Algo detecta/no le gusta el router de Digi o bloquea el AX3600 pero no funciona el teléfono fijo.

He leído lo que se ha escrito de esta misma configuración del router Mikrotik pero no veo ninguna pista que me indique que pasa.

Albertorc12

Ostras, esto me va genial ya que hace dos meses que me puse Digi y no me gusta la configuración actual, porque el router Zte h3600p no admite modo Bridge.

Todavía se puede conservar el router de Digi como caja de voz con ese modelo? Si es así me aventuro y me compro un Mikrotik.

Entre los modelos Mikrotik hAP ax2 y Mikrotik HAP ax3 cual elegiriais? Los dos tienen un alcance Wifi decente?

Muchas gracias!!!

Saludos.