BandaAncha.eu

Comunidad de usuarios
de fibra, móvil y ADSL

Parada al reproducir Xvid en disco duro externo

BocaDePez
BocaDePez

Tengo un disco multimedia algo "viejito", un Woxter iCube 35 Xp Pro de 250GB con FAT, y cada vez son más frecuentes los cortes en los vídeos ripeados en Xvid + AC3 que reproduzco desde este medio. Los vídeos se cortan sobre la hora y diez minutos de reproducción. Unas veces es problema del AC3 y no me lleva mucho tiempo reconvertir el audio desde Linux con ffmpeg, pero cuando se trata del vídeo la cosa cambia ya que se puede tirar horas en reconvertir el códec de vídeo y el resultado es bastante malo.

Este es el aviso que devuelve mplayer:

[mpeg4 @ 0xdea520]Invalid and inefficient vfw-avi packed B frames detected

¿Me pueden confirmar si se debe a un error de codificación de vídeo y si hay alguna solución rápida?

BocaDePez
BocaDePez

¿Funciona bien 70 minutos y luego falla? ¿Muchos vídeos? Busca un firmware mejor, o tira el cacharro :D

🗨️ 10
BocaDePez
BocaDePez

Como digo, el aparato es "viejito" (4-5 años) pero funciona perfectamente, el problema está en la codificación de algunos vídeos, no todos, al encontrar errores la reproducción se corta a los 70-80 minutos, justamente estos vídeos son los que me lanza el mencionado error desde mplayer.

No encuentro firmware más nuevo para este aparato en la página del fabricante y está claro que no lo voy a tirar. =;-)

🗨️ 9
BocaDePez
BocaDePez

Una cosa es que el vídeo tenga errores reales en su codificación, y otra cosa es que haya un patrón de reproducción que falle con el algoritmo que use el firmware.

En ciertos resultados de Google a propósito de tu problema, recomiendan hacer una pasada con Avidemux al fichero. Lo que no sé es si hace falta recodificar el vídeo, o simplemente generar un nuevo AVI a partir del anterior, que reordene los elementos de otra forma sin recomprimir.

Ten en cuenta que puede haber miles de archivos que usen DivX 5 con Bitpacked stream, que provocan esos avisos de mplayer, pero que no necesariamente cascan en la mayoría de reproductores de salón, quizás con otro algoritmo de decodificación diferente al que lleve el tuyo.

🗨️ 3
BocaDePez
BocaDePez

¿Quién habló de Divx 5?

🗨️ 2
BocaDePez
BocaDePez
🗨️ 1
BocaDePez
BocaDePez
BocaDePez
BocaDePez
1

Ese artículo lo vi hace tiempo y me vuelvo a remitir a los hechos:

Wifire, no te recomiendo actualizar en otro que no sea el que indico, ya que lo mas probable es que cambie el hardware totalmente y puedas conseguir tener un gran ladrillo en tu salon.

No me apetece tirar el disco duro a la basura por meter un firmware que no vale. No sería la primera vez, al menos en los decos sAT/TDT.

Por cierto, presupones mal. ;-)

🗨️ 3
BocaDePez
BocaDePez
1
🗨️ 2
BocaDePez
BocaDePez
BocaDePez
BocaDePez
vukits

por cierto.. ¿tienes partición swap el firmware?

si no, ¿has buscado la forma de usar una?

🗨️ 3
BocaDePez
BocaDePez

Aún pudiendo crear una partición swap habría que decir a ese firmware que usara ese espacio. Lo veo difícil y desconozco la razón para hacer esto. ¿Puedes explicarte mejor?

🗨️ 2
BocaDePez
BocaDePez

Hola, ¿eres el autor del hilo?

¿No se arregló nada el tema con el MPEG4 Modifier que te aconsejé el 11 de Abril, o el Avidemux que te aconsejé el pasado 3 de Abril?

🗨️ 1
BocaDePez
BocaDePez

Soy el autor y no he comentado nada acerca de si resolví el problema porque todavía no he probado las soluciones del artículo, no he podido dedicarle tiempo. Ya que han aportado más soluciones tras mi última visita he querido que me explicaran un poco más por dónde iban los tiros de la partición swap para disponer de varias alternativas.