BandaAncha.eu

Comunidad de usuarios
de fibra, móvil y ADSL

Sobremesa

Pantallazos azules y posible RAM mal configurada

junxard375

Hola, hace un año compré un equipo a piezas y aunque aparentemente pueda funcionar correctamente, de repente, al cabo de un tiempo indeterminado sale una pantalla azul. Hice una prueba de Memtest36+ y salieron unos 18 000 errores en la RAM. Puede que esos errores sean porque la RAM no esté bien configurada en la BIOS o puede que sea incompatible con mi sistema. De hecho, tampoco sé si puede ser el disco duro, la tarjeta gráfica o la placa base, los que estén dando problemas. Tengo todos los controladores y el sistema operativo actualizados a las últimas versiones.

Los principales síntomas de mi pc son: pantallazos azules espontáneos y de todo tipo, a veces los exploradores se cierran sin más, otras veces se cierran y sale un mensaje diciendo "El programa ha dejado de funcionar", pequeños bloqueos que pueden durar algunos segundos, a veces el sistema no se hiberna correctamente, etc.

El hardware que tengo es el siguiente:

Disco duro: Seagate 2 TB Barracuda 7200.14
Tarjeta gráfica: AMD HD 7850 2 GB OC (Sapphire) GDDR5
Procesador: AMD FX-8150
RAM: Corsair Vengeance 16 GB (2 x 8 GB) 1866 MHz CMZ16GX3M2A1866C9
Placa base: Asrock 990FX Extreme4
Sistema operativo: Windows 8 Enterprise 64 bits

Cuando borré la CMOS los pantallazos azules disminuyeron, pero todavía sigue habiendo, incluso una vez en modo seguro saltó uno muy típico en mi pc (KERNEL SECURITY CHECK FAILURE). Casi todos los pantallazos están relacionados con el kernel del sistema operativo.

Algunos de ellos son: IRQL NOT LESS OR EQUAL, MEMORY MANAGEMENT, KMODE_EXCEPTION_NOT_HANDLED, BAD_POOL_CALLER, KERNEL_MODE_EXCEPTION_NOT_HANDLED, BAD POOL HEADER...

Tengo también la BIOS actualizada a la última versión, así como el firmware del disco duro. La tarjeta gráfica viene overclockeada de fábrica. He de decir también que no me dejó instalar Windows con los dos módulos de memoria, tuve que quitar uno porque saltaba un patallazo azul antes de finalizar la instalación. Una vez uno de los pantallazos estuvo relacionado con un driver del antivirus Kaspersky y en otra ocasión fue con uno de la tarjeta gráfica.

He probado dejando la velocidad y latencias de la RAM en modo Auto y también en 1866 MHz en la BIOS, pero sin resultados en ambas ocasiones, eso sí, nunca he subido el voltaje de la RAM.

En esta página [url=http://support.amd.com/en-us/kb-articles/Pages/ddr3memoryfrequencyguide.aspx#bios]DDR3 memory frequency guide[/url] dice que los procesadores AMD FX solo pueden alcanzar una velocidad de 1600 MHz con dos slots de memoria ocupados en placas base compatibles con cuatro slots disponibles.

Tengo la esperanza de que sea un problema de configuración de la BIOS y/o de overclock del procesador y de la RAM, por eso necesito que me ayudéis porque ya no sé qué hacer más, he hecho pruebas de estabilidad (de poco tiempo de duración) a la tarjeta gráfica, al disco duro y al procesador y las han pasado.

eddie2k

En mi humilde opinión... yo me dejaría del resto y verificaría la ram. Configura la BIOS con la configuración de la ram (aunque hoy en dia el modo auto debería de ir de lujo) y pasale el memtest. Si sale rojo tienes muchas papeletas de que esté la ram rota (no es tan raro, por mis manos han pasado bastantes). Si tienes opción, pinchala en otro pc (retira los que tenga) y le haces un memtest, y si sale mal, a garantía. Tambien puedes hacer memtest individuales a cada módulo que tengas en tu propio PC (incluso, si quieres ir sobre seguro, distintas pruebas al mismo módulo en distintos bancos) y podrás ver si hay algún culpable, pero yo apuesto a ram averiada.

Al menos parece bastante posible, como tu dices, que sea por la ram (casi siempre que he visto esos tipos de errores aleatorios era por la ram). Yo tiraría por ahí, tienes muchas opciones de que tengas un modulo mal, y casi que es la mejor opción, te la cambiarán en garantía, te quitarás de quebraderos de cabeza y todo irá como la seda.

Un saludo.

BocaDePez
BocaDePez

RAM: Corsair Vengeance 16 GB (2 x 8 GB) 1866 MHz CMZ16GX3M2A1866C9
Pues hombre.... la ram normal funciona a 1333Mhz, la corsair normal, a 1666 si no recuerdo mal, pero la tienes subida de tono hasta 1866Mhz.¿No crees que podría ser que la estas pasando de vueltas? ¿has probado a ponerla a 1666 y a hacerla un memtest?
Suerte.

junxard375

Sí, como decís yo creo que la culpable es la RAM. Lo que haré será comprobar los dos módulos por separado a ver qué tal y también probaré subir un poco el voltaje de la RAM o bajarle la frecuencia. Lo que no tengo muy claro es si es cierto lo que dice la página de AMD, si es cierto que la máxima velocidad en una placa con 4 slots de RAM disponibles y 2 de ellos ocupados sea de 1600 MHz con un procesador AMD FX.