BandaAncha.eu

Comunidad de usuarios
de fibra, móvil y ADSL

Fibra

Warnings PPPoE periódicos en OpenWrt con fibra Movistar

kitus

He estado buscando en el foro antes de postear, y no he localizado hilo previo que cubre esto que os voy a preguntar. Me disculpo de antemano si no he sabido buscar bien, y en caso de que así sea, por favor agradeceré que me dirijáis al hilo correspondiente.

Tengo un Netgear R7800 funcionando con OpenWrt en la red de Movistar desde hace un año y medio. El HGU MitraStar lo tengo en modo bridge. La verdad es que desde que lo tengo así, ha funcionado muy muy bien; tengo un monitor cloud de mi interfaz WAN y veo un 100% sostenido de disponibilidad.

Pues bien, el hecho es que desde hace un tiempo la red cableada de mi casa me hace el cabra. La mitad de la red cableada se me cae y cada vez me sucede más a menudo (a diario últimamente). Tengo la sensación de que o bien puede ser por el calor, o bien porque uno de mis switches manda alguna trama de STP y me tumba los SW no gestionados. Es un poco como buscar una aguja en un pajar, la verdad.

Pero bueno, dejando la inestabilidad de mi LAN (que eso entiendo es ámbito de otro foro), buscando buscando al fantasma, me he topado con las siguientes trazas periódicas (cada 15s.!!) en la consola del OpenWrt:

Sat Aug 27 23:59:37 2022 daemon.warn pppd[6801]: Timeout waiting for PADO packets
Sat Aug 27 23:59:37 2022 daemon.err pppd[6801]: Unable to complete PPPoE Discovery
Sat Aug 27 23:59:37 2022 daemon.info pppd[6801]: Exit.
Sat Aug 27 23:59:37 2022 daemon.notice netifd: Interface 'wan6' is now down
Sat Aug 27 23:59:37 2022 daemon.notice netifd: Interface 'wan6' is setting up now
Sat Aug 27 23:59:37 2022 daemon.err insmod: module is already loaded - slhc
Sat Aug 27 23:59:37 2022 daemon.err insmod: module is already loaded - ppp_generic
Sat Aug 27 23:59:37 2022 daemon.err insmod: module is already loaded - pppox
Sat Aug 27 23:59:37 2022 daemon.err insmod: module is already loaded - pppoe
Sat Aug 27 23:59:37 2022 daemon.info pppd[6892]: Plugin rp-pppoe.so loaded.
Sat Aug 27 23:59:37 2022 daemon.info pppd[6892]: RP-PPPoE plugin version 3.8p compiled against pppd 2.4.8
Sat Aug 27 23:59:37 2022 daemon.notice pppd[6892]: pppd 2.4.8 started by root, uid 0

Lo cierto es que hice el cambio hace mucho tiempo y no localizo el tutorial que en su momento seguí. Lo que sí veo, tras haber estado mirando algunos hilos aquí, es que mi configuración no es tan sofisticada como alguna que he visto; en mi configuración no estoy utilizando las 3 VLANs que entrega Movistar porque el teléfono lo tengo en el HGU y no uso la IPTV que ofrecen. Temo que en el tagging puede estar el problema que muestro más arriba, pero no sé por dónde tirar.

Para más inri, no tengo claro que pudiera logarme en el HGU MitraStar porque no tengo ni habilitado el acceso por el portal Alejandra, y cuando hice la configuración actual no alcancé a pensar que me podría interesar conectarme al HGU; es decir, configuré la misma subred en el OpenWrt que tenía ya antes de hacer el cambio, por lo que si desde el OpenWrt pudiera llegar por routing al HGU. La única forma supongo que sería desconectando el OpenWrt y conectando un PC directo al HGU.

¿Alguno de vosotros podría orientarme porfa?

vukits

antes de nada , prueba otros cargadores de corriente.

🗨️ 8
kitus

Hola vukits!

esto que propones va en línea de mis perdidas parciales de la red de casa o sobre el problema de flapping en la WAN que muestran las trazas que adjunté?

(btw, creo que es tuyo el tutorial al que hago referencia cuando digo que he visto configuraciones mucho más sofisticadas que la que yo tengo; felicidades!)

🗨️ 3
vukits

el hecho es que desde hace un tiempo la red cableada de mi casa me hace el cabra. La mitad de la red cableada se me cae y cada vez me sucede más a menudo (a diario últimamente

algo le pasa al switch del Netgear.

🗨️ 2
kitus

El Netgear 7800 es el que corre OpenWrt. Miraré si puedo localizar un adaptador de AC compatible con el Netgear a ver. Con eso tu crees que la WAN dejará de hacer flapping?

🗨️ 1
vukits
kitus
1

Mira, tengo un Netgear de reemplazo en el trastero. Lo compré refurbished para poder hacer un swap rápido cuando empecé a juguetear con OpenWrt… en un rato bajo al trastero y clono el que tengo en producción a ver.

De todos modos, creo que hay algo que no he dejado claro. Mi topología es esta:

Router OpenWRT Netgear R7800
                                     |
        |----------------------------|----------------------|-------------------|
        |                            |                      |                   |
    switch D-link (#1)   switch Netgear PoE (gest.) #2 switch Netgear #3     Alarma
    |                |        |      |                  |       |
    |                |      cámaras PoE                 |       |
    |                |                                qnap    Nuc 
switch Netgear (#4) switch d-link (#5)

Cuando se lía, se me cae los switches (y todo lo que de ellos cuelga) #1, #3, #4, y #5. El router Netgear OpenWrt funciona perfectamente en esa situación de caida. Todo lo que cuelga del switch PoE también. La propia Alarma responde a ping sin problemas cuando tengo ese problema…

Tengo que buscar la forma de poder utilizar el loggin del Netgear OpenWrt para poder investigar qué sucede, porque con los loggins básicos no veo nada, y cuando hay caida no he conseguido sacar el agua clara durante el periodo de corte.

Mi estómago me sugiere lo siguiente:

  • calor excesivo en el R7800 me tira los puertos del #1 y el #3 (siempre son los mismos equipos los que caen, incluso si permuto los cables)
  • algún switch o algún endpoint lanza alguna trama STP que me tumba los switches #1 y #3
  • que tenga alguna relación con el problema de la WAN (que el R7800 quizá esté propagando alguna trama de discovery en modo flood)

Lo dicho: voy a montar el R7800 de backup y miro si me vuelve a suceder.

Gracias por tu ayuda!!

kitus

Hola de nuevo @vukits,

prueba realizada de nuevo con otro R7800, con su correspondiente fuente de alimentación. Mismo resultado: cada 15 segundos mensaje de warning.

No puede ser que tenga problemas de tagging o algo así?

🗨️ 2
vukits

como siempre digo, he cursado redes tres años seguidos, y jamás aprobé

en todo caso, el log es de caída PPPoE (corte de la conexión, vaya).

🗨️ 1
kitus

jajaja :)

luego pruebo lo que me ha dicho aeri, y reporto aquí

EnfermeraSexy

Desactiva IPv6 en la interfaz.

🗨️ 10
kitus

En la captura de las interfaces no veo cómo tirar la IPv6. Sabes dónde lo debería hacer en OpenWrt?

g0bztpaw.webp
🗨️ 2
aeri
1

En esa captura se ve que tienes tres interfaces WAN; "WAN_6" (con guión bajo) es una interfaz que autogenera OpenWrt al establecer direccionamiento IPv6 por PPPoE, lo cual me es muy curioso porque en tenoría Movistar no provee IPv6, de hecho ni siquiera asigna direcciones en enlace PPPoE, igual estás en una zona de pruebas.

La interfaz que te está dándo problemas es "WAN6" (sin guión bajo), eliminala presionando el botón "Delete" que aparece en dicha interfaz y aplica los cambios, si no te deja hacerlo así, edita el fichero /etc/config/network y borra todas las entradas referentes a la "WAN6".

Con esto te deberían desaparecer los errores que señalas.

🗨️ 1
kitus

Muchísimas gracais @aeri! Esta noche lo pruebo y reporto aquí. Gracias de nuevo otra vez!

kitus

Buenas de nuevo! comentado el fichero de config (para no perder la configuración por si acaso), he reiniciado el router, y he verificado que la interfiere wan6 ya no se mostraba. Lamentablemente, solo con la definición de WAN, no me cogía IP por DHCP sobre PPPoE. Hasta que no he desconectado esa parte de la configuración y reiniciado de nuevo, el router no tenía conexión a Internet.

Pego aquí la configuración tal y como la tengo, por si hay algo que no veas no esté bien:

root@OpenWrt:~# cat /etc/config/network 

config interface 'loopback'
	option proto 'static'
	option ipaddr '127.0.0.1'
	option netmask '255.0.0.0'
	option device 'lo'

config globals 'globals'
	option ula_prefix 'fda7:3a7a:0f62::/48'

config interface 'lan'
	option proto 'static'
	option netmask '255.255.255.0'
	option ip6assign '60'
	option ipaddr '192.168.1.1'
	option device 'br-lan'

config interface 'wan'
	option proto 'pppoe'
	option password 'adslppp'
	option ipv6 'auto'
	option username 'adslppp@telefonicanet.pa'
	option device 'eth0.2'

config interface 'wan6'
	option proto 'pppoe'
	option password 'adslppp'
	option ipv6 'auto'
	option username 'adslppp@telefonicanet.pa'
	option device 'eth0.2'

me sorprende ver

ipv6 'auto'

en la configuración de las 2 interfieres…

Por ahora lo he dejado así, a ver qué tal:

config interface 'loopback'
	option proto 'static'
	option ipaddr '127.0.0.1'
	option netmask '255.0.0.0'
	option device 'lo'

config globals 'globals'
	option ula_prefix 'fda7:3a7a:0f62::/48'

config interface 'lan'
	option proto 'static'
	option netmask '255.255.255.0'
	option ip6assign '60'
	option ipaddr '192.168.1.1'
	option device 'br-lan'

config interface 'wan'
	option proto 'pppoe'
	option password 'adslppp'
	option username 'adslppp@telefonicanet.pa'
	option device 'eth0.2'

config interface 'wan6'
	option proto 'pppoe'
	option password 'adslppp'
	option username 'adslppp@telefonicanet.pa'
	option device 'eth0.2'
	option auto '0'
	option ipv6 'auto'

pero es super raro eso de la wan6 porque además he comentado el "option IPv6 'auto' " para asegurarme que no dejaba nada de IPv6 a la vista, y el cachondo del router me ha vuelto a forzar "option IPv6 'auto' " en el fichero de configuración de la wan6!!

Al final lo he dejado forzado a mano con esto:

config interface 'wan'
	option proto 'pppoe'
	option password 'adslppp'
	option username 'adslppp@telefonicanet.pa'
	option device 'eth0.2'

config interface 'wan6'
	option proto 'pppoe'
	option password 'adslppp'
	option username 'adslppp@telefonicanet.pa'
	option device 'eth0.2'
	option auto '0'
	option ipv6 'no'

y parece que ha booteado bien y tengo conectividad. Además, los mensajes de error han desaparecido del log.

🗨️ 3
vukits

pues ahora solo toca a ver si se cae la LAN

🗨️ 2
kitus
1

mi sentido arácnido me sugiere que el Nuc es el que me está generando problemas. Ayer moví ese equipo bajo el switch Netgear PoE y en todo el día de hoy no me ha dado problemas… parezco los cazafantasmas :)

🗨️ 1
vukits
kitus

Pues he cantado victoria demasiado pronto. Al cabo de unos minutos, me ha empezado a hacer flapping la salida a internet. Mirad la imagen adjunta. Sé que suena raro, pero tras lo que he visto al hacerlos cambios de arriba, me da la impresión de que el router necesita esa interficie funcionando para que el acceso sea estable? Mirad esta imagen: la que se ha liado mientras estaba cenando…

imagen.webp

Voy a probar con esta configuración, que me parece una opción interesante:

config interface 'wan'
	option proto 'pppoe'
	option password 'adslppp'
	option username 'adslppp@telefonicanet.pa'
	option device 'eth0.2'
        option ipv6 'auto'

#config interface 'wan6'
#	option proto 'pppoe'
#	option password 'adslppp'
#	option username 'adslppp@telefonicanet.pa'
#	option device 'eth0.2'
#	option auto '0'
#	option ipv6 'auto'
🗨️ 2
aeri

Si, esta es la idea que tenía, dejar la wan6 totalmente al margen, borrarla o como en este caso comentarla.

🗨️ 1
kitus

por ahora pinta de coña… vuelvo a actualizar en un "rato" :)

de todos, veo que me continua creando la interficie virtual que no te cuadraba:

afydtwsa.webp

mil gracias!!

Cucalister

Compra un ONT puro Huawei por 15e y quita esa basura infecta de router Movistar

🗨️ 2
kitus

Pues no es ninguna tontería. Pero si tengo problemas de conexión, Movistar se desentenderá no? cómo podría localizar los parámetros de configuración para esa nueva ONT si no tengo acceso a mi HGU?

🗨️ 1