Banda Ancha EU

Comunidad de usuarios
de fibra, móvil y ADSL

ADSL

Nuevo firm ( no oficial ) para el HG520-v300

Ari

Muchos usuarios del Huawei HG520-v300, equipo que está proporcionando actualmente Jazztel junto con el Comtrend 536+, han experimentado todo tipo de dificultades al usarlo con sus conexiónes.

En los últimos dos meses hemos tenido la oportunidad de probar uno de estos equipos, y de sufrir también algunos de sus inconvenientes: caídas de conexión, imposibilidad de poder encriptar en wpa, incluso conectado en wep y con la red abierta, perdida de conexión entre el pc y el router que en los casos más agudos suponía tener que reparar la conexión inalámbrica cada 15 segundos, haciendo la navegación por wifi una tarea casi imposible...

Después de muchas pruebas hemos llegado a la conclusión de que, si bien el HG520 es un buen equipo, no lo es ninguno de los firms disponibles para él: se probaron tres firms específicos para este equipo sin resultados completamente satisfactorios.

Visto todo esto, la solución a estos problemas pasaba por un nuevo firm que, parece que por ahora, huawei no está dispuesta a desarrollar, así que, visto esto, a grandes males, grandes remedios y así hemos fabricado, por decirlo de alguna manera, nuestro propio firm :)

El usuario Raulito escogió, entre los diferentes firms del Comtrend 536+, uno de los más apreciados por su estabilidad por los usuarios de este foro: el A101-302JAZ-C01_R05
Tras modificar varios parámetros de este firm y después de varias pruebas consiguió transformarlo hasta convertirlo en un firm completamente compatible con el HG520-v300. Durante dos semanas se ha estado probando de forma casi completamente satisfactoria, por lo que hemos decidido que el firm está listo para ser utilizado por los usuarios de este equipo

RECOMENDACIONES

Antes de cambiar de firm deberéis de tener en cuenta al menos estas precauciones básicas:

* Si no estáis seguros, no os bajéis ni cambies de firm solo por cambiar: cambiar de firm no es obligatorio y a no ser en el caso de usuarios avanzados con afán de investigación, ha de hacerse para paliar algún problema o añadir alguna mejora necesaria en nuestras líneas.

* Antes de subir el nuevo, debéis de guardar una copia de vuestro actual firm y hacer un backup de vuestra actual configuración ( que SOLO os servirá para eso firm concreto, no para el que pongáis nuevo ), por si este no os gustara o no os fuera bien, poder volver atrás, subiendo el anterior firm, y, posteriormente, subiéndole su respectivo archivo de configuración. También debéis guardar copia de vuestros datos de conexión, porque pueden haceros falta para conectaros con el nuevo firm.

* Bajar el firm, extraerlo de la carpeta zip contenedora ( es el archivo .bin ) y una vez extraído, subirlo a través de la opción Management--Update. Siempre debéis subir y cambiar el firm conectados con cable de red.

* Si a pesar de todas estas precauciones, surge algún problema, generalmente basta para solventarlo con hacer un simple reset. Si esto no os funciona, o si no queréis simplemente usar la anterior opción, guardad y tened a mano este hilo, y seguid sus instrucciones. Es prácticamente infalible para recuperar el router.

VENTAJAS DEL NUEVO FIRM

* Estabilidad de la conexión tanto conectando con cable de red como por wifi: ausencia de los temidos cortes de ppp, frecuentes en este equipo anteriormente.
* Posibilidad de poder encriptar la conexión wifi en wpa-tkip ( en mi caso no he podido encriptar en AES, pero Raulito me comenta que él sí pudo) sin perdida de conexión entre el router y el pc.
* Sincronización sin apenas altibajos y estable: anteriormente una caída de conexión podía suponer una perdida en velocidad de hasta, en mi caso, de 18 megas, con una subida en valores de snr y atenuación espectaculares.

INCONVENIENTES

* A pesar de todos los esfuerzos que se han hecho en ese sentido, no se ha conseguido que el led de adsl se encienda cuando tiene lugar la conexión, lo cual es un inconveniente, menor, pero lo es, aunque obviamente la conexión vaya con toda normalidad.

Antes de dejaros el enlace para descarga aquí tenéis unas capturas ( con y sin fastpath ) para que lo veáis

Imagen original en http://img359.imageshack.us/img359/4449/dslrouter11042008151732cf0.th.jpgImagen original en http://img238.imageshack.us/img238/5130/dslrouter11042008155311fv0.th.jpgImagen original en http://img515.imageshack.us/img515/4706/dslrouter11042008155436th1.th.jpg

El enlace para descarga es este /store/descargas_antiguas/hgv300-A101-30…-C01_R05.zip
Las claves de acceso al router: admin/admin

Nada más entonces: solo agradecer profundamente a quien hizo posible que tuviéramos en nuestras manos el huawei HG520-V300 para probarlo su ayuda, ya que sin equipos no hubiéramos podido ver donde estaba el problema y obtener esta solución, y por supuesto, muchísimas gracias al usuario Raulito por su esfuerzo y dedicación para que todos los usuarios de este equipo puedan por fin disfrutar de él ;) :)

Un cordial saludo y que lo disfrutéis :)

Este tema está cerrado a nuevas respuestas. Abre un nuevo tema para retomar la conversación.
BocaDePez
BocaDePez

felicidades a todos los que lo han hecho posible!!!

Comtrend536

Ahora sólo me falta conseguir un Huawei HG520-v300

¿Los darán gratis en algún lado? :-P

🗨️ 7
Ari

La verdad es que encontrar un huawei a día de hoy es muy fácil: todo el mundo quiere desprenderse de ellos..pero, esperamos que a partir de ahora no sea tan fácil conseguir uno ;)

Saludos :)

🗨️ 6
BocaDePez
BocaDePez

ya mismo se cambia en nick xDDD

🗨️ 5
Comtrend536

Igual me lo pienso...jajajaja

🗨️ 4
darkdead
🗨️ 3
Ari
pitusito

Hola, ¿aparece la opción de WDS?¿Funciona?

Un saludo.

🗨️ 1
Ari

Sí, sí la tiene , aunque no la he probado, pero pienso que no hay problema para que funcione normalmente.

Saludos

Luke

mejor que el firmware oficial seguro que es.. ademas asi me entretengo mientras no tengo linea :P

🗨️ 3
Ari

Puedes jurar que mejor que el oficial es :P

🗨️ 2
Luke

pues por lo que puedo probar (que es poco jajajaja) funciona perfectamente. Esto transforma completamente el huawei en algo decente ;)

🗨️ 1
Ari

Sí, la palabra es esa : decente :) Además, al menos en mi caso, la cobertura wifi es mejor que con el Comtrend, y tiene unos muy buenos valores de bajada, que se estropeaban cada vez que se caía la línea y se te quedaba en 3 megas, que ya es caída. Ahora ya no: a ver qué tal resultado le da a otros usuarios.

GetA1

Funciona bien, es estable y tengo cifrado WPA bajo Windows XP, incluso sincronizo a 1704Kb en G.dmt, nunca habia llegado a esos valores con este router.
Gracias por vuestro trabajo y por compartirlo

🗨️ 2
Ari

Gracias a vosotros por probarlo :) Esperamos que sirva de ayuda a todos los usuarios de este equipo, que tanto han sufrido con él ;)

Saludos

GetA1

Llevo desde el día 12 con el router funcionando sin ningun tipo de problemas y con estabilidad completa.
Con el zyxel tengo mas bajada (hasta 2400) pero tambien es cierto que la conexión se muestra mas inestable para mi linea (estoy a 5500m de la central).

Teordoro

Es que sois la pera limonera.

Mira que si, después de lo que hemos despotricado de este router, me va tocar buscarme uno.

Como siempre, gracias.

drago111

me cachis precisamente ahora que he comprado un comtrend :-? :-? :-? :-?

🗨️ 1
Ari

Bueno, si tienes el huawei te lo quedas para una urgencia :) Funciona muy bien con este firm con mejor cobertura wifi que el Comtrend e incluso mejores valores de sincronización en bajada. Mejo tener dos equipos útiles por cualquier circunstancia, que tener un cacharro casi inútil guardado por ahí y que nadie quería ;)

Saludos

OzzyOsbourne

¿Es imprescindible conectarse por cable, por wifi no?....

🗨️ 2
Kalimist

Para actualizar el firmware sí.

🗨️ 1
drago111

Tremendo esto es un tiro, enhora buena una maravilla.

🗨️ 7
OzzyOsbourne

Jo, pues a mi no me ha servido. Instale el nuevo firm y las luces de ppp y dsl no se encendian y obviamente no podia navegar.

Yo creo que es por algo que han tocado en mi linea desde que pedi que me pusieran jazztelia.

Una pena pero bueno.

🗨️ 6
Ari

La luz de adsl NO se enciende lo cual no significa que no tengas conexión. Mírate el apartado "inconvenientes " La de ppp, sí. El firm se modidificó para que pudiera ser usado con el huawei pero no se pudo hacer nada para que se encendiera ese led: pasaba lo mismo con el de ppp pero eso se pudo solventar antes de liberarlo :)

En cualquier caso mira el log del router a ver qué te dice.

Saludos

🗨️ 5
drago111

ozzy tienes que volver a poner los datos de la carta y ya esta

OzzyOsbourne

Ya se que no se enciende, pero tampoco se encendia la de ppp y aunque intentaba navegar no podia, por eso he vuelto a poner el firm que tenia antes.

Otro dia que tenga un rato lo intento.

🗨️ 3
Ari
🗨️ 2
drago111

Bueno, si tienes el huawei te lo quedas para una urgencia Funciona muy bien con este firm con mejor cobertura wifi que el Comtrend e incluso mejores valores de sincronización en bajada. Mejo tener dos equipos útiles por cualquier circunstancia, que tener un cacharro casi inútil guardado por ahí y que nadie quería

Saludos

Que me recomendais el Huawei con nuevo firm o el comtrend con ultimo firm de jazztel?

🗨️ 1
Ari

El Comtrend es mucho más manejable y trasteable en muchos sentidos que el huawei, o casi que cualquier equipo de los que proporcionan ahora los diferentes isps: si no encuentras un firm que no te guste, o no te vaya bien, tienes una docena más para escoger.

Con el huawei, ahora mismo, solo tenemos esta opción. Pero si te va bien, eso es algo que debes valorar solo tú, de acuerdo a lo que necesites más: subida, bajada, estabilidad, ping, wifi... :)

Saludos

BocaDePez
BocaDePez

para el v100 no vale no?

🗨️ 2
Luke

no, internamente es distinto

🗨️ 1
Raulito

El primer firm que hice lo hice para el v100...lo que pasa que puesto que funciona bien, y el v300 es el que más gente tiene, pues no he pensado en liberarlo, supongo que lo tengo por ahí, no estoy seguro. De todos modos era mucho más fácil que el v300

eskasi

Y utilizar el usb del huawei, seria posible?

🗨️ 4
Raulito

Utilizar usb como?

🗨️ 3
eskasi

No lo se...quizas conectar al puerto una impresora o un disco duro?
Con firmwares de asus se puede "manipular" el puerto?

🗨️ 2
Raulito
🗨️ 1
eskasi
BocaDePez
BocaDePez

He instalado el nuevo firm. y ahora no puedo navegar. No se encienden las luces del DSL ni el PPP...
Y no se deja resetear. ¿como puedo lograrlo?

gracias.

🗨️ 17
BocaDePez
BocaDePez

Hola Raulito.
En ese post se habla de recuperar al Comtrend ¿vale igual para el Huawei?

Saludos.

🗨️ 15
Raulito

Sí, si lees el hilo donde estás respondiendo ahora mismo, verás que el enlace está ahí...

🗨️ 14
drago111
🗨️ 13
BocaDePez
BocaDePez
🗨️ 12
Ari
🗨️ 11
BocaDePez
BocaDePez
🗨️ 10
BocaDePez
BocaDePez
🗨️ 9
Raulito
🗨️ 8
Luke
🗨️ 7
Raulito
🗨️ 6
Ari
🗨️ 5
Raulito
🗨️ 4
Ari
🗨️ 3
BocaDePez
BocaDePez
🗨️ 2
Ari
vukits

a las instrucciones habría que añadirle un hard-reset antes del flasheo y otro después ¿no? .. jaja, nusé 8-)

🗨️ 2
Ari

"Antes de" hay que volver a los valores por defecto y para eso no es necesario, a nos ser que se ponga tozudo, claro, un hard reset.
Tampoco pasa nada por hacerlo pero es tan simple como darle a la opción correspondiente del router.

Saludos

🗨️ 1
OzzyOsbourne

Ah.... o sea ¿que primero hay que restaruar el router a su estado original?....

BocaDePez
BocaDePez

Necesito ayuda.He ctualizado al nuevo firmware sin guardar el anterior y ahora no tengo conexion.¿Que puedo hacer?

🗨️ 2
Ari

¿ Has reseteado el router ? Inténtalo pulsando durante varios segundos el botón de reset, mientras lo apagas y lo enciendes con el botón de atrás, de apagado y encendido ?

¿ Desde donde estás, puedes bajarte la versión del último oficial de Jazztel ?

BocaDePez
BocaDePez

y donde lo subo por que ahora es distinto con la configuracion del commtrend

🗨️ 5
Ari

La interfaz del Comtrend y el v300 es muy parecida, por no decir casi idéntica :)

Vete aquí http://192.168.1.1/upload.html y súbelo desde donde lo tengas guardado.

Saludos

🗨️ 4
BocaDePez
BocaDePez

gracias Ari eres un monstruo

🗨️ 3
BocaDePez
BocaDePez

cuales son mis datos de conexion donde los puedo ver?

🗨️ 2
Ari
eskasi

Alguna pega le he encontrado, aunque me parece increible el cambio que ha experimentado el huawei.

Actualmente lo tengo en pruebas, como router principal de acceso a internet y enganchado a el via wifi, una fonera.

Pues bien, esta se resetea cuando sufre algun corte el enlace wifi. La fonera me dice que se reseteo hace unas 4 horas...a las 5 y media de la mañana.

Por otro lado, la administracion remota via web no acaba de funcionar bien. Ayer, en el puerto 80 por defecto, no me dejaba entrar, a pesar de estar correcta la clave. Una vez en casa, habiendo cambiado el puerto al 8080, no me responde y da error de timeout el navegado.

Por lo demas, un trabajo excelente....ahora es un router medio decente.

BocaDePez
BocaDePez

Probado con éxito el WDS con este nuevo firmware, que es para lo que yo había reservado el Huawei de lo malo que era. Me funcionó bien, WEP incluido, contra un Comtrend 5631 de Telefonica actualizado con el firm no oficial que anda por aquí últimamente (con el firm oficial de Telefonica no funcionaba el WDS).

Gracias Raulito y cia!

BocaDePez
BocaDePez

The path must not contain more than 128 characters :S No me deja actualizar a ese firm

🗨️ 4
Ari

¿ Has vuelto a la configuración por defecto antes de subirlo ?

Saludos

🗨️ 2
BocaDePez
BocaDePez

Sip, y me sigue pidiendo lo mismo, como es posible q solo me ocurra a mi? :S

🗨️ 1
Luke

copialo a una carpeta más alta en el disco duro (es decir, c:\algo\firmware.bin en lugar de c:\cosas\blah\firmwares\comtrend\bandaancha\firmware.bin)

BocaDePez
BocaDePez

Hola, buen curro por este firmware no oficial... solo me queda una pregunta ¿sacareis una revision de este firmware para arreglar algunas cosillas como el led de adsl y para perfeccionarlo mejor?
Gracias

🗨️ 2
Ari

Se va a intentar corregir algún problema con los leds, no solo con el del adsl, pero en este momento lo que nos interesa es ver si los cortes y otros problemas que presenta este equipo se os solucionan, ya que eso es lo prioritario ;)

Saludos

Raulito

El led del adsl es imposible arreglarlo, lo intenté de todas las maneras. Llegué a hacer que se encendiera, pero no funcionaba como debiera, así que decidí deshabilitarlo.

Respecto a mejorarlo, pues como no des más pistas...

BocaDePez
BocaDePez

Bueno señores pues he intentando de todas las formas meterle este firmware y no me tira , no se enciende la luz de ppp ni la de dsl aunque esta luz es normal con este firmware, pero la luz ppp no enciende y no tengo internet.

Solo se queda encendida la de wlan, la de lan1 y la del power y no me funciona. Lo he echo de 2 formas una normal con el update y la otra como el manual de recuperar el router dejando pulsado el reset y al acceder al router que me pida el firmware directamente.

A los que lo han metido que me diga la forma porque tonto no soy pero esto no tira. Asi que he vuelto al firmware oficial de jazztel.

Si alguien sabe como hacerlo que lo diga. Saludos

🗨️ 38
OzzyOsbourne

A mi me pasa exactamente lo mismo. No se si he deducido por ahi, que despues deguardar la configuracion, hay que restaurar la version que venia por defecto en el router, la original, no la que tengamos puesta.

A ver si es eso y alguien nos dice algo.

🗨️ 37
Luke

Yo lo primero reestablecería valores de fabrica y configuraria desde cero. Luego, os habéis fijado en qué dice el log?

es normal que la luz ppp y dsl no se enciendan nunca, aunque la conexión funcione

🗨️ 35
BocaDePez
BocaDePez

A mí la luz de DSL se me enciende todo el rato, desde el principio... hasta que le enchufo la línea al conector DSL y entonces se apaga cuando pilla sincronismo... :-P

A los demás, que no navegáis, obviamente hay que reconfigurar los parámetros de conexión con el ISP (Advanced Setup -> WAN). OZZYOZBOURNE, tu "Diagnostics" ya lo dice claro:
Test PPP server connection: PASS Help
Test authentication with ISP: FAIL Help

Tienes mal el usuario y/o contraseña.

🗨️ 33
BocaDePez
BocaDePez
🗨️ 31
BocaDePez
BocaDePez
🗨️ 29
BocaDePez
BocaDePez
🗨️ 26
Luke
🗨️ 25
Ari
🗨️ 12
Ari
🗨️ 10
Ari
🗨️ 8
Ari
🗨️ 6
Luke
🗨️ 4
Luke
🗨️ 2
Luke
Luke
🗨️ 10
Raulito
🗨️ 7
Luke
Luke
🗨️ 5
BocaDePez
BocaDePez
🗨️ 3
Ari
Luke
🗨️ 1
Ari
Ari
drago111

yo lo metí y funciona perfectamente metes el firmware se reinicia entras en la configuracion 192.168.1.1 te pide la clave y contraseña admin admin y despues tienes que meter los datos(creo que es en NAT) que te enviaron en la carta nombre de usuario xxxx@jazztel y la contraseña le das a save/reboot (en mi caso tuve que apagarlo manualmente) y cuando vuelve a sincronizar ya puedes navegar.

Espero haber sido de ayuda

bira

Lo estoy probando.
Las encriptaciones funcionan correctamente, en wpa2.
Algunas pegas:
1.- Tiene el firmware el nombre del comtrend.

2.-Cuando le digo que me sincronice la hora con internet me es imposible conectarme.

3.- Disminuye bastante la sincronización tanto de subida como de bajada, con relacion al comtrend.

Por lo demás consideró que Raulito ha recuperado un routers sin control y al que nadie, incluido su fabricante, le ha preocupado su funcionamiento.

Un notable por tu trabajo.

Gracias por tu aportación

🗨️ 2
Ari

Muy curioso, lo de la sincro que comentas porque a mi, el huawei, a día de hoy, y con cualquiera de sus firms, oficiales o no, me da el máximo en sincro tanto en bajada como en subida :)

Lo de la hora, no me ha pasado pero a ver si pillo algo más de tiempo, y lo reviso ;)

Saludos

🗨️ 1
bira

estos son los valores que me da de sincronizacion:
Normalmente con el comtrend me sincroniza entre 19000 y 2000 de bajada y sobre los 850 o 900 de subida.

Statistics -- ADSL

Mode: ADSL2+
Line Coding: Trellis On
Status: No Defect
Link Power State: L0

Downstream Upstream
SNR Margin (dB): 8.3 10.5
Attenuation (dB): 10.5 2.6
Output Power (dBm): 0.0 4.4
Attainable Rate (Kbps): 17652 916
Rate (Kbps): 17442 793
MSGc (number of bytes in overhead channel message): 66 131
B (number of bytes in Mux Data Frame): 244 13
M (number of Mux Data Frames in FEC Data Frame): 1 16
T (Mux Data Frames over sync bytes): 2 1
R (number of check bytes in FEC Data Frame): 10 16
S (ratio of FEC over PMD Data Frame length): 0.4485 8.3843
L (number of bits in PMD Data Frame): 4548 229
D (interleaver depth): 64 4
Delay (msec): 7 8

Super Frames: 156583 156581
Super Frame Errors: 3 1
RS Words: 22548088 665469
RS Correctable Errors: 7032 603979779
RS Uncorrectable Errors: 63 N/A

HEC Errors: 3 0
OCD Errors: 0 0
LCD Errors: 0 0
Total Cells: 104049563 4710139
Data Cells: 226019 201604
Bit Errors: 0 0

Total ES: 2 1
Total SES: 0 0
Total UAS: 15 26

darkdead

Acavo de probarlo en mi hawei y la verdad esta bien pero sincronizando es un poco malo con el comtrend mis datos ahra sin fast path son estos con el ultimo de raulito.

Mode: G.DMT
Type: Interleave
Line Coding: Trellis On
Status: No Defect
Link Power State: L0

Downstream Upstream
SNR Margin (dB): 9.3 9.0
Attenuation (dB): 56.0 31.5
Output Power (dBm): 12.5 19.4
Attainable Rate (Kbps): 5376 960
Rate (Kbps): 4800 896
K (number of bytes in DMT frame): 151 29
R (number of check bytes in RS code word): 16 8
S (RS code word size in DMT frame): 1 8
D (interleaver depth): 64 8
Delay (msec): 16 16

y con el hawei me da solo 3780 /898 con hardreset y todo.
Por cierto es mi tope joder algo han cambiado por que rara vez pillava esos 4800.
Lo que si he notado es que el cabron del spliter se me come unos cuantos kb en subida pero la estavilidad que da es brutal.
PD:Creo que para mi atenuacion my linea despues de ver el tema de atenuaciones no me puedo quejar.. casi 5m con 56 db

BocaDePez
BocaDePez

Hola a todos, me gustaria saber como le habeis metido el firmware porque yo se lo meto y no me conecta. A ver si alguno de vosotro me lo explica mejor porque cuando lo pongo no navega ni nada. Me sale todo bien pero a la hora de conectarse no va.

Saludos y gracias

🗨️ 1
Ari

¿ Has probado a resetear ?

Saludos

aNews2K

He intentado varias veces descargarme este firm, pero el enlace no es valido...

Espero que lo arreglen pronto.

Saludos!!

🗨️ 5
Ari

Hoy se van a subir varios firms, entre ellos este, a su nuevo alojamiento en la página: mis disculpas a todos por los inconvenientes causados :)

Saludos

🗨️ 4
OzzyOsbourne

Alguien con jazztelia ha podido usar este firm?¿ Te pregunto a ti por si tienes mas informacion que la del hilo....

🗨️ 1
Ari

No lo sé, pero es posible que sí, pero para hacerlo habría que habilitar una nueva conexión en el apartado advanced setup---wan, con los datos correspondientes a la conexión de Jazztelia.

A ver si lontxo te lee, él tiene Jazztelia, u otro usuario con este servicio, y nos puede comentar si lo ha probado o no.

Saludos

aNews2K

Sobre que hora estará disponible el enlace?

Un saludo y gracias!

🗨️ 1
Ari

Bueno, pues parece que no me deja pegar el nuevo enlace en el mensaje principal de este hilo, así que dado que la longitud de este también es bastante prudencial, abro un nuevo hilo , ya con el enlace actualizado, y para que sigáis posteando vuestras dudas con respecto a este firm abro un hilo nuevo, que es este http://bandaancha.eu/tema/1635598/nuevo-firm-no-oficial-para-hg520-v300-2o-parte.

Saludos y cierro