BandaAncha.eu

Comunidad de usuarios
de fibra, móvil y ADSL

Nomodeset y noapic, ¿ralentizan el sistema?

BocaDePez
BocaDePez

En una reciente instalación de Slackware 14 tuve que añadir nomodeset al kernel porque la gráfica no soportaba modesetting. El arranque era errático: a veces iniciaba y otras no, así que tuve que añadir también noapic.

Ahora, el sistema se vuelve muy lento y KDE parece no responder bien, va a pedales.

Esto no me pasaba con versiones anteriores. ¿Es normal con estos parámetros, se puede hacer algo?

Gracias de antemano.

mceds

¿Es una nVidia? Con la "nueva" que le puse hace unas semanas, también me recomendaban el modeset en algún tutorial. Lo hice y tuve problemas con las X. Lo quité, claro, y todo va muy fino. ¿Que problemas encuentras sin modeset?

BocaDePez
BocaDePez

El arranque se queda indefinidamente en:

error fb: conflicting fb hw usage radeondrmfb vs VESA VGA - removing generic driver

🗨️ 2
mceds

¿Con o sin? (modeset)

Alex B

Tiene pinta que se están peleando los drivers del Framebuffer para radeons y el Vesa framebuffer???

Si son módulos haz un blacklist de uno de los dos a ver..

Alex B

Nomodeset, lo mas seguro, porque deshabilitas el KMS, que permite utilizar DRI2?, etc que mejoran el rendimiento gráfico.

No apic,lei por algun sitio que afectaba a sistemas multicpu/multicore sobretodo, pero el impacto sobre un monocore es bastante bajo.

Ambas hacen empeorar el rendimiento.

🗨️ 8
BocaDePez
BocaDePez

Gracias alecuba16, el micro es un P4 a 3,06 con HT (sin activar).

Probaré a desactivar vesa en blacklist...

🗨️ 7
Alex B

De nada, ya nos contaras si consigues resolverlo.

🗨️ 6
BocaDePez
BocaDePez

No me olvidé, volví por allí ayer y probé varias cosas. Radeonfb aparece como blacklist en /lib/modprobe.d/framebuffers.conf, lo comenté sin resultado. Vesafb no aparece y no existe el módulo en el sistema.

Um, no sé qué hacer, el sistema se vuelve realmente intratable y me están dando ganas de cambiar a alguna distro fácil a ver si maneja mejor el problema, y no quiero volver a entrar en el odioso distro-hopping. ¡Cachis!

🗨️ 2
BocaDePez
BocaDePez
BocaDePez
BocaDePez
1
BocaDePez
BocaDePez

A ver, he conseguido saltar el error con vga=normal pero necesito sí o sí iniciar con noapic ya que, en caso contrario, se queda colgado en la línea "Mounting local filesystem".

¡El sistema sigue a pedales y no encuentro la causa! ¿noapic?

🗨️ 1
BocaDePez
BocaDePez
BocaDePez
BocaDePez

Resuelto a medias el problema de la lentitud:

La solución pasa por utilizar un kernel sin soporte SMP (vmlinuz-huge-3.2.29 en vez de vmlinuz-huge-smp-3.2.29-smp). La máquina tiene un procesador Pentium4 con HyperThreading (HT) y por alguna razón necesito activar el HT en la BIOS para que no se quede colgado, cuando éste siempre estuvo desactivado. No funciona tan veloz como el kernel SMP de la versión 13.1 que corría con anterioridad pero la mejora es significativa.

vukits

noapic es para usar durante la instalación ... no es para uso día a día..

🗨️ 1
BocaDePez
BocaDePez

Interesante. Osea que es para arrancar y arreglar algo y no como solución fija, al igual que puede ser nomodeset.

A ver si consigo que la resolución de fb se entienda con KMS. Ya os contaré.

BocaDePez
BocaDePez

Solución:

🗨️ 2
BocaDePez
BocaDePez

Si, pero no para todas las cosas, compila el Openwrt en Windows XP sin usar ninguna herramienta de linux.

🗨️ 1