Banda Ancha EU

Comunidad de usuarios
de fibra, móvil y ADSL

ADSL/VDSL

No hay comunicacion entre hosts

BocaDePez
BocaDePez

Hola, vereis, tenemos un problema... tengo una instalacion la cual consta de 3 oficinas, las cuales estan interconectadas via radio a traves de enlaces. El ADSL, por cuestiones de cobertura, entra a traves de la Oficina 3, que es independiente de las otras dos y con la cual no necesito comunicacion local con los equipos que alli hubiera (me interesa que esten aislados, es decir, ellos solo acceso a internet). Desde ahi, se sale via radio a la Oficina 2 que es la central y de ésta a la Oficina 1, en efecto es una red en cascada. Yo desde la Oficina 2, donde tengo el router D-Link con DHCP, si que puedo ver todos los clientes que estan conectados, tanto en esa oficina como en la Ofi.1, pero a la hora de utilizar Ntop, o carpetas compartidas, de la Oficina 1 no veo ni me sale nada, ni el trafico, ni carpetas, ni equipos... En cambio desde la Of. 1, si hago un scan si que veo los equipos de la 2. A todos los router puedo acceder tanto desde la 1 como desde la 2, no siendo así al de ASDL de la Oficina 3, que a partir del D-link ya no se puede entrar a su ip, tengo que conectarme al router que esta antes de él. Con la configuracion actual todos los equipos tienen salida a internet pero desde la 2 no veo los de la 1.

Despues de estar revisando una y otra vez todos los posts que he encontrado al respecto, creo que ya no me queda nada mas por probar, solo añadir que dudo tambier acerca de que DNS poner, ya que unos dicen que la ip del router, otros que las de Google... Y pedir ayuda a ver si alguna amable persona me echa un cable ;).

- A continuación, adjunto el mapa de red para que se pueda comprender mejor, asi como la configuracion actual de cada dispositivo. Saludos y gracias de antemano.

(link roto)

BocaDePez
BocaDePez

La descripción y el gráfico (por cierto, demasiado pequeño) no concuerda. Creo que has intercambiado las etiquetas de "OFFICE 1" y "OFFICE 2" en la imagen.

Si no ves el router ADSL de la oficina 3 nada más que desde el equipo RECEP1, será porque RECEP1 está haciendo NAT en vez de enrutar. ¿Me equivoco si digo que sales a Internet haciendo triple NAT? Es que no queda claro qué equipos están haciendo traducción de red. Me lo sugiere la extravagante conexión entre RECEP1 y DLINK a través de una segunda subred 192.168.2/24

¿Puedes pegarnos un traceroute desde 192.168.1.100 a 192.168.1.105 y viceversa?

vukits

'Gateway' sólo debe estar definido en los equipos cliente ...

Me parece que tienes un problema de NAT con los enlaces WiFi ,... no creo que sean todo lo 'transparentes que deberían ser.. .. que puede estar en varios sitios:

--El router con Openwrt no debería tener Gateway ni WAN IP ... (no uses su puerto WAN, si es que lo tiene).

-- en 'Enlace Transparente' ... que no sea totalmente transparente

--El 'recep1' debe estar en modo client bridge (i.e. multiples clientes cableados , un enlace Wifi, sin NAT) o WDS (no creo que tu router adsl soporte WDS ..)

ya nos contarás

🗨️ 7
BocaDePez
BocaDePez

Hola de nuevo, gracias por responder y perdon si no quedo del todo claro, ademas resubire el mapa porque es cierto que en el enlace se ve mal.

Por otro lado, supongo que la configuracion actual no sea la correcta, pero he probado distintas que me han sugerido y el resultado es siempre el mismo: internet en todos pero entre oficinas distintas nada.

Quiza sera mejor omitir todas las configuraciones de la imagen, y empezar de cero. Y ver segun vuestro criterio, cual seria mas correcta; sin olvidar que, la red local de la oficina 3 que es por donde entra el ADSL, NO debe ver los demas equipos y que la IP del ADSL Router es 192.168.1.1. A continuación dejo el nuevo enlace con algun detalle mas, y una pequeña plantilla, para ahorraros tener que teclear tanto... ;)

(link roto) Mapa editado y resubido.

OFICINA 3 ADSL:

Debe estar aislada del resto de equipos (las demas Ofi. no importa si le ven los equipos a esta)

IP Router: 192.168.1.1

Mask:255.255.255.0

DNS: 8.8.8.8

OFICINA 2 CENTRAL:

RECEP1 WIFI:

IP WAN: 192.168.1.210 estatica

IP Router: 192.168.2.1

Mask:255.255.255.0

Puerta de enlace: 192.168.1.1

DNS: 192.168.1.1

DHCP: ON (si OFF, no hay conexion)

D-Link ROUTER:

IP WAN: 192.168.2.220

IP Router: 192.168.1.2

Mask:255.255.255.0

Puerta de enlace: 192.168.2.1

DNS: 192.168.1.1

DHCP: ON

Bridge TX Access Point:

IP Router: 192.168.1.22 estatica

Mask:255.255.255.0

Puerta de enlace: 192.168.1.2

DNS: 192.168.1.2

OFICINA 1:

Bridge RX Cliente:

IP Router: 192.168.1.33 estatica

Mask:255.255.255.0

Puerta de enlace: 192.168.1.2

DNS: 192.168.1.2

Router Open-WRT:

IP WAN: OFF

IP Router: 192.168.1.3

Mask:255.255.255.0

Puerta de enlace: 192.168.1.2

DNS: none

DHCP: OFF

Gracias de nuevo y un saludo.

🗨️ 5
BocaDePez
BocaDePez

Quizás no debas elegir en ImageShack reescalar a 800 pixels la imagen, porque no se ve bien.

Ayer te pedí un par de traceroutes entre las oficinas 1 y 2. ¿Puedes pegarlos, por favor? Así vemos realmente los saltos entre las máquinas.

Hay que descartar primero que haya problemas de enrutado, para centrarnos después en posible bloqueos de puertos en cortafuegos.

Por supuesto, si hay NAT, la has fastidiado. No verás nada. Los bridges tienen que ser completamente transparentes y permitir paquetes de broadcast (difusión).

🗨️ 3
BocaDePez
BocaDePez

Hola! si disculpa, que ayer se me paso pegarlo..

ofi2 a ofi1:

traceroute to 192.168.1.105 (192.168.1.105), 30 hops max, 60 byte packets
1 192.168.1.105 (192.168.1.105) 4.188 ms 4.279 ms 4.460 ms

ofi1 a ofi2:

traceroute to 192.168.1.100 (192.168.1.100), 30 hops max, 60 byte packets
1 192.168.1.100 (192.168.1.100) 8.122 ms 8.576 ms 8.757 ms

desde PC0 a google por si sirve de algo:

PC0@PC0:~$ traceroute www.google.com
traceroute to www.google.com (*.*.*.*), 30 hops max, 60 byte packets
1 192.168.2.1 (192.168.2.1) 5.589 ms 5.668 ms 5.749 ms
2 192.168.1.1 (192.168.1.1) 16.760 ms 17.639 ms 18.165 ms
3 *.*.*.* 49.477 ms 50.754 ms 56.481 ms
4 *.*.*.* 50.095 ms 51.298 ms 53.220 ms
5 *.*.*.* 70.933 ms
6 *.*.*.* 70.439 ms 42.798 ms 48.045 ms
7 * * *
8 * * *
9 * * *
10 * * *
11 * * *
12 * * *
13 * * *
14 * * *
15 * * *
16 * * *
17 * * *
18 * * *
19 * * *
20 * * *
21 * * *
22 * * *
23 * * *
24 * * *
25 * * *
26 * * *
27 * * *
28 * * *
29 * * *
30 * * *

🗨️ 2
BocaDePez
BocaDePez
BocaDePez
BocaDePez
BocaDePez
BocaDePez
Imagen original en http://img189.imageshack.us/img189/1540/mapa1m.png

Este es el enlace real.