BandaAncha.eu

Comunidad de usuarios
de fibra, móvil y ADSL

Fibra/Cable

No funciona SSH, incluso abriendo puertos, desactivando firewall.. DISCO EPC 3825

BocaDePez
BocaDePez

Pues nada, que por temas de trabajo me ha surgido la necesidad de conectarme por SSH a un servidor para cambiar unas cosas y no hay manera.

Desde el trabajo me han dado opción de conectarme por el puerto 22 y 27, los he abierto y no hay forma de hacer que funcione. De hecho he abierto otro puerto de ejemplo y con una utilidad web de comprobación de puertos, este puerto de ejemplo si que me dice que está abierto, pero ni el 22 ni el 27 me dicen que están cerrado.

¿Hay alguna forma de hacer que funcione? Me urge bastante por el trabajo... :(

Gracias a tod@s!!

quilloquepasa
1

Si el test de puertos lo haces desde el PC cliente, siempre, siempre, siempre, te aparecerán cerrados, habida cuenta que donde debes tener abiertos los puertos es en el lado del servidor y desde allí realizar el test.

En el lado del cliente no es necesario abrir puerto alguno.

Saludos ;)

BocaDePez
BocaDePez

¿Y como es posible que en el ordenador del curro, hace 15 minutos, me dejara siendo que el servidor está contratado vete tu a saber donde, y llego a casa y no me funciona? En el curro tenemos un ADSL mondo y lirondo, y en casa una conexión normal a ONO.

No lo acabo de entender :(

Si puedes probar tu a ver si te deja, simplememente a ver si llegas al prompt de que te pida user y pass... ---

🗨️ 1
txuspe

Yo conecto sin problemas desde ONO también.

BocaDePez
BocaDePez

¿El servidor SSH está en tu casa? Si no es así, si el servidor está en las oficinas donde trabajas, no tienes que abrir ningún puerto en el router de tu casa. Eres tú quien inicias la conexión desde dentro.

El problema será otro. Tal vez el cortafuegos de tu PC. ¿Qué cliente SSH usas? ¿Te ha solicitado permiso el sistema operativo (o quizas alguna suite antivirus, que tenga funcionalidades de cortafuegos) para darle paso?

BocaDePez
BocaDePez

He desactivado el antivirus, firewall y demás, también el firewall del router.

Ahora voy a llamar al servicio técnico de la empresa de hosting, porque tampoco puedo acceder a mi cpanel, que ya es más mosqueante... -.-

Y eso que lo hemos contratado hoy, bien empezamos...

🗨️ 2
BocaDePez
BocaDePez

He visto que has puesto la IP en un mensaje anterior. Yo pruebo a entrar, me da el hash, me autodetecta SSH2 y me pide login y password. Obviamente test/test no va :D

Repito... ¿qué cliente SSH usas?

BocaDePez
BocaDePez

¿Te llegan los traceroutes bien? El servidor está en Hostalia y se llega por la red de Acens.

BocaDePez
BocaDePez

¿Has hecho muchos intentos fallidos? Si puedes forzar un cambio de IP, yo lo haría e intentaría de nuevo. Por descartar una cosa más.

BocaDePez
BocaDePez

Vaya, el acceso al CPanel ya funciona, me han comentado los del servicio técnico que por un fallo anterior se había puesto la contraseña antigua y no la nueva.

Pero el SSH nada, sigue sin funcionar. A través del panel de control puedo abrir una aplicación que mediante Java me abre una consola en una ventana del navegador, y me funciona. No es que sea lo mejor, porque no funcionan muchas cosas como el tabulador para autocompletar ordenes, pero algo es algo.

Aun así me mosquea mucho, ¿porqué cojones no puedo entrar? No he realizado muchos intentos, a la primera ya me ha cortado. El putty me dice "connection refused" -.-

🗨️ 1
BocaDePez
BocaDePez

Desde luego es que son para matarlos... Yo intentando por todos los medios acceder por el puerto 27, que es el que me han dicho que entre, y en el curro de hecho he podido entrar por ahí. Y pruebo el 22 y funciona.

No acabo de entender porqué en el curro el 27 funciona y aquí no pero bueno... Cosas de la informática, ¿no?...

Por cierto, mil gracias a todos, alucino a la velocidad que respondéis... GRACIAS :D

🗨️ 2
BocaDePez
BocaDePez

Bueno, si algún moderador lee esto, deberían entonces quitar la IP del principio del hilo ;)

🗨️ 1
superllo

Hecho.