BandaAncha.eu

Comunidad de usuarios
de fibra, móvil y ADSL

No funciona Alt Gr en Debian

FishMouth

Bueno, pues voy solucionando problemillas, pero este me supera, no consigo que la tecla Alt Gr funcione, o sea, que ni puedo escribir arrobas ni almohadillas y es un poco palo tener que buscar textos que las contengan y hacer copy/paste todo el rato. La tecla funciona, comprobado en Mandrake, el teclado esta configurado con layout spanish y como 101 teclas.

Ideas? Gracias por adelantado!

Edito: por si sirve de algo, uso Debian Sid con gnome 2.6.

Reedito: Cuando arranco Debian me aparece esto en una ventana de error.

Error activating XKB configuration.
Probably internal X server problem.

X server version data:
The XFree86 Project, Inc
40300001
You are using XFree 4.3.0.
There are known problems with complex XKB configurations.
Try using simpler configuration or taking more fresh version of XFree software.
If you report this situation as a bug, please include:
- The result of xprop -root | grep XKB
- The result of gconftool-2 -R /desktop/gnome/peripherals/keyboard/xkb

Este tema está cerrado a nuevas respuestas. Abre un nuevo tema para retomar la conversación.
BocaDePez
BocaDePez

Mirate el mapa del teclado en el centro de control de gnome... yo lo resolvi asi pero en kde ;)

undertow

añade en el ficherito de config de las x ( /ex/X11/XF86Config-4) en la seccion del teclado:
option "nodeadkeys"

o en dpkg-reconfigure xserver-xfree86 en las opciones del teclado ( cuando las pregunte ): nodeadkeys

🗨️ 1
FishMouth

He probado esto que me comentas y nada, todavía no tengo arrobas...

BocaDePez
BocaDePez

hola, ese error !!!! madre mia.......

Como Root ejecuta " setxkbmap -rules xfree86 -model pc105 -layout es -option"

Y ya está.

un saludo.

🗨️ 2
Pridebowl

Buenas tardes

Que yo recuerde era cuestión únicamente del "-layout es". :)

Un saludo

BocaDePez
BocaDePez

Pues no me acaba de funcionar fino el tema, pongo lo que comentas y me pasa esto:

refried@debian:~$ su
Password:
debian:/home/refried# setxkbmap -rules xfree86 -model pc105 -layout es -option
Xlib: connection to ":0.0" refused by server
Xlib: No protocol specified

Cannot open display ":0.0"

Y sigo sin arrobas ni almohadillas....

FishMouth

Muchas gracias por las respuestas, esta noche lo pruebo que estoy muy liado!

FishMouth

Problema solucionado!! Ya tengo arrobas y almohadillas! El problema era esto en la config:

"XkbVariant" "es"

Solo con eliminarlo se ha arreglado el tema!

PD: @@@@@@###### ;-)