BandaAncha.eu

Comunidad de usuarios
de fibra, móvil y ADSL

Necesito AYUDA con el ipw2200 (AL FIN SOLUCIONADO!)

anthrax

Buenas,
no pediría ayuda si realmente no la necesitara, pero es que no hay manera de que me funcione la wireless Intel PRO/Wireless 2200BG de mi portatil HP. Yo lo que quiero que funcione es lo siguiente:

1) En modo managed/ad-hoc en modo open (sin encriptación) y con encriptación wep ( y si se puede wpa :P )
2) Y que de paso también me funcione en modo monitor ... :D
3) Que no tenga problemas con el envio de paquetes broadcasts!!!!

Yo ya he probado diferentes kernels, versiones del driver ipw2200, versiones de firmaware, versiones de pila 802.11 (todo esto con y sin parches que supuestamente solucionan bugs de lo que no son últimas versiones).

Y no hay manera de que me funcionen las tres cosas que quiero. Y la verdad es que ya me sé de memoria los documentos README/INSTALL de todos los componentes necesarios.

Así que agradecería la ayuda de todo aquel que tenga mi modelo de tarjeta wireless y le funcionen las cosas que quiero. Bastaría que me dijera que versiones utiliza de lo siguiente:

driver ipw2200
driver iee80211
(si ha aplicado algún parche para lo anterior)
kernel
firmware ipw2200
que opciones ha activado en el kernel

Y me pegase la salida de este comando:

dmesg | egrep 'ipw2200|ieee80211'

Porque creo que no se me instala bien la pila 802.11

La última que me ha pasado con este tema es que la activar el modo monitor (al hacer el modprobe ipw2200 mode=2), empieza a salir por pantalla un mensaje de error del firmware (diciendo que hace un restart) que se repite a gran velocidad. Tal es así que tengo que quitar el módulo ipw2200, sino no puedo ni trabajar ...

Las versiones usadas cuando me pasa esto son:
kernel 2.6.14
iee80211 1.1.6
ipw2200-1.0.8
firmware ipw2200 2.4

Lo "jodio" de todo esto es que en su día me funcionaba, pero fue actualizar el kernel y los drivers y dejar de funcionarme el invento :(

Creo recordar que el kernel era un 2.6.12.X o 2.6.13.X y el driver ipw2200 1.0.6. Pero desde entonces nada de nada ...

Ya no sé que hacer, estoy por comprarme una wireless pcmcia y pasar olimpicamente de la intel ... :(

Gracias por adelantado :)

Saludos :|

Este tema está cerrado a nuevas respuestas. Abre un nuevo tema para retomar la conversación.
merakebas

Buenas,
tengo exactamente tus versiones desde esta mañana, y creo que las cosas me han empeorado, pero en ad-hoc y monitor me sigue funcionando (probado monitor "mirando" unas cosillas :-p y ad-hoc con wep en mi casa)
Versiones, por si acaso:

kernel 2.6.14
iee80211 1.1.6
ipw2200-1.0.8
firmware ipw2200 2.4

Durante una semana he estado con lo mismo, pero kernel 2.6.12, y no me daban ciertos errores, como el que voy a mostrar ahora:

# dmesg | egrep 'ipw2200|ieee80211'
ieee80211_crypt: registered algorithm 'NULL'
ieee80211: 802.11 data/management/control stack, 1.1.6
ieee80211: Copyright (C) 2004-2005 Intel Corporation
ipw2200: Intel(R) PRO/Wireless 2200/2915 Network Driver, 1.0.8
ipw2200: Copyright(c) 2003-2005 Intel Corporation
ipw2200: Detected Intel PRO/Wireless 2200BG Network Connection
ipw2200: Firmware error detected. Restarting.
ipw2200: Sysfs 'error' log captured.
ipw2200: Firmware error detected. Restarting.
ipw2200: Sysfs 'error' log already exists.

Y lo del syslog me ha pasado esta mañana de modo que ni se me apagaba el portatil...

En cuanto a mi config del kernel

/usr/src/linux# grep -i wireless .config
# Wireless LAN (non-hamradio)
# Obsolete Wireless cards support (pre-802.11)
# Wireless 802.11b ISA/PCI cards support
CONFIG_NET_WIRELESS=y

/usr/src/linux# grep -i hotplug .config
CONFIG_HOTPLUG=y
# PCI Hotplug Support
# CONFIG_HOTPLUG_PCI is not set

Y nada más al respecto, creo. He tenido bastantes problemas con este driver, no me acaba de convencer, pero ahora mismo estoy escribiendo esto a través del mismo.

Saludos

Editado. Si quieres cualquier otro dato, avisa :-)

🗨️ 7
anthrax

pero el error que da:

pw2200: Firmware error detected. Restarting.
ipw2200: Sysfs 'error' log captured.
ipw2200: Firmware error detected. Restarting.
ipw2200: Sysfs 'error' log already exists.

es justamente el que comento en mi post. El que hace que sea imposible hacer nada debido a lo rápido que se que escribe por consola de manera repetitiva. A mi me ocurre ese error cuando activo el modo monitor al cargar el modulo (modprobe ipw2200 mode=2) y justo con las mismas versiones de kernel,driver y firmware que tienes tú. Tengo que descargar el módulo si no no hay manera de hacer nada :(

En cambio en modo managed o ad-hoc ese error no me lo da.

Y dices que el wep te funciona bien, no? Pensaba que cuando en el dmesg te decía esto (lo que me pasa a mi):

ieee80211_crypt: registered algorithm 'NULL'

el wep no funcionaba. Pero debe ser por otra cosa que no me funciona el wep :(

Probaré la configuración que tenias tú antes:

kernel 2.6.12
ipw2200-1.0.8
ieee80211-1.1.6
ipw2200 firmware 2.4

a ver que tal :)

Saludos 8)

🗨️ 6
merakebas

Ese error que te comento, me aparece en los logs "normalmente", pero sólo una o dos veces.

Y, excepcionalmente, en una de las veces que lo he usado, al apagar el portatil, no paraba de salir ese error, (supongo que lo que te pasa a tí, cada 1 o 2 segundos, el mensajito) y así el portatil nunca se apagó.

No he hecho nada para solucionarlo, asi que poco más te puedo decir, solo me pasó esa vez :-( De todas formas, por lo que he visto en el archivo de la lista de mails, no somos los únicos a los que nos ha pasado (bughost.org/bugzilla/show_bug.cgi?id=802)

Saludos, y suerte :-)

🗨️ 5
anthrax

Yo estoy flipando mandarinas! xD

Si me pudieras pegar aqui el contenido de tu fichero .config de tu kernel actual. Así podría compararlo con el mio. También si me pudieras decir que pasos sigues para instalar el driver ipw2200, el ieee80211 y el firmware.

Otra cosa, dime la versión del gcc que tiene tu portatil. La del mio es una 4.X

Muchas gracias

Saludos 8)

🗨️ 4
merakebas
🗨️ 1
anthrax
merakebas
🗨️ 1
anthrax
BocaDePez
BocaDePez

(link roto)

¿Quien soy? xD

Te ayudaria, pero lamentablemente mi ""flamante"" Troshiba Mierda30 ha sufrido un casque total de disco duro, ahoa cuando enciendes oyes un sonoro "clon clon clon clon" durante 3 minutos y se apaga sin pasar de arrancar la BIOS xD

Llevo dos semanas que juro que como dure esto mas me hago al Hare Crisna.

Pega unos cuantos errores o avisos del dmesg a ver :P

Un saludo.

🗨️ 1
anthrax

Eso te pasa por usar gentoo y tener tantas horas compilandote el vim ( ya sabes de que hablo ;) )

No hay aire acondicionado que valga para bajar la temperatura :P

Saludos 8)

Psm1

La verdad que el tema de versiones anda muy liado últimamente, en el kernel 2.6.14, ya viene con el soporte con la versión 1.0.0 de ipw2200, pero la verdad que esa versión es un poco mala comparada con las recientes. Así que si te instalas el último kernel y lo configuras bien... debería funcionarte (sin modo monitor :S).

PD: Mi disco duro esta perfectamente, y también tiene gentoo ;-).

🗨️ 1
anthrax

;)

anthrax

Finalmente he conseguido que no salga este error del kernel:

Mar 12 00:48:45 bebop kernel: ipw2200: Firmware error detected. Restarting.
Mar 12 00:48:45 bebop kernel: ipw2200: Sysfs 'error' log already exists

(cada segundo) cada vez que activaba el modo Monitor en la tarjeta wireless 2200BG :D

Ha sido al actualizar a la última versión del driver y del firmware (1.1.1 y 3.0).

Con las anteriores (1.1.0 y 2.4) seguia pasando el error, tanto era así que el thread del driver de la tarjeta (ipw2200/0) me comsumia aproximadamente entre un 70-80% de la cpu ... :(

La versión del kermel que uso es la 2.6.15.5

Saludos 8)

🗨️ 2
FrAnS

Se que ahora no te sirve de nada que te lo diga, pero bueno, ahí va: El error en el firmware que hace reiniciar el driver se debe a que el cifraje por hardware nunca ha funcionado bien del todo, para evitar los reseteos había que cargar el módulo con el parámetro hwcrypto=0 para que el cifraje se hiciera por software. Ahora te funciona porque en esta nueva versión por fin han puesto hwcrypto=0 por defecto, está en el change-log.
Siento no haberte sido de gran ayuda ahora, llevaba un tiempo desintoxicandome y no me pasaba por aquí, yo también he sufrido esos dolores de cabeza.

Enga Saludetes!

🗨️ 1
anthrax

Pero con el driver 1.1.0 y el firmware 2.4 aún me dabe el error de reinicio de firmware :)

No ha sido hasta usar el driver 1.1.1 y el firmware 3.0 que se ha solucionado el error al poner la tarjeta en modo Monitor

Lo de deshabilitar el encriptado por hardware ya se deshabilita por defecto desde la versión 1.0.11 del driver

Saludos 8)
P.D: Lo importante es que ya me funciona al 100% todo lo que quería :D

anthrax

donde se especifica que en el nuevo firmware (3.0) ya no se producen los errores continuos de reinicio al poner la tarjeta en modo monitor:

Upgrade 1.1.0 to use new 3.0 fw image format: patch

The 3.0 fw image does not add any new capabilities, but it should

 fix two problems experienced by users:

 1) Race conditions with the request_firmware interface and udev/hotplug

 are improved as only a single request_firmware call is now required to

 load the firmware and microcode (vs. 3 separate calls previously)

2) The monitor mode firmware (sniffer) is now packaged with the correct

 boot image so it can now function without frequent restarts.

 Once you apply the above, you will also need to upgrade your firmware

 image to the 3.0 version available from downloadable from:

 http://ipw2200.sf.net/firmware.php

Aunque este texto es sobre parchear la versión del driver 1.1.0 para que soporte la última versión de firmare, en el punto 2) se comenta que con el firmware 3.0 se soluciona el problema que me tenía frito :)

Saludos 8)