BandaAncha.eu

Comunidad de usuarios
de fibra, móvil y ADSL

En Mozilla Firefox no puedo instalar Ublock ni ningún complemento

Kissio
1

Hasta ayer me funcionaba correctamente el complemento Ublock del navegador Mozilla.

Hoy por la mañana, conecto mi equipo como siempre y me dice que Ublock se ha desactivado él sólo ( ! ).

Cuando lo quiero reinstalar, me sale desde Mozilla el siguiente mensaje:

"Falló la descarga. Comprueba tu conexión."

Y no me deja instalar ese ni ningún complemento.

No sé dónde tengo el fallo en mi conexión, tengo internet perfectamente, de hecho estoy escribiendo aquí.

He desinstalado Firefox, limpiado temporales, reiniciado el equipo, vuelto a instalar y me sale lo mismo.

Mi equipo es un portátil Toshiba Z930 con Win 10 Pro 1809 17763.475

De antivirus solo tengo el Windows Defender.

BocaDePez
BocaDePez

A mí me pasa igual pero con android.

🗨️ 1
BocaDePez
BocaDePez

Tienes nueva actualización para Firefox en Android. Ya no desactiva las extensiones. Un saludo.

Kissio

Buceando en el Mozilla, creo que encontré la solución por si alguien más le sucede, os dejo el enlace de soporte de Mozilla por aquí, parece ser que hay un fallo con un certificado a la hora de instalar complementos y que funcionen:

discourse.mozilla.org/t/fixed-certificat…tall/39047/4

userfiber
2

En la madrugada de hoy ha caducado un certificado SSL intermedio de la organizacio Mozilla -Firefox, el cual se ha estado usando para firmar los plugins de navegador Firefox, A alguien se le ha pasado la fecha jeje.

Y como desde 2017 es obligatorio tener el plugin firmado y con una firma valida, al no estar vigente lo considera un plugin no valido.

Segun dicen en el bug report ...estan ahora mismo probando el parche para este problema.

discourse.mozilla.org/t/fixed-certificat…tall/39047/8

twitter.com/mozamo

🗨️ 2
BocaDePez
BocaDePez

Pues a ver si llega ya de una santa vez la actualización!!

BocaDePez
BocaDePez

Gracias por la info, se me desactivó Fixed Zoom por lo mismo, no pudo ser verificado y se autodesactivó, en cambio uBlock lo tengo instalado desde los repos en un sistema no Windows y puedo navegar sin publi.

BocaDePez
BocaDePez

Me pasa lo mismo en Linux mint

BocaDePez
BocaDePez

Alucino

12:50 p.m. UTC / 03:50 a.m. PDT: We rolled-out a fix for release, beta and nightly users on Desktop. The fix will be automatically applied in the background within the next few hours, you don’t need to take active steps.

In order to be able to provide this fix on short notice, we are using the Studies system. You can check if you have studies enabled by going to Firefox Preferences -> Privacy & Security -> Allow Firefox to install and run studies.

You can disable studies again after your add-ons have been re-enabled.

We are working on a general fix that doesn’t need to rely on this and will keep you updated.

BocaDePez
BocaDePez

A mi me ha vuelto a la normalidad recuperando el perfil anterior y haciendo lo siguiente:

Ir a about:config

Buscar xpinstall.signatures.required

Cambiar la opción a false (haciendo doble clic)

Fuente: old.reddit.com/r/firefox/comments/bkhtv8…ddons_being/

Según este hilo si no activasen esa opción por defecto no hubiese pasado esto, el que quiere instalar un add-on malicioso lo va a instalar sí o sí, es como las ventanas de confirmación de Windows, que ni las leemos.

old.reddit.com/r/firefox/comments/bkgbjm…hat_forcing/

🗨️ 5
BocaDePez
BocaDePez

Pues ha vuelto a darme el problema, a ver, hay otra solución para habilitar los add-ons: blog.mozilla.org/addons/2019/05/04/updat…-in-firefox/

Basicamente, en Preferencias -> Privacidad & Seguridad -> bajamos a Recopilación y uso de datos de Firefox y marcamos Permitir a Firefox enviar datos técnicos y de interacción a Mozilla y también marcamos Permitir que Firefox instale y ejecute estudios

Con esperar un rato nos habilitarán los addons de nuevo y luego ya según pone podemos volver a desmarcar esas 2 casillas.

🗨️ 4
BocaDePez
BocaDePez

El rato puede ser de 6 horas según pone, ojo, pero a mi me lo ha aplicado en unos 4 minutos o cosa así. Debe haber incluso una opción para acortar esa comprobación pero yo no tocaría nada más.

🗨️ 3
Bramante

A mí me se me han reactivado los add-ons hace unos 10 minutos, justo tras activar Allow Firefox to install and run studies

🗨️ 2
BocaDePez
BocaDePez
🗨️ 1
BocaDePez
BocaDePez
superllo

A mi he ha avisado de que me desactiva los plugins pero mientras no lo cierre no se van a desactivar.

🗨️ 2
BocaDePez
BocaDePez
1

Yo he flipado cuando me han comenzado a salir anuncios a mansalva y veo que ha desaparecido el icono del anti publicidad. Todo por dejarse caducar un certificado, la leche. Eso si, las extensiones las desactiva "al vuelo", sin reiniciar.

🗨️ 1
BocaDePez
BocaDePez

Que las desactive al vuelo, es normal, por seguridad, que tarde en activarlas también.

Lo que no es normal es que les haya caducado el certificado y como han manejado esta incidencia.

BocaDePez
BocaDePez

Buen momento para probar Edge Chromium 😁

Kissio
1

He conseguido volver a instalar el complemento Ublock haciendo lo que dicen desde Mozilla y varios usuarios aquí:

Opciones > Privacidad & Seguridad > Recopilación y uso de datos de Firefox > Permitir que Firefox instale y ejecute estudios (desmarcar esta opción).

Lo único que no sé, a la larga, en qué afecta tener desmarcada esta opción cuando vuelvan a activar el cerificado.

🗨️ 1
BocaDePez
BocaDePez
1

Yo la tengo desmarcada por defecto, no te preocupes, si la tenías marcada se te hubiesen hecho las modificaciones solas. Lo de desmarcarla es para los que la teníamos desmarcada.

mceds
1

Perdón si repito una solución ya expuesta. Para los que usan "empaquetados no oficiales" de Firefox (versiones ESR, Firefox para Android y Firefox para diversas versiones de Linux), hay dos alternativas a la solución propuesta por Mozilla, la de los studies/estudios, que no funciona en esos empaquetados:

  1. Instalar este XPI: storage.googleapis.com/moz-fx-normandy-p…2-signed.xpi . Firmado por Mozilla.
  2. Si aun así no os fiáis, otra solución es ejecutar este comando:
sed -i -e 's/"appDisabled":true/"appDisabled":false/g' \
       -e 's/"signedState":-1/"signedState":2/g' \
    ~/.mozilla/firefox/*.default/extensions.json

... donde "*.default" es vuestro profile (el que sale como Default si escribís about:default en la barra de direcciones).

Si no disponéis de "sed" (no sé si será fácil de instalar y ejecutar en Android), tenéis que editar el fichero extensions.json a mano y cambiar todos los "appDisabled":true por "appDisabled:false", así como todos los "signedState":-1 por "signedState":2 .

Y lo suyo sería dejarlo como estaba cuando todo vuelva a la normalidad.

🗨️ 1
BocaDePez
BocaDePez

Muchas gracias Mceds, funciona de maravilla.

BocaDePez
BocaDePez

Si ya de por sí Firefox no lo usa casi nadie, esto es la puntilla. Se han lucido 🤦🏻‍♂️

🗨️ 2
mceds

Sí, Dios mío, van a cerrar mañana mismo y sus responsables se harán el seppuku y colgarán el vídeo en las redes. En Dailymotion, para joder a Google.

Qué ganas tenéis algunos de enterrar a Firefox. Gilipollez absoluta porque ya sabemos todos lo que implican los monocultivos en el ámbito del software. Y darle todo el poder a una sola empresa, también.

pepejil

El segundo navegador más usado, excluyendo los Webview de los móviles... Y para ti "no lo usa nadie".

BocaDePez
BocaDePez

Han sacado ya nueva versión que no desactiva las extensiones, para desinstalar el hotfix que se descargaba manualmente se puede ir al directorio ~/.mozilla/firefox/{PERFIL}/extensions/ y borrar

Un saludo.

pepejil

Esta mañana me pasó lo mismo en Firefox para Android. Error en no se qué CDN de Mozilla y a su vez me avisa de que uno o más complementos se han bajado corruptos. Todos ellos desactivados.

Ahora mismo antes de hacer nada, he forzado actualización en Firefox en escritorio, 66.0.4 y he forzado actualizaciones de complementos. Cero problemas. Mañana haré la prueba en Android.

🗨️ 1
pepejil

Firefox para Android actualizado y los complementos desactivados vuelven a funcionar sin hacer nada más.

Así que con actualizarlo es suficiente.

BocaDePez
BocaDePez

Muchos de nosotros tenemos el Firefox, yo ahora mismo, el Firefox 66.0.4 no falla.

Para ver si os da esto, podéis ver con el about:studies:

hhotfix-reset-xpi-verification-timestamp-1548973•Completo

Este estudio fija el valor de app.update.lastUpdateTime.xpi-signature-verification a 1556945257.

Me pasó exactamente lo mismo anteayer, pero no vi desactivados las extensiones que tengo (solo son 3 extensiones). Y están funcionando sin problema.