Banda Ancha EU

Comunidad de usuarios
de fibra, móvil y ADSL

hosting en interdominios
55 lecturas y 4 respuestas
  • Cerrado

    BocaDePez BocaDePez
    6

    Montar Servdor WEB con Apache

    Hola Amigos,

    Necesitaría que me echárais un cablecillo.

    MI intención es montar un servidor para mi propia web. Tengo una LAN con varios puestos y por lo tanto IP de la propia LAN.
    COn el SpedStream5660 tal como indicáis he abierto los NAPT poniendo la IP en el puerto 80 y con http. Bien, no me funciona, y me estoy volviendo loco para poder hacerlo. Lo pruebo desde anonymizer y nada de nada, me dice que esta bloqueado.

    ¿ Como hago para decirle al SS que cuando venga una petición de mi IP me la pase a la Maquina donde tengo el apache?

    Muchas gracias, sois unos makinas!!!!!!

    Este tema es antiguo y puede contener información obsoleta. Abre un nuevo tema para publicar tu mensaje.
    1
    • Cerrado

      BocaDePez BocaDePez
      6

      lo que no puedes "pretender" es salir a internet desde tu lan…

      lo que no puedes "pretender" es salir a internet desde tu lan por 1 router y volver a entrar en tu lan desde internet por el mismo router... q es justamente lo q estas haciendo, aunque no quieras
      para poder acceder a tu servidor web desde tu lan tienes 2 opciones:
      1 tener 2 routers en tu lan y conectados a internet...1 de ellos para enroutar las llamadas a tu servidor a 1 ordenador de tu lan y usar tu servidor web
      1 el otro para usarlo para q el resto d equipos (todos los de la lan - el del router) para salir a internet desde cualquiera de ellos

      de todas formas si quieres testear el funcionamiento de tu servidor web puedes llamarlos desde tu lan:
      http:/168.0.0.1 (
      o darle a alguien la ip q t asigna tu ISP y en la q tu router lleva las llamadas del puerto 80 a tu servidor web

      espero q t sirva d algo todo esto

      ciao

      • Cerrado

        BocaDePez BocaDePez
        6

        He probado a poner la IP, es decir: http://168.28.0.1:80 que…

        He probado a poner la IP, es decir: http://168.28.0.1:80 que es la ip de mi router y me sale la pantalla de configuración del Spee Stream...
        Le he puesto en el NAPT los datos correctos pero he leido antes que con el apache había que crear una especie de VHOST Virtual Host. He mirado en el apache y no me sale nada para crear eso.
        ¿ Que puedo hacer ?
        Según he visto hay mucha gente a la que le pasa lo mismo.

        • Cerrado

          BocaDePez BocaDePez
          6

          pos eso... lo que estas haciendo con http://168.28.0.1:80 es…

          pos eso...

          lo que estas haciendo con http://168.28.0.1:80 es llamar al router por el puerto 80

          y lo que tu quieres hacer es llamar al servidor WEB http://168.28.0.XXX:80 (ni siquiera deberias poner :80 pq el router ya redirige la llamada de tu navegador al puerto al que hayas enroutado la ip...o sea a tu servidor web)

          a ver si ahora lo consigues

          ciao

          • Cerrado

            BocaDePez BocaDePez
            6
            en el propio manual de que encotraras en el interfaz web del…

            en el propio manual de que encotraras en el interfaz web del router te lo explica, sección server port mapping incluso te pone un ejemplo de lo q te esta pasando:

            For example, assume you have configured the NAPT server to sends HTTP traffic to an HTTP server hosted at 10.0.0.2. HTTP connection requests received on the WAN interface will be routed to the HTTP server on port 80 of the host at 10.0.0.2. It is no longer possible to connect to the HTTP server running on the router from the WAN and the capability to use the web page-based router configuration interface is lost. If, however, you then remap the HTTP server on the router to a new port (such as 8080) and enable WAN access, WAN side clients will be able to access the HTTP server on the router.

            suerte