BandaAncha.eu

Comunidad de usuarios
de fibra, móvil y ADSL

Mismo modelo de módulos RAM pero diferentes medidas de tamaño

cisquito
1

Mi ordenador tiene, actualmente, 4 GB de memoria RAM. Son dos módulos de 2 GB cada uno, concretamente este modelo, Kingston KVR1333D3N9/2G.

Mi idea es ampliar la RAM a unas 12 GB. La placa base soporta, teóricamente, hasta 16 GB. Todavía me quedan dos puertos RAM libres, así que podría ser dos módulo nuevos de 4 GB o uno de 8 GB.

El modelo anterior tiene una versión de 8 GB pero sus dimensiones parecen distintas a los que yo tengo. Aquí la versión de 8 GB.

Comentar que las dimensiones de la versión de 2 GB, según la página de Amazon, no son las correctas. Me he molestado en medir los módulos de mi placa base y son: 13,3 cm x 1,7 cm x 0,3 cm. Las medidas de la versión de 8 GB sí se acercan a las mías pero no son exactas. Así que tengo dudas de adquirir el módulo de 8 GB, ya que las que tengo ahora entran muy justas en los puertos. Aquí una foto de los puertos:

Ranuras RAM
superllo
1

Me has hecho volver a abrir la torre y hacerle una foto:

memram.webp

La RAM que admite es DDR3. La que yo tengo es PC1600. Tengo dos módulos de 2 gigas desde el principio y le metí uno de 8 (el de rojo).

Si estás ampliándolo también te diré que admite i7 de primer generación y Xeon X3470 (a unos 25 euros).

🗨️ 11
cisquito

Gracias, una vez más, por su ayuda.

El problema es que hace poco me pusieron fibra óptica de 700 Mbps. Antes tenía WiMAX de 8 Mbps. Ahora, al descargar, parece que el ordenador se bloquea o más bien el entorno gráfico de GNOME 3 en Debian (GNU/Linux). Había pensado empezar a probar por ampliar la RAM, a ver si mejora. Viendo que a Ud. le funciona, compraré mañana por Amazon el módulo de 8 GB.

Ahora tengo un CPU Intel i5 650 de dos núcleos a 3,20 GHz. No sé si los CPU que referencia Vd. serán mejores (el Xeon parece tener menor velocidad). Y no creo que el i7 valga 25 € (será el Xeon, ¿verdad?)

Un saludo.

🗨️ 3
superllo

Pues me acaba de llegar el Xeon, a ver si este fin de semana lo cambio. Ahora tengo un i5 750 y en las webs de comparación de procesadores pone que el Xeon es un 25% más rápido.

En nuestros ordenadores lo más importante es la RAM, luego cambiar disco duro por SSD (pon la swap en memoria, que ahora te sobra) y ahora voy a ver el tema del procesador. De todas formas tengo previsto cambiar el ordenador entero en unos meses, cuando los nuevos Ryzen bajen de precio.

Ahora me acuerdo de que cuando le puse el módulo de 8 gigas se me paraba el sistema y era porque no le gustaba estar en el slot que lo puse así que dejé los de 4 gigas donde los ves y el de 8 separado.

🗨️ 2
cisquito

Gracias por su respuesta.

Un compañero más abajo comenta que sería más recomendable dos módulos de 4 GB cada uno en vez de uno de 8 GB. ¿No le da a Ud. problemas su RAM tal y como la tiene ahora?

Un saludo.

🗨️ 1
superllo
1

He editado el post para decir que tengo dos módulos de 2 gigas desde el principio, y con el de 8 se me quedan en 12 gigas. Puse que tenía dos de 4.

cisquito

Hola de nuevo.

Estoy mirando los procesadores compatibles con la placa y no aparecen los XEON: CPU Compatibles

Y por el precio que indica Ud. lo habrá comprado en AliExpress. ¿Ese comercio dispone de puntos de recogida o solamente envía a domicilios particulares?

¿Usa Vd. el mismo ventilador que su antiguo i5?

Un saludo.

🗨️ 5
superllo
1

He dejado el ventilador, prácticamente lo único que he cambiado ha sido el procesador, uno por otro (y ya venía con pasta térmica). Tienes que mirar que el procesador sea del socket de la placa y, aunque ponga que no lo soporta, lo hace perfectamente. Puedes buscar más gente que lo ha cambiado por Internet, por eso decidí a hacerlo, porque otros lo habían hecho antes. De todas formas dicen que este Xeon es un i7 870.

Lo he comprado de Aliexpress y le puedes poner que te lo envíen a un Citypaq, que son armarios de Correos.

🗨️ 4
cisquito

Gracias nuevamente.

Después de unos días de fallo en la página de Correos, por fin he conseguido darme de alta en Citypaq y elegir una taquilla de destino.

He comprado en AliExpress este CPU. Me dicen que tardará entre 10 y 20 días en llegar.

Bien. Hemos mejorado conectividad USB, memoria RAM, CPU y disco duro interno. Pero, ¿no faltaría una cosa?: la tarjeta gráfica, supongo. ¿O es demasido caro y no merece la pena, ya que yo no juego a videojuegos? Estoy mirando esta.

Un saludo.

🗨️ 3
superllo
1
🗨️ 2
cisquito
🗨️ 1
naveganteperdido

y porque no averiguas que es lo que causa la congelacion del sistema durante la descarga antes de empezar a añadirle/cambiarle componentes?

🗨️ 3
cisquito

Gracias por su respuesta.

En su momento hice chequeos de la CPU, tarjeta gráfica, memoria RAM y disco duro, resultando todos correctamente. Pero aprovechando su sugerencia, he hecho dos cosas que no había realizado: reducir drásticamente la velocidad de descarga y usar un entorno gráfico más liviano.

  • Al limitar la velocidad a las 8 Mbps que tenía hace una semana desaparecen los congelamientos.
  • Al usar otro entorno gráfico menos pesado (LXDE) no se observa congelamiento aunque sí una ralentización del sistema.

Mi conclusión es que al hardware le falta potencia (tiene unos 9 años). Por eso voy a empezar probando por ampliar la memoria RAM.

Un saludo.

🗨️ 2
naveganteperdido

chequeos?

has de comprobar que recurso es el que hace de cuello de botella en la situacion que quieres solucionar, por ejemplo con top/htop o system monitor, yo para una descarga antes apostaria por la velocidad del disco duro que cualquier otra cosa

🗨️ 1
cisquito

Gracias de nuevo por su sugerencia.

He probado con top y system monitor. System monitor indica, durante la descarga, un 60% total de uso de CPU y hasta 1,7 GB total de RAM sobre 3,8 GB (un 48%). Con top no me fío, ya que me indica un uso de la CPU ¿superior al 100%? Los mayores consumos individuales, tanto de CPU como de RAM, se los lleva el programa de descargas. Todo eso en entorno gráfico LXDE; con GNOME 3 ni pruebo, ya que la pantalla se queda "fija" como en un photo finish.

En cuanto a la velocidad de escritura del disco duro mecánico SATA:

$ dd if=/dev/zero of=test bs=64k count=16k conv=fdatasync
16384+0 registros leídos
16384+0 registros escritos
1073741824 bytes (1,1 GB, 1,0 GiB) copied, 7,92223 s, 136 MB/s

Es decir, 136 MB por segundo de escritura, cuando la conexión de fibra lo máximo que suele llegar, en sus picos, es a unos 80 MB/s. No creo que sea el disco duro el problema. Pero bueno, no es mala idea pensar en ir sustituyéndolo por un disco sólido.

Empezaremos ampliando la RAM, que la recibiré el domingo, si no hay percances. Cuando amplíe ya comentaré los resultados.

Un saludo.

Alentines

Ayudaría que indicaras el modelo de placa, de todas formas, las medidas en los módulos de memoria son estándar así que da igual si son de 2, 4 u 8 gigas. Otro tema, que la placa admita hasta 16GB de memoria seguramente quiera decir que como mucho admite módulos de 4GB por puerto de memoria.

🗨️ 1
cisquito

Gracias por su respuesta.

La placa base es una Asus P7H55, que resulta ser la misma que tiene el compañero superllo. Y como él dice, en este mismo hilo, que tiene un módulo RAM de 8 GB enchufado y funcionando, yo voy a probar lo mismo.

Un saludo.

BocaDePez
BocaDePez

La memoria Ram funciona mejor si lleva parejas iguales de chips de memoria en cada canal.

Normalmente, los canales A y B suelen ser distinguibles en la placa base.

Las configuraciones pueden ser A B - A B o bien A A - B B.

Yo añadiría 2 módulos de 4 mejor que uno solo de 8.

cisquito

Gracias por su respuesta.

Vaya, ya he realizado la compra de la unidad de 8 GB… No sé si suspenderla y cambiarla por lo que Vd. comenta.

Mi configuración actual es dos módulos de 2 GB cada uno en A2-B1.

Un saludo.

cisquito

Bueno, he anulado la compra de la memoria anterior y he comprado estas.

A ver qué tal va.

Un saludo.

cisquito
1

Bien. Ya he instalado los dos módulos RAM de 4 GB cada uno.

Debian reconoce sin problemas las nuevas 12 GB (las 8 GB de ahora y las 4 que habían antes) y según Windows se encuentran en Dual channel.

Volviendo a probar el programa de descarga en GNOME 3 ya no se congela el sistema gráfico, aunque se ralentiza. En LXDE, donde antes se ralentizaba, ahora apenas se nota.

Quizás el paso siguiente sería mejorar la CPU y/o pasarme a disco SSD.

Gracias a todos los que han participado ayudándome desinteresadamente, en especial a superllo.

Un saludo.

🗨️ 3
superllo

Si cambias más cosas: primero SSD y luego procesador. Yo he puesto el Xeon X3470 y es un poco más rápido, un vídeo que tardaba 1 hora y 51 minutos con kdenlive ahora ha tardado 1 hora y 32 minutos (por comparar algo). Eso sí, quizá GNOME es demasiado cargado para nuestros procesadores, yo uso Mate (aunque con Compiz).

🗨️ 2
cisquito

Gracias de nuevo por su respuesta.

¿El cambio a un procesador más potente no le da problemas con la fuente de alimentación?

Un saludo.

🗨️ 1
superllo
1

No.

cisquito
1

Bien. Esta misma tarde he instalado el nuevo procesador. El antiguo era un i5; este es un i7:

usuario@debian:~$ lscpu
Arquitectura:                        x86_64
modo(s) de operación de las CPUs:    32-bit, 64-bit
Orden de los bytes:                  Little Endian
Tamaños de las direcciones:          36 bits physical, 48 bits virtual
CPU(s):                              8
Lista de la(s) CPU(s) en línea:      0-7
Hilo(s) de procesamiento por núcleo: 2
Núcleo(s) por «socket»:              4
«Socket(s)»                          1
Modo(s) NUMA:                        1
ID de fabricante:                    GenuineIntel
Familia de CPU:                      6
Modelo:                              30
Nombre del modelo:                   Intel(R) Core(TM) i7 CPU         870  @ 2.93GHz
Revisión:                            5
CPU MHz:                             1212.944
CPU MHz máx.:                        2934,0000
CPU MHz mín.:                        1200,0000
BogoMIPS:                            5887.54
Virtualización:                      VT-x
Caché L1d:                           32K
Caché L1i:                           32K
Caché L2:                            256K
Caché L3:                            8192K
CPU(s) del nodo NUMA 0:              0-7
Indicadores:                         fpu vme de pse tsc msr pae mce cx8 apic sep mtrr pge mca cmov pat pse36 clflush dts acpi mmx fxsr sse sse2 ss ht tm pbe syscall nx rdtscp lm constant_tsc arch_perfmon pebs bts rep_good nopl xtopology nonstop_tsc cpuid aperfmperf pni dtes64 monitor ds_cpl vmx smx est tm2 ssse3 cx16 xtpr pdcm sse4_1 sse4_2 popcnt lahf_lm pti tpr_shadow vnmi flexpriority ept vpid dtherm ida

La navegación por el explorador de archivos es ahora más rápida. La codificación de vídeos de 1080p es un 50% más rapida. Ahora ya puedo reproducir fluidamente vídeos 4K, aunque la codificación con 4K le queda demasiado grande (no sé si una tarjeta gráfica mejor ayudaría en codificación).

Un saludo y Felices Fiestas.

🗨️ 3
superllo
1

Pues tienes suerte de poder ver cosas en 4K porque yo no puedo, debe ser tema de la gráfica. Y a mi no me da tanto rendimiento la codificación, será mejor ese i7 que mi Xeon.

🗨️ 2
cisquito
1

Gracias por su respuesta.

Quizás también tenga que ver el programa codificador y su configuración. Yo codifico por línea de comandos con ffmpeg. Esta aplicación usa por defecto todos los hilos de procesado (8 en mi caso). La tarjeta gráfica es una NVIDIA GeForce GT 440 pero de 1080p.

Un saludo.

🗨️ 1
superllo
1

Yo soy un vago que usa Kdenlive y lo único que le he hecho es ponerle 6 hilos. Mi gráfica es una Nvidia GT210 bastante cutre.