Banda Ancha EU

Comunidad de usuarios
de fibra, móvil y ADSL

hosting en interdominios
128 lecturas y 18 respuestas
  • Microcaídas en Orange al usar P2P

    Hola.

    Llevo ya casi 2 años con la ADSL de 6MB de Orange, y hasta entonces no he tenido demasiados problemas. Eso sí, tengo un problema de "microcaídas" en la línea que me molesta bastante, especialmente para el P2P. No creo que sea algo de mi ordenador, porque me pasa con 2 ordenadores distintos y todas las versiones de uTorrent que fueron saliendo a lo largo de este tiempo.

    La situación es:

    1. El uTorrent bajando a una velocidad "respetable", unos 200-300 KB/s
    2. La subida limitada, pero mantenida estable a 30 KB/s
    3. Cuando se dan estas dos situaciones y utilizo un poco la línea con cualquier otro programa (abrir unas webs, etc), la línea se cae por completo, y CREO (esto no lo he confirmado aún) que el router pierde la sesión PPP, porque CREO que me cambia de IP. A los pocos segundos se recupera la conexión.

    Para el uso normal de la línea no es un problema, pero en cuanto al P2P sí lo es, porque pierdo todas las colas de descarga y las conexiones con los peers y tiene que volver a iniciar todo de nuevo. Se ve muy claro en esta gráfica de velocidad del uTorrent (rojo subida, verde bajada, aunque en la caída parece que no llega a 0, sí llega, es porque esa una gráfica promediada 30 segundos).
    Todavía no he llamado a Orange porque seguramente me digan que es culpa mía por usar P2P, pero... a ver si alguien tiene idea de qué puede ser. Tengo el router Thomson 530 v6 conectado en modo bridge a un Linksys WRT54GL con OpenWRT (debo decir que también me pasaba con el firmware Thibor y con DD-WRT).
    Gracias de antemano.

    Este tema lleva más de 6 meses inactivo. Es recomendable que abras un nuevo tema para retomar la conversación.
    1
    • BocaDePez BocaDePez
      6

      Despues de multitud de pruebas con diversos routers y…

      Despues de multitud de pruebas con diversos routers y configuraciones estoy seguro de que los micro cortes de la sesion ppp no son debidos a mi equipo. Todo parece apuntar a la propia Orange, en llamadas con el SAT me comentan que yo "descargo mucho" y por eso falla (el dia 2 de enero me decia el tio que habia descargado 4 gigas de informacion!!! madre de diox!). Dudo mucho de que haya una solucion clara para esto; es mas, lo mismo lo hacen a posta para limitar de alguna manera la descarga. Yo particularmente he empezado a tener cortes desde diciembre, mas o menos la misma fecha en la que me llamaron diciendo que si firmaba un contrato de permanencia me hacian un descuento en la factura. Firmar y empezar a ir mal fue todo uno. Quiza fuera casualidad, quiza sea casualidad que monitoricen los consumos de cada uno de nosotros... lo que esta claro es que de mi router no es el problema y que se da mucho mas a menudo cuando tengo el emule tambien.

      En el momento en que acabe el contrato me largo.

    • BocaDePez BocaDePez
      6

      A mi me pasa lo mismo con el P2P y otras cosas: Hasta hace un…

      A mi me pasa lo mismo con el P2P y otras cosas:

      Hasta hace un mes estaba con Telefonica y todo me iba perfecto, pero ahora con máxima velocidad + linea de orange: el VNC funciona cuando quiere, nadie puede conectarse a mi radio por internet con shoutcast (conecta pero cuando va a comenzar a reproducir se clava y se corta en 20")

      Casi deciros que lo que me va mejor es el emule...

    • Yo también sufro el mismo problema que comentáis. Hace una…

      Yo también sufro el mismo problema que comentáis. Hace una temporada (más o menos unos 20 días) me paso lo mismo y después de trastear un poco con el moden (es el moden SMC WIFI de Ya.com) se pasó el problema. En un principio pensé que podía ser debido a usar el moden de ya.com, pero ahora el problema se repite.
      Yo lo noto descargando ficheros de rapidshare o megaupload y navegando normalmente, por lo tanto no creo que sea problema de p2p. Alguien puede aportar algo de luz al problema.

    • ¿Has comprobado si el módem ADSL es el que pierde la…

      ¿Has comprobado si el módem ADSL es el que pierde la sincronía, o si es el OpenWRT el que pierde la sesión PPPoE sólo sin perder sincronía ADSL? Yo tengo una configuración similar (el Speedtouch en modo bridge y una fonera haciendo sesión PPPoE con firmware DD-Wrt).

      Mi problema es simplemente que la línea sincroniza con el margen de ruido justo, y de vez en cuando se cae (normalmente cada 1, 2 o 3 días, alguna vez dos veces al día) sin estar usando P2P. Supongo que con el uso de P2P intensivo se caería más frecuentemente, aunque no me ha molestado en ningún momento.

      Mira los datos de sincronía, margen de ruido y atenuación de tu router y coméntalos.

      Saludos

      • Uf, veo algo difícil intentar discernir entre ambos…

        Uf, veo algo difícil intentar discernir entre ambos problemas. Supongo que podría mirar las luces del módem cuando ocurre esta caída, pero ocurre como mucho una o dos veces al día, y además cuando me doy cuenta que he perdido la conexión, ya la recupera, y es bastante difícil enterarse. He mirado a ver si queda algún registro de sesión PPP en el router pero no encontré mucho.

        Yo supongo que lo que se cae es la sincronía de la ADSL, aunque no sé si se puede recuperar en tan poco tiempo (los cortes son de unos 5 segundos, no mucho más), porque si fuese algún bug o algo en el firmware del router, se habría solucionado o sería distinto al cambiar de firmware.

        Estos son los datos que me da el modem, no sé si son buenos o no, porque nunca los entendí xD

        • Uptime: 0 days, 0:03:14
        • Modulation: G.992.5 Annex A
        • Bandwidth (Up/Down) [kbps/kbps]: 510 / 6.142
        • Data Transferred (Sent/Received) [KB/KB]: 0,00 / 0,00
        • Output Power (Up/Down) [dBm]: 12,0 / 0,0
        • Line Attenuation (Up/Down) [dB]: 11,0 / 29,0
        • SN Margin (Up/Down) [dB]: 16,5 / 23,5
        • Vendor ID (Local/Remote): TMMB / GSPN
        • Loss of Framing (Local/Remote): 0 / 0
        • Loss of Signal (Local/Remote): 0 / 0
        • Loss of Power (Local/Remote): 0 / 0
        • Loss of Link (Remote): 0
        • Error Seconds (Local/Remote): 1 / 0
        • FEC Errors (Up/Down): 0 / 154
        • CRC Errors (Up/Down): 1 / 76
        • HEC Errors (Up/Down): 0 / 2
            • Manda huevos, ahora a mi en una de las dos conexiones (la de…

              Manda huevos, ahora a mi en una de las dos conexiones (la de Orange) que tengo se ha caído la conexión y no sincroniza. Primera incidencia en un mes con Orange XD

              No sé si eres capaz de acceder al módem al tenerlo en modo bridge, pero deberías intentarlo para ver su log (el SpeedTouch tiene, aunque algo cutre) a ver si es él el que pierde la sincronía ADSL.

              Saludos

              • Hay que ser gafe xD En cuanto a los logs, poder puedo, pero…

                Hay que ser gafe xD

                En cuanto a los logs, poder puedo, pero tengo que conectar el PC directamente al modem, porque al estar conectado al puerto WAN del router, no es posible conectar directamente. El problema es que para hacer esto hay que reiniciarlo... y adiós logs xD

                ¿O se mantienen entre reinicios?

                • Te digo como lo hago yo: Supongo que al router OpenWRT…

                  Te digo como lo hago yo:

                  Supongo que al router OpenWRT conectas por SSH. Bien, el módem lo tengo con IP 192.168.0.1, el router DD-Wrt en mi caso y resto de red son 192.168.1.X

                  Lo que hago es conectar por SSH con el cliente ssh PuTTy al router configurando en PuTTY en la seccion Connection -> SSH -> Tunnels un puerto con redirección dinámica (en realidad es un servidor socks).

                  Abres la conexión ssh al router y haces login, y en el navegador configuras en conexiones de red como servidor proxy 127.0.0.1 (tu propio ordenador) y el puerto que hayas puesto en la ocnfiguración del PuTTy.

                  Así podrás conectar sin reiniciar ni nada ni desconectar cables al módem, eso sí, otras configuraciones de red (IP del módem en el mismo rango que el router) no las he probado.

                  Con iptables lo intenté apañar, pero no conseguí que funcionase correctamente.

                  Saludos

                  • Yo tengo justo al revés, el OpenWRT con la IP 192.168.0.1 y…

                    Yo tengo justo al revés, el OpenWRT con la IP 192.168.0.1 y el SpeedTouch con la 192.168.1.254, conectados a través del puerto WAN del router OpenWRT.

                    Intento hacer lo que me comentas, hacer un túnel, y aparentemente funciona bien (puedo ver webs y tal), pero no hay forma de entrar a la 192.168.1.254. ¿A ti te funciona bien así?

                    De hecho, ni siquiera puedo hacer ping desde el router (por SSH) a 192.168.1.254 (el SpeedTouch)...

                    • Ay!!! Se me olvidó que tienes que poner IP al interface donde…

                      Ay!!! Se me olvidó que tienes que poner IP al interface donde tienes conectado el router (tranquilo, no se casca la conexión). En tu caso, podrías ponerle (supongo que eth0 es el interface por cable que está metido en el bridge):

                      ifconfig eth0 192.168.1.253

                      Reglas de iptables no hay que meter creo (te lo diría, pero como se me ha caído la conexión no puedo acceder externamente). Por cierto, he llamado al 1414 con una tarjeta prepago de Orange que regalan a cliente de Yacom y ya me han puesto incidencia y todo perfecto. Ya verás, se darán cuenta que tengo una subida que no me corresponde y me la joderán :-(

                      Saludos

                      • Muajaja, ya funciona, ¡GRACIAS! Me gusta estar siempre al…

                        Muajaja, ya funciona, ¡GRACIAS! Me gusta estar siempre al tanto de estos numeritos, y me fastidiaba que para verlos tenga que estar conectando y desconectando... ahora ya es inmediato! Encontré este post con algo más de info sobre acceder a un modem por el puerto WAN, incluso el asignarle la IP automáticamente.

                        Ahora estaré al tanto de las caídas, y si veo que al modem se le va la pinza cuando se satura, pido otro distinto a Orange. Si fuese de esto, ¿sabes si hay algún otro modem (o router con modo bridge) que dé Orange y vaya bien?

                        • Es que yo tengo mis dudas de que se te caiga la conexión por…

                          Es que yo tengo mis dudas de que se te caiga la conexión por el módem con esos parámetros decentes de ruido, por eso te decía lo de ver si cuando se te cae la conexión pierdes sincronía o sólo se va al garete la sesión PPPoE.

                          El tema de saturarse típico suele ser de la NAT de los routers, y en este caso al ser un simple módem, esto sería culpa del router con OpenWRT.

                          Qué número límite de conexiones tienes puestas en tu software P2P?

                          • Pues tengo un límite de 230 conexiones globales para todo el…

                            Pues tengo un límite de 230 conexiones globales para todo el uTorrent, que es lo único que uso.

                            De la NAT no creo que sea porque si mal no recuerdo (una vez tenía el límite de conexiones muy bajo y lo vi) salen alertas en el log del kernel del router.

                            Estaré atento los próximos días a los logs del módem, a ver si descubro algo.

                            Gracias por toda tu ayuda :))

                            • Alehop. Unos días después, primera caída, dejando…

                              Alehop. Unos días después, primera caída, dejando deliberadamente el uTorrent sin limitar la subida. En el SpeedTouch no hay ningún log (me imagino que las pérdidas de sincronía las mostrará en los logs), así que las sospechas recaen sobre el router con OpenWRT, concretamente sobre el plugin rp-pppoe... Tengo que probar con el nuevo OpenWRT 8.09, aunque de momento está en RC.

                              • BocaDePez BocaDePez
                                6
                                Buenas. Resulta que yo tengo exactamente los mismos problemas…

                                Buenas. Resulta que yo tengo exactamente los mismos problemas que relatais en este hilo. He probado con 2 routers distintos, el sagem que me dieron en Orange y lo tenia guardado y un Billion que funcionaba perfectamente hasta hace poco. Al principio pense que seria cosa del Billion ya que actualize el firm y cada 2x3 me decia que habia perdido la sesion ppp y por alguna extraña razon no reenganchaba, de forma q lo tenia q reiniciar. Esto me pasaba 1 vez cada 2 dias excepto al final que me podia pasar 2 veces al dia. Cambie al Sagem para probar y las caidas son cada 10 o 20 minutos: el messenger me reconecta y por lo que veo pierde la sesion ppp pero este router reconecta bien.

                                Con el Sagem he comprobado que las desconexiones son mucho mas frecuentes cuando tengo el emule puesto. Lo tenia con 900 conexiones y se reiniciaba cada 5 minutos. Las baje a 600 y ahora lo hace cada media hora mas o menos. Si p2p se puede reconectar cada 3 o 4 dias.

                                Francamente, no se a que puede deberse esto. Al principio pensaba que era un problema del Billion pero luego, al ver que el Sagem tambien falla ya no se que pensar. El sagem de todos modos es una castaña de router, cuando hay muchos nateos activos se medio aturulla y es imposible acceder al interface web para ver que esta pasando.

                                Habeis llamado al sat? os han dicho que es lo que puede estar pasando? yo casi he descartado que sea un tema de router pero intentare probar con algun otro (a ver si puedo echarle el guante a un cisco 820 y a ver que pasa).

    • 6

      pues a mi desde hace dos dias, tambien tengo pequeñitas…

      pues a mi desde hace dos dias, tambien tengo pequeñitas caidas de unos segundos, no uso p2p, lo noto en el msn que se me desconecta, pruebo a ver una pag. de internet, y no va... al cabo de menos de 1 min. ya está otra vez conectado...

      saludos