BandaAncha.eu

Comunidad de usuarios
de fibra, móvil y ADSL

Fibra

Livebox Fibra. No accedo al NAS desde fuera de la LAN.

BocaDePez
BocaDePez

Buenos días pezpañeros,

Hace tres días que activaron la fibra óptica de Orange en casa y me han montado un router Livebox Fibra. Tras configurar lo típico, cuatro cambios de contraseña y añadir mis equipos con IP's fijas me dispongo a abrir los puertos para el NAS y... ¡Sorpresa! la tabla NAT/PAP no hace ni puñetero caso a dicha apertura desde fuera de la LAN.

Ni SSH, ni FTP, ¡ni la web de gestión del NAS funca!(HTTP). Desde dentro de la LAN todo funciona correctamente, me da la sensación de que abre los puertos entre el router y el NAS, pero no del router hacia Internet.

He visto que se han conseguido obtener los datos ONT (aparecen la misma gestión del router) y SIP. Peeero, a partir de agosto el SIP ya no puede extraerse o por lo menos no se conoce la manera con la nueva versión de firmware. A mí ya me venía actualizado a la última revisión :-(
Así que por ahí tampoco puedo tirar hacia un cambio de router sin perder el fijo.... y mi señora me mata.

¿A alguien le ha ocurrido lo mismo? ¿Alguna solución? En caso de no existir solución por lo típico "política de seguridad de la empresa impide abrir esos puertos a Internet" todavía estoy en el período de prueba y puedo desistir del contrato. ¿Qué me recomendáis?

Muchas gracias por vuestro tiempo y ayuda!

rbetancor

Tiene más pinta de que estás tras el CGNAT de ipv4 y con ipv6 activado ... compruebalo verficando la IP WAN del router.

🗨️ 17
BocaDePez
BocaDePez

Gracias por tu respuesta. Parece que tengo IPv4, no tiene pinta de que pertenezca a ese grupo de usuarios con IPv6.. en http://ipv6-test.com/ me dice IPv6 "Not Supported". En el apartado "Información y diagnóstico -> Parámetros del sistema" del router también me aparece IPv6 desactivada, en cambio IPv4 activada. No sé si es fiable... pero todo indica que sí.

🗨️ 5
rbetancor

Pues hasta ahora ,el LiveBox hacía caso al tema de puertos, salvo que en la última firmware hayan capado algo.

🗨️ 4
BocaDePez
BocaDePez

Me parece rarísimo. Si hago ping al NAS me responde pero como digo, no tengo acceso a ningún servicio fuera de la LAN.
Llamaré al servicio técnico cuando llegue a casa a ver qué se cuentan. Gracias!!

🗨️ 1
BocaDePez
BocaDePez

El propio ping me lo responde un tal "16.pooletcetcetc".dynamic.orange.es. ¿Supongo que estoy en CGNAT de IPv4? Me he informado algo sobre CGNAT y una de sus propiedades es:

  • Hace imposible el uso de aplicaciones que requieren puertos específicos (instalar un servidor web, por ejemplo).
🗨️ 1
BocaDePez
BocaDePez
BocaDePez
BocaDePez

¿ahora hay cg-nat en orange?

🗨️ 10
rbetancor

Para la gente de IPv6

🗨️ 9
BocaDePez
BocaDePez

Yo estoy con IPv4 y tengo CG-Nat ,la IPWan en el router es 192.0.0.1 y la IP Publica es otra tipo 89.131.xxx.xxx .Orange Fibra 300/300 directa

🗨️ 8
rbetancor
🗨️ 7
BocaDePez
BocaDePez
🗨️ 6
rbetancor
1
🗨️ 5
BocaDePez
BocaDePez
🗨️ 4
rbetancor
🗨️ 3
BocaDePez
BocaDePez
pepor
🗨️ 1
BocaDePez
BocaDePez
BocaDePez
BocaDePez

Por si sirve de algo para solucionar en la manera de lo posible:

Yo tengo Orange, con el Livebox, con su tabla de NAT asignada correctamente y funcionando desde hace meses .......... y un dia todo cambio .............

el culpable el IPV6.

me conecte en una de esas paginas que te informan de la IP externa y ¡voila! tenia una IPV4 y una IPV6.

Asi que entre en la configuracion del router, te vas al apartado de la IPV6 y ahi asignas el puerto exterior que usaras, el protocolo, la IP de tu ordenador en cuestion, y el puerto de este que ira la informacion. Si necesitas por un motivo u otro que el puerto sea en tu ordenador uno determinado (el que le has indicado), no marques la opcion de que te den uno por el sistema.

Una vez realizado el sistema te dirá si es correcto o tiene un fallo, si es asi cambiale el puerto exterior y prueba de nuevo.

Te doy un ejemplo:

Puerto exterior 1080

Protocolo TCP

IP ordenador 192.168.1.15

Puerto del ordenador 80

Marcas el NO.

si todo esta correcto y te lo acepta debes de entrar a tu red desde el exterior IP PUBLICA:1080.

Espero que te sirva.

Saludos.

BocaDePez
BocaDePez

A mi me han cambiado el router por este problema de no abrir los puertos (fibra 30mb).
Comprueba si tus puertos están abiertos aqui: canyouseeme.org

BocaDePez
BocaDePez

Gracias a todos por vuestras recomendaciones, soy el op del hilo, que se ha desmadrado un poco :D
Finalmente mi problema no sé de donde venía. Se solucionó en parte tras reiniciar el router varias veces... impresionante. Digo en parte porque me es imposible abrir un rango para el servidor FTP pasivo. Tengo el rango abierto en la tabla NAT/PAT pero al hacer un nmap a ese puerto dice que el estado del puerto es "closed". El resto de puertos "individuales" sí los abre.

🗨️ 5
vukits

ftp está un poco desfasado.

migra a sftp

🗨️ 3
BocaDePez
BocaDePez

Gracias por la recomendación, eso haré en cuanto descubra el problema con los puertos :)
Acabo de descubrir que si abro el rango de puertos uno a uno en el router (lo limito a 5 puertos por ejemplo para no tener tanto trabajo abriendolos) sí funciona. Así que parece que este router no permite la apertura de puertos por rango. :O
Si alguien sabe como abrir un rango de puertos, que levante la patita. Gracias!

BocaDePez
BocaDePez

Yep! parece que mi NAS reserva y limita sftp para admin.
- "QNAP has intentionally restricted the SSH access to admin only - and sftp is essentially a shell access."
- "I need it to be enabled for all user accounts, preferably something I can enable/disable via the Network Services for each user account."
- "You can't. Use ftp(es) instead."

🗨️ 1
vukits

leñe, siempre puedes pedir apertura de puertos mediante UPNP (con un script, claro)