BandaAncha.eu

Comunidad de usuarios
de fibra, móvil y ADSL

LAN lenta a través de wifi

BocaDePez
BocaDePez

Hola a todos

Quería ver si alguien puede ayudarme a resolver un problema que lleva días dándome la lata y ya no se que probar... El problema básicamente es la lentitud de mi red local a través de wifi (lan, sin salida a internet), que alcanza como picos máximos unos 1.5Mbytes/s cuando (creo) debería alcanzar mucho más. Si me equivoco al pensar que debería alcanzar más de 1.5 decirlo y ya no sigais leyendo, que hay mucho rollo xD

Os pongo en situación.
Tengo dos ordenadores, uno de sobremesa normal con tarjeta ethernet 100 integrada y un adaptador wifi usb, y un portatil con tarjeta wifi ipw2200 y ethernet100 integrado. Además un router zyxel prestige 660hw que tiene configurada un red wifi con seguridad WPA y que funciona en modo g (54Mb) en el canal 8 y con nivel de señal excelente.

Con esta configuración realizo pruebas y obtengo:

sobremesa (ethernet) <-> portatil (ethernet): velocidad en torno a 8.5MBytes/s
sobremesa (ethernet) <-> portatil (wifi): velocidad en torno a 1Mbytes/s
sobremesa (wifi) <-> portatil (ethernet): en torno a 1Mbytes/s
sobremesa (wifi) <-> portatil (wifi): menor a 1Mbytes/s

Todas las pruebas las hago en todos los sentidos y por duplicado, ya que tengo windows xp2 y linux-debian instalado en ambos ordenadores, lo cual me descarta (en principio) problemas de firewall y drivers. Algo más rápido cuando interviene linux, pero nada salientable
Además las pruebas las hago con un par de programas específicos (netcps y netio) y con los propios exploradores de windows y debian intercambiando ficheros, obteniendo más o menos los mismos valores.

llegados a este punto, y viendo que las conexiones cable-cable funcionan correctamente, y que las que son wifi-cable dan la misma velocidad independientemente del adaptador wifi que use decido que es el router lo que falla, así que consigo un linksys wrt54g... hago más pruebas y obtengo exáctamente los mismos resultados :S

Comienzo a cambiar cosas a la desesperada:

Fuerzo a los routers a trabajar en modo b (11Mb): observo que tampoco funciona al máximo, ya en el mejor de los casos obtengo velocidades de 300Kbytes/s
Desactivo protección de wifi, dejando la red abierta o con wep: no hay cambios
Cambio de canal del wifi: observo que el canal que mejor funciona es curiosamente el que ya tenía, el 8
Hago pruebas con otro portaátil (asus eee pc) y con otro ordenador de sobremesa algo más antiguo: no hay cambios.
Decido que el problema está en algún tipo de interferencia en mi salón (teléfono inalámbrico, tv...quien sabe): me voy a otro sitio de mi casa con el router y dos portátiles: mismos resultados que antes, velocidad en torno a 1Mbyte/s
Decido que soy demasiado optimista con el wifi o que me he pasado por alto alguna chorrada pero no la veo: escribo en este foro

¿alguna idea? ¿soy demasiado optimista? xD

gracias por leer el tocho...he pensado que cuanta más información de lo que ya he hecho mejor para todos:D

vukits

ell máximo que aguanta 54g son 20mbps . ..

al wrt54g ponle firmware tomato...... y actualiza los driver de la tarjeta intel...

si no,,pues pilla un wrt350n +DD-WRT, y dos tarjetas wireless-N Linksys.

saludos

🗨️ 9
BocaDePez
BocaDePez

Si habeis leído mi mensaje (el largo por algo xD) vereís que ya he probado con dos routers distintos, ya he probado con windows y linux (ambos con drivers actualizados) y ya he probado con wep, con wpa y sin encriptación

que quieres decir con eso de que 54g solo llega a 20mbps? :-/ De todos modos, 20mbps=2.5MBs que está muy lejos de lo que yo alcanzo

🗨️ 8
vukits

no estoy hablando de wrt54g a secas... estoy hablando de wrt54g con firmware Tomato

🗨️ 7
BocaDePez
BocaDePez

el zyxel tiene el firmware de telefónica, el linksys tiene el tomato ;) y ambos dan resultados similares, por no decir exáctamente iguales. Yo creo que hay algo que está limitando las velocidades porque dan los mismos valores con distintos routers, distintos drivers y distintos sistemas operativos. Parece que hay un límite ahí que no se puede pasar

🗨️ 6
vukits
AguilaRoja
🗨️ 4
BocaDePez
BocaDePez
🗨️ 3
AguilaRoja
🗨️ 2
BocaDePez
BocaDePez
🗨️ 1
BocaDePez
BocaDePez
BocaDePez
BocaDePez

antes de gastarte el dinero, prueba a cambiar la WPA por WEP.Habeces es el tipo de contraseña que impide que vaya mas rapido. WPA con XP no se, no se, tiene muchos problemas.

🗨️ 1
BocaDePez
BocaDePez

AHH tambien prueba de conectar, los dos con linux con live cd.