Banda Ancha EU

Comunidad de usuarios
de fibra, móvil y ADSL

Bugs/Devel

Lag en el editor de mensajes de la web

Weikis336

A alguien mas le sucede que el móvil se calienta en exceso se quedo pillado cuando escribes respuestas largas y de repente el navegador deja de funcionar hasta cerrarse. A mi me sucede e incluso llego a notar que el teléfono se calienta bastante.

Nota en Android no me pasaba donde lo estoy notando es en iOS.

Mi móvil es un iPhone 6s. Aunque ya tiene sus años debería de bastar e ir bien.

En otras paginas webs no he notado que vaya lento.

finn

Yo lo que noto es que en Safari en iOS no funcionan las predicciones ni el autocorrector. También alguna vez se me ha colgado Safari escribiendo.

🗨️ 4
Weikis336

Yo utilizo firefox

🗨️ 3
finn

¿Cómo que no utilizas Safari? ¿No te gusta?

🗨️ 2
Weikis336

La verdad no

🗨️ 1
finn
Spyd

Justo ahora he estado haciendo unas pruebas escribiendo este mismo post, y sin importar cuánto texto haya escrito, el uso de la CPU es bastante elevado.

Lo que estoy viendo del administrador de tareas, es un uso de la CPU que pasa de aproximadamente el 5% mientras no escribo, a el 30% aproximadamente cuando escribo a una velocidad aproximada de 150 cpm, con el aumento de uso de todos los hilos bastante equilibrado.

Mi CPU es un Ryzen 3 a 3,5Ghz de 4 núcleos y 4 hilos, Windows 10 Pro 1909 x64, 8Gb de RAM y Google Chrome 83 de 64 bits.

Si hago esta misma prueba en un foro basado en phpBB, paso de usar un 5% a un 10%, con lo que efectivamente hay algo que consume muchos recursos en el editor de BA; usar un 25% de CPU me parece una barbaridad para un editor de texto.

🗨️ 2
Weikis336

Vamos un uso desmesurado para solo estar escribiendo. Si en tu ryzen el uso se dispara imagina en un movil

🗨️ 1
NetSpot

Yo iba a decir que en un Core 2 Duo no pasa, pero supongo que escribo demasiado lento.

Es ponerse a aporrear el teclado, y entonces sí pasa. Va a ser cosa de la duplicidad entre el textarea y el div editable (la posible razón de que no os funcione el autocorrector, como no me funciona a mí) y el contador de carácteres que se queda pillado.

Si no fuera porque veo a la vez (el hack CSS para poder ver el div editable y poder publicar mensajes con este navegador) no podría tampoco corregir. Lo que pasa es que lo que corriges en el textarea no se replica en el div editable. Sólo va en un sentido.

Por cierto, Josh, puede ser por algo que ocurre desde que cambiaste el editor. No sé qué es pero está todo el rato el indicador de carga del navegador flasheando mientras escribo. Entiendo que haya un script vigilando para hacer modificaciones de estilo al vuelo con el código ese que pusiste, pero, ¿que recargue la página? Juraría que alguna vez que he jugueteado con divs editables la carga de la página no se inmuta…