BandaAncha.eu

Comunidad de usuarios
de fibra, móvil y ADSL

Java en Windows 10 - no ejecuta el setup

Maua

Buenos días,

Tengo un problema. Da igual que baje la última versión de Java completa o que utilice el instalador que lo hace vía web. En cualquier caso, no se ejecuta nada por más que lo intente. Con nada, es nada. He bajado unas 10 veces los instaladores, por si había algo mal.

He instalado una versión anterior, la 8u45. Pero me dice que existe una nueva y tampoco me deja actualizarla. Pensé en dejar la 8u45, pero es que ahora tampoco funciona. Está instalada, pero cuando voy al verificador de java, me dice que no lo encuentra instalado. Lo he intentando con Explorer y firefox.

Es importante tener java, porque en la oficina trabajamos con Hacienda y nos lo exigen.

¿Alguna idea?

Gracias de antemano.

BocaDePez
BocaDePez

¿Aparece algún mensaje de error al instalar? Lo que comentas es muy extraño.

¿Descargas de la web java.com o de la web de Oracle?

¿Tienes privilegios de administador en ese Windows 10?

🗨️ 3
Maua

Pues las últimas versiones, desde la web de Java.com. Para la versión anterior que he instalado, la saqué de Oracle.

No da mensaje de error. Simplemente no ejecuta. Y da igual que lo haga como administrador, como compatible con windows anteriores, nada. No hace nada.

Y cuando instalé la anterior, y le doy a actualizar, me saca la ventanita de se va a instalar la última versión... le das a siguiente y no hace nada más.

Gracias.

🗨️ 2
BocaDePez
BocaDePez

No sé si llegaste a ver el mensaje de arriba con los datos de las versiones offline de la 8u73. Lo curioso es que hayas descargado la 8u45... supongo que no lo habrás hecho hoy y la tendrías ya descargada de mucho antes, ¿no? Cada semana hay una nueva aproximadamente.

Revisa que te coinciden los tamaños y el MD5, no vayas a tener el sistema infectado. Si no tienes programas para chequear la suma de comprobación, hay muchos gratuitos... este es el primero que me sale en Google: www.winmd5.com/

Una cosa es que el Java esté instalado en el sistema y otra cosa es que esté instalado en el navegador. Firefox bloquea todo lo anterior al 8u66, así que no me extraña que no te funcione el verificador. java.com/es/download/help/firefox_java.xml

🗨️ 1
BocaDePez
BocaDePez

Sí, lo leí e intenté instalar nuevamente. Comprobé el md5 y era correcto. Pero no funcionaba. Así que tiré al 8u45, porque era el último que tuve que me ha funcionado... no por nada en particular.

Gracias.

BocaDePez
BocaDePez

Yo tengo instaladas las versiones de 32 y 64 bits sobre W10 y no he tenido problema alguno.

Lo que tienes que hacer es desinstalar cualquier java que tengas instalado, hacer una limpieza del registro para quitar restos que hayan podido quedar y después de eso instalar la última versión. Mira a ver si esto te ayuda

java.com/es/download/help/manual_regedit.xml

🗨️ 2
Maua

Hice una limpieza del registro con CCleaner... y sí, desinstalé todo.

Leeré eso y probaré de nuevo. Gracias

Edito: el Fixit de windows no me deja descargarlo. Me dice que no es compatible con W10.

🗨️ 1
BocaDePez
BocaDePez

Existen muchos hilos sobre CCleaner cargándose instalaciones de Windows 10. No está bien preparado para el 1511, cuidado.

BocaDePez
BocaDePez

También asegúrate que ha descargado correctamente, que es posible que estéis cacheando una descarga cortada.

La última versión fuera de línea de Java para 32 bits es:
jre-8u73-windows-i586.exe
50.265.184 bytes
MD5: e7c20ffb5c8cd1b0b4178cb54bfa8755

La última versión fuera de línea de Java 8u73 para 64 bits es:
jre-8u73-windows-x64.exe
57.099.360 bytes
MD5: 83d6262456b3dfa8c6dac549765ad800

🗨️ 3
Maua

Sí, lo he comprobado... y he vuelto a bajar ambas nuevamente.

🗨️ 2
BocaDePez
BocaDePez

Aparece la 8u45 todavía, no está instalada la 8u73. Firefox necesita la 8u66 como mínimo.

🗨️ 1
BocaDePez
BocaDePez

claro, ese es el problema que no me deja...

BocaDePez
BocaDePez

instala Linux o Windows XP.. que es lo que siguen utiizando muchas empresas

instalar un sistema nuevo puede llevar a sorpresas

🗨️ 3
BocaDePez
BocaDePez

No, hombre no, un Commodore 64 que es cojonudo.

🗨️ 2
BocaDePez
BocaDePez

eso es mu moderno,mejor un apple lisa

🗨️ 1
BocaDePez
BocaDePez

Va a ser que no: C64 -1981 y Lisa - 1983

BocaDePez
BocaDePez

Botón derecho -> Propiedades -> pestaña Compatibilidad, y marca la casilla "Ejecutar este programa como Administrador" o

botón derecho / Ejecutar como administrador.

BocaDePez
BocaDePez

Muchas gracias a todos. Di con la solución. El problema estaba en el usuario... que estaba mal, o yo que se. He creado uno nuevo y ha ido como la seda.

Gracias y perdón por las molestias.

🗨️ 1
BocaDePez
BocaDePez

Es probable que el registro de ese usuario estuviese corrompido. Yo no me fío del CCleaner.

BocaDePez
BocaDePez

No puedo ayudarte. Tan sólo mencionar que es un error de esta nueva versión de Windows, ya que conozco varios casos iguales.