BandaAncha.eu

Comunidad de usuarios
de fibra, móvil y ADSL

IPTABLES DD-WRT

BocaDePez
BocaDePez

Hola, no estoy del todo seguro que esto vaya aquí, así que disculpadme.

A ver si alguien me puede echar una manita con esto:

Tengo un router TP-LINK WR741ND: tp-link.es/products/details/?model=TL-WR741ND al cual le he instalado DD-WRT v24-sp2. De momento estoy haciendo pruebas y jugueteando, así que lo tengo conectado al cisco epc3825 de ONO sin puentear, aunque esto no tiene relevancia creo. Lo tengo configurado por DHCP para WAN, y con IPs fijas en LAN en otro rango que cisco.

Hasta aquí ningún problema. Todo me funciona perfectamente, no tengo conflictos, ni por cable ni por wifi. Navego sin problemas y accedo a servicios correctamente y tal...

El problema es que no puedo ver los equipos de mi red, y mucho menos aún compartir nada en ella. Ni con W8, ni con W7, ni con Debian, ni con android.... nada

Los equipos están todos bien configurados y de hecho, hasta ahora usaba IPCOP sin ningún problema y sin tener que hacer ninguna configuración especial para compartir cualquier cosa.

He probado con, y sin, DHCP, con idéntico resultado.

Evidentemente he probado a desactivar el firewall del router, y.... funciona. Lo cual aclara el origen del problema, pero no la solución al mismo. Añado que el problema se me da tanto con el firmware original como con distintas versiones de DD-WRT o de openwrt.

Me parece extraño que tenga que abrir puertos, y no sé si el problema pueda estar en IPTABLES. El caso es que llevo unos días tratando de encontrar alguna solución sin éxito, y mis escasos conocimientos no dan para más.

¿Alguien tiene alguna sugerencia?

BocaDePez
BocaDePez

No tendras activado "AP Isolation" ¿no?

🗨️ 3
BocaDePez
BocaDePez

Eso no deberia afectar para que vea equipos entre si dentro de la red ¿no? de todas formas no lo tengo activado.

🗨️ 2
BocaDePez
BocaDePez

En wifi si

🗨️ 1
BocaDePez
BocaDePez

Bueno, obvié que queria decir por cable, que el wifi solo lo conecto lo justo.

BocaDePez
BocaDePez

lo tengo conectado al cisco epc3825 de ONO sin puentear, aunque esto no tiene relevancia creo

¿Entonces estás haciendo doble NAT?

Lo tengo configurado por DHCP para WAN, y con IPs fijas en LAN en otro rango que cisco.

no puedo ver los equipos de mi red

Perdona que sea puntilloso, pero es para dejar claro desde el principio el esquema de la red y enfocar el problema. ¿Estás intentando ver desde un PC colgando del TP-Link recursos compartidos de otro PC que cuelga del Cisco en el otro rango de IPs? ¿Estás intentando hacerlo en el sentido inverso?

Lo digo porque si hay doble NAT, debería haber una apertura de puertos en el TP-Link hacia una IP determinada. Desactivando un firewall no resolvería ese problema.

Si no hay doble NAT (y por lo tanto no me estoy enterando de tu topología) habrías necesitado una ruta estática de vuelta en el Cisco y habilitar el paso de los puertos de los servicios necesarios entre ambos rangos en el Iptables.

¿Lo intentas explicar mejor y nos vuelcas las reglas aquí?

🗨️ 14
BocaDePez
BocaDePez

No, no hago doble NAT, aunque tambien tengo equipos que cuelgan solo del cisco, pero en este caso, mi problema trata solo de la lan del TP-LINK.

Tengo lo siguiente: cisco lan x DHCP ==><==TP-LINK wan x DHCP | TP-LINK lan x IP fija a varios equipos x cable y x wifi.

Ya te digo que no tengo ningun problema en la red aparte de no poder ver los equipos de la lan del TP-LINK entre ellos. Ping me responde " host de destino inaccesible", salvo que desactive el firewall del TP-LINK.

🗨️ 13
BocaDePez
BocaDePez

Entonces no interesa ni la LAN del Cisco ni cómo está configurada la WAN del TP-Link, ya que el problema sería ajeno a esa zona.

El tema del AP Isolation que otro compañero citó al principio, sería importante porque haría invisibles los equipos de la LAN a los de la WLAN y viceversa.

Si los equipos de la LAN (cableada) del TP-Link no se ven entre sí, a mí lo único que se me ocurriría es que estuviesen aislados por VLANes diferentes.

Si dices que desconectando el firewall se soluciona, ¿por qué no vuelcas en el foro las reglas de iptables y las comentamos?

🗨️ 12
BocaDePez
BocaDePez

Pues no se muy bien como hacer para volcarlo desde el tp-link a un windows por ejemplo, si hago iptables-save por SSH o por la shell web, no me reconoce el comando.

Otro dato: he hecho muchas pruebas estos dias y por ello igual estaba un poco confundido, en este momento, tanto con el firewall activado como desactivado, entre dos equipos windows, uno con W8, y otro con W8.1, puedo ver a ambos equipos en la carpeta de red y puedo hacer ping, pero no puedo acceder a los equipos. Lo realmente curioso es que por IP si que puedo acceder de W8 a W8.1 incluso con firewall activo, pero no asi al reves.

La red está montada en 255.255.255/29, va desde la 184 a la 191, el router tiene asignada la 188, y el resto, de la 185 a la 190 para equipos.

Realmente, esto ya empieza a tenerme comida la moral, pues hasta ahora no habia tenido problemas de este tipo para ver equipos en una lan.

🗨️ 11
BocaDePez
BocaDePez
🗨️ 5
BocaDePez
BocaDePez
🗨️ 4
BocaDePez
BocaDePez
🗨️ 3
BocaDePez
BocaDePez
🗨️ 2
BocaDePez
BocaDePez
🗨️ 1
BocaDePez
BocaDePez
BocaDePez
BocaDePez
BocaDePez
BocaDePez
🗨️ 3
BocaDePez
BocaDePez
🗨️ 2
BocaDePez
BocaDePez
🗨️ 1
BocaDePez
BocaDePez