Banda Ancha EU

Comunidad de usuarios
de fibra, móvil y ADSL

hosting en interdominios
66 lecturas y 14 respuestas
  • Cerrado

    BocaDePez BocaDePez
    6

    Incapaz de configurarlo en monopuesto + router

    Hola a todos.

    Os cuento mi situación. Tengo un SS5660. Hace unos meses me compré un Linksys wrt54g, es un router con wifi, pero que no tiene modem ADSL.

    Ahora mismo el ss5660 está en modo router, y todo funciona. Peero como ya es conocido, es ss5660 tiene un defecto que hace que las conexiones se saturen cuando utilizas programas P2P (especialmente mldonkey). Lo que quiero hacer es que el ss5660 solamente actúe de módem ADSL, y que todo el trabajo de router lo haga el wrt54g.

    He probado dos alternativas:

    1) Poner el ss5660 en modo brigde. Todavía no tengo muy claro lo que este modo significa, yo pensaba que era la manera de hacer que hiciese exclusivamente de módem pero no me funciona. Entonces, una vez configurado como brigde el speedstream, al wrt54g lo configuraba con mi IP pública para el interfaz WAN, y como gateway le daba la que me proporciona Terra (mi ISP). Y enchufaba un cable de red desde el interfaz ethernet del ss5660 a la entrada "Internet" del wrt54g. A continuación, en todos los ordenadores de mi red ponía como puerta de enlace la IP privada del wrt54g. Pero no funciona.

    2) Seguir los tutoriales que hay en internet para poner manualmente el ss5660 en monopuesto. Igualmente, conectaba el cable de red al interfaz "Internet" del wrt54g, y configuraba las IPs de este último de la misma manera que en el caso 1). Pero tampoco me funciona.

    Hay un hilo de hace poco en el que se pregunta lo mismo, y Tatolino explica la solución (que es la del caso 2), pero no soy capaz de hacerlo funcionar. Mis dudas son varias:

    a) ¿Hay que realizar alguna configuración de las rutas estáticas, en el ss5660 o en el wrt54g, para que funcione?
    b) ¿Importa el uso de cables de red cruzados o no-cruzados en las conexiones? Según tengo entendido, el wrt54g detecta automáticamente la configuración del cable, pero no estoy seguro.
    c) El firmware del wrt54g me da la opción de configurarlo como gateway o como router. ¿Cual es la correcta?

    Igual no se explicarme bien, si es así lo siento. Cualquier ayuda que podais darme será bienvenida.

    Muchas gracias!

    Este tema es antiguo y puede contener información obsoleta. Abre un nuevo tema para publicar tu mensaje.
    1
    • Cerrado

      [Editado 24/01/06 22:52]

      La opción que debes seguir es la 2, es decir: -SS5660…

      La opción que debes seguir es la 2, es decir:

      -SS5660 configurado en monopuesto.
      -WRT54G configurado en modo router.

      Nada de bridge, eso es para monopuesto cuando tienes IP dinámica.

      Respecto a tus preguntas:

      a) No hay que configurar rutas estáticas en ninguno de los dos routers.
      b) Tienes que usar el mismo cable que usas ahora en multipuesto pero conectado a la entrada "Internet" del WRT54G.
      c) El WRT54G debbes configurarlo en modo gateway.

      Lo que te recomiendo es que primero configures el SS5660 en monopuesto con IP fija siguiendo los pasos del enlace que di en mi post del otro hilo, aunque he visto un error en dicho tutorial en lo referente al cálculo de la "puerta de enlace remota" o sea la IP que debemos colocar en la parte ethernet del ss5660. Dicha puerta de enlace se obtiene sumando 1 no 2 al final de la IP.

      Cuando hayas configurado el ss5660 en monopuesto, comprueba si tienes conexión conectando el ss5660 a un ordenador (sin el wrt54g) y si te funciona, pasas a configurar el wrt54g como se dice en mi otro post metiendo tu ip pública y demás datos y, por supuesto, conectando el ss5660 a la entrada Internet del wrt54g.

      En el tcp/ip de los ordenadores debes poner ips que estén en el rango de la ip de red del wrt54g y como puerta de enlace predeterminada la ip de red del wrt54g.

      Saludos

      • Cerrado

        BocaDePez BocaDePez
        6

        Muchas gracias de verdad. Ya he visto que se ha comentado…

        Muchas gracias de verdad. Ya he visto que se ha comentado este tema hace poco pero es que lo he intentado varias veces y no lo doy conseguido.

        Una duda que me asalta con lo del monopuesto es lo del método del AND y el +1. Mi ISP me da como gateway la máquina 80.XX.XX.2 con máscara 255.255.255.0. Entonces, cuando pongo el ss5660 en monopuesto, calculo su IP para el puerto ethernet y me queda como 80.XX.XX.1 (mi IP es fija y está dentro del mismo rango que el gateway, cambia el último numero ná más)

        ¿Es correcto? Ahora bien, cuando configure el PC para comprobar la conexión, ¿que puerta de enlace pongo en la configuración del interfaz de red? ¿80.XX.XX.1 (que es la que he calculado para el ss5660) u 80.XX.XX.2 (que es la que me da Terra como gateway)? El caso es que, sea cual sea la correcta, veo que la otra IP se queda colgando sin utilizarse para nada :-? Con el +2, me coincidía el cálculo, aunque de todas formas tampoco era capaz de hacer funcionar la conexión. Y se me hace rrarro rrarro aplicar la IP que pertenece a otra máquina, a mi router, ezo no lo yego yo a conchabá :-)

        Los pasos que me das pienso que los he realizado todos correctamente, pero algo se me debe escapar y/o me estoy haviendo la picha un lio. Lo que si tengo que hacer es probar primero con el PC a ver si funciona la conexión sin el wrt54g de por medio.

        Gracias de nuevo.

        • Cerrado

          [Editado 20/01/06 18:47]

          Bueno, veamos. Hay que distinguir dos IPs: 1. La IP ethernet…

          Bueno, veamos. Hay que distinguir dos IPs:

          1. La IP ethernet del router que es la 80.x.x.1 (la del +1) esta has de ponerla como IP ethernet del router.

          2. La IP de la puerta de enlace remota, que es la 80.x.x.2 (la del +2). Esta IP es la del router del proveedor, también llamada puerta de enlace remota o gateway (es la que suele dar el proveedor de Internet). Esta IP se usa en la configuración multipuesto.

          Lo que te decía en mi anterior post es que primero compruebes, después de configurar el ss5660 en monopuesto, que tienes conectividad a Internet, sin intercalar el WRT54G. Para ello en las propiedades TCP/IP de dicho ordenador tendrás que configurar lo siguiente:



          Como puedes ver aqui si hay que poner la IP ethernet del ss 5660 (la del +1) como puerta de enlace predeterminada.
          ____________________________________

          Si lo anterior te funciona (que te ha de funcionar ;-)) ya podrás pasar a intercalar el WRT54G entre el Speed y tus ordenadores.

          La conexión física ha de ser: de la salida ethernet del ss5660 y con cable de red recto conectas al puerto Internet del WRT y también con cables de red rectos, conectas tus ordenadores cableados a cualquiera de los 4 puertos LAN del switch del WRT (desde sus tarjetas de red).

          Por defecto, el WRT54G viene con la IP de LAN 192.168.1.1 y con el servicio DHCP activado. Puedes dejarle esta IP por defecto pero te recomiendo que desactives el servicio DHCP del router porque puede entorpecer los mapeos de puertos que, posteriormente, quieras hacer.

          Si conservas la IP por defecto del router (192.168.1.1) y desactivas el DHCP del router, deberas configurar el TCP/IP de tus ordenadores según la figura que muestro a continuación:



          Aquí, como puedes ver, fijamos una IP al ordenador 192.168.1.2 (si tienes más ordenadores, puedes darles IPs consecutivas 192.168.1.3, etc.). Máscara 255.255.255.0 y como puerta de enlace la IP de LAN del WRT 192.168.1.1

          En la parte WAN del WRT deberás configurar lo siguiente:



          Es decir:

          1. En Internet Address tu IP pública 80.x.x.y
          2. En Subnet Mask 255.255.255.0
          3. En Gateway la IP ethernet del SS 5660. Si, la del +1, 80.x.x.1

          Uff... espero que lo dicho te sirva.

          Saludos

          P.D.:
          Me dejaba un detalle: si pones los DNS en el propio router (recomendable), en las propiedades TCP/IP de los ordenadores deberías configurar en vez de DNS poner solo la IP del router como DNS principal y sin DNS secundario, es decir:

          • Cerrado

            BocaDePez BocaDePez
            6
            Joder, estás hecho un fiera, muchísimas gracias. Estoy seguro…

            Joder, estás hecho un fiera, muchísimas gracias. Estoy seguro de que esta va a ser la buena (y si no zoy tonto y me dedico a otra cosa, porque más mascado imposible...), ya contaré por aquí cómo ha ido.

            PD.: la info sobre los DNS está muy bien, no lo sabía, yo las tengo puestas en los routers y siempre las ponía también en todos los equipos de la red.

            • Cerrado

              BocaDePez BocaDePez
              6
              En fins, o soy muy torpe, o tengo algún dato mal, o no se. Lo…

              En fins, o soy muy torpe, o tengo algún dato mal, o no se. Lo único que no he hecho todavía ha sido hacer un default all y empezar de cero, me da yuyu cargarme toda la configuración, sobre todo la tabla NATP. Aunque acabaré haciéndolo... creo que se puede exportar la configuración a un fichero, si mal no recuerdo.

              Tras hacer todo me pasa lo de siempre, ni se resuelven las URLs ni puedo hacer ping a ninguna IP. Parpadean un poco ATM y ENET, pero nada más. Y lo he probado desde windows, linux y macintosh.

              Bueno, en cualquier caso muchas gracias Tatolino, me has ayudado mucho y no quiero darte más la brasa. Seguiré intentandolo...

              Saludos!

              • Cerrado

                [Editado 20/01/06 14:44]

                Bueno, si te atreves al cepillado total del Speed 5660 que,…

                Bueno, si te atreves al cepillado total del Speed 5660 que, por otro lado, creo es lo mejor, deberías meterte por la consola del router y:

                1. Guardas la config actual (miedoso xDD): Ahí se explica:
                http://s48.yousendit.com/d.aspx?id=0UFQZRR9154J73S3OHEKLQGPJM

                2. A teclear:
                http://p076.ezboard.com/fadsl4everfrm11.showMessage?topicID=60.topic

                Si con eso no logras tener el ss5660 en monopuesto... en fin.

                Saludos

                P.D.IMPORTANTE:

                Me acabo de dar cuenta de un error. La IP de la puerta de enlace predeterminada tiene que ser la del +1, no la del +2. Sorry.
                Ya rectificaré las imágenes.

                • Cerrado

                  BocaDePez BocaDePez
                  6
                  Respondo a tu postdata: gracias por el dato. Creo que ya…

                  Respondo a tu postdata: gracias por el dato. Creo que ya probé también a poner la puerta de enlace a +1, pero bueno, con la de combinaciones que he hecho, quizás alguna otra cosa estaba mal mientras en otro lado. Probaré de nuevo.

                  Gracias majo!

                    • Cerrado

                      BocaDePez BocaDePez
                      6
                      Hola. Con el trabajo que te has tomado para ayudar, las…

                      Hola. Con el trabajo que te has tomado para ayudar, las disculpas no son necesarias :-)

                      Además, hay novedades. Empezando desde cero (default all) y con la puerta de enlace correctamente puesta a 80.x.x.1, conetando directamente al PC ya tengo internet. En cambio, cuando pongo de por medio el wrt45g, me resuelve las URL pero de ahí no pasa (antes ni siquiera resolvía las URL). La configuración de la tarjeta ethernet de los equipos de la red es correcta, así como las conexiones físicas de los cables.

                      Si hago un traceroute a barrapunto.com (por ejemplo) desde mi PC (192.168.0.4), no paso del router wrt54g (192.168.0.254). Si entro por telnet al wrt54g, y desde él hago el mismo traceroute, todo va bien. Es decir, la configuración monopuesto del ss5660 ya es la correcta. Pero no acabo de configurar bien el wrt54g para que sirva la conexión al resto de ordenadores de la LAN. Aunque en principio debería estar bien. Estas son las configuraciones que tengo puestas en el wrt54g:

                      Tipo de conexión a internet: estática
                      IP pública: 80.x.x.y
                      Máscara: 255.255.255.0
                      Gateway: 80.x.x.1
                      DNS: los que me da el ISP (195.235.113.3 y 195.235.96.90)

                      Advanced routing: RIP2 router

                      La única duda que tengo es respecto a qué poner en el gateway de la "Configuración de red local": 192.168.0.254, 80.x.x.1, 80.x.x.2 o 0.0.0.0. Pero he probado con todas.

                      Por otra parte, en las ethernet de los equipos locales:

                      gateway: 192.168.0.254 (ip del wrt54g)
                      DNS: 192.168.0.254
                      ...

                      Bueno, con esto está claro que ya consigo poner el ss5660 en monopuesto. Ahora se trata de que el wrt54g sirva la conexión WAN a la LAN... eso ya es otra historia. Si se te ocurre algo te agradezco que lo compartas. Si no, o ya te has cansado... lo comprendo XD. En cualquier caso te debo una pila de cañas y una estatua xDDD si vives por madrid te las pago: carlos.bravo en gmail.com

                      Saludos!

                      • Cerrado

                        [Editado 23/01/06 18:54]

                        Bueno, ya es mucho que tengas el ss 5660 en mono.;-) Nunca he…

                        Bueno, ya es mucho que tengas el ss 5660 en mono.;-)

                        Nunca he probado esta combinación de routers con IP estática. Lo que está claro es que el RIP tiene que estar deshabilitado (Terra no lo usa).

                        Veo correcta la parte WAN en el Linksys y también la ethernet de tus equipos.



                        Editado:

                        La configuración correcta para el Linksys, apartado Advanced Routing, es como Gateway, no como Router (ver posts más abajo).

                        • Cerrado

                          BocaDePez BocaDePez
                          6
                          ¡¡CONSEGUIDO!! uf, al fin.Creí que iba a volverme loco. Sin…

                          ¡¡CONSEGUIDO!!

                          uf, al fin.Creí que iba a volverme loco. Sin tu ayuda y paciencia creo que no lo hubiese conseguido, o me hubiese costado mucho más.

                          Resumiendo: todos los pasos de configuración del SS5660 son tal y como tú explicas. Es en la parte del Linksys donde está el detalle. La IP WAN, el gateway el 80.x.x.1... todo correcto. Pero el modo de funcionamiento del router es gateway, no router. Ahí está la clave. Estuve estrujándome los sesos probando con las rutas estáticas, hasta que leí la ayuda del router, donde dice que "la configuración gateway es la adecuada para la mayoría de usuarios". El manual está orientado a configurar una red doméstica con un módem ADSL conectado al Linksys. Ya había probado el modo gateway, pero antes de tener el resto de la configuración bien, y no me rulaba.

                          Ahora que el resto de los pasos están encajados, fue ponerle a gateway y empezar a navegar! Ahora a ver si noto mejora con el mldonkey funcionando.

                          Saludos y gracias de nuevo!

                          • Cerrado

                            Me alegro sinceramente que te funcione 8-). Cualquiera cae en…

                            Me alegro sinceramente que te funcione 8-).

                            Cualquiera cae en lo de funcionamiento como gateway XDD. Lo lógico es pensar que funciona como router ¿no? En fin... seguramente eso de gateway esté por defecto en el router y en este caso no haría falta más que configurar WAN y LAN y marchando.

                            Bueno, pues esperemos que este hilo sirva a otros que quieran aprovechar su viejo SS5660 como módem y tener una red wireless con el wrt54g. Con esta combinación es esperable que tu red te funcione mucho mejor.

                            Saludos

                            P.D.: cuando tenga un rato corregiré el último pantallazo del wrt54g para no llevar a error a nadie. ;-)

                • Cerrado

                  BocaDePez BocaDePez
                  6
                  jeje, ya lo hice ayer, más tarde... y a pelo, como los…

                  jeje, ya lo hice ayer, más tarde... y a pelo, como los buenos. Bueno no tanto, recordé que ya me había hecho una imagen de la configuración hace no mucho.

                  Por cierto que he estado siguiendo un tutorial tuyo mediante la línea de comandos del router que hay en una página... no me acuerdo del nombre, una con fondo negro y las letras amarillas..

                  Tampoco ha habido suerte. A mi, lo que más me extraña es mi máscara de red pública. Es decir, es 255.255.255.0, con lo que al hacer el AND simpre te sale 1, tengas el número que tengas al final de tu IP pública. En los ejemplos de los tutoriales la máscara es siempre 255.255.255.192 o algo así. Entonces, qué pasa, ¿que todos los usuarios de Terra que estén en el mismo rango que mi IP pública, y que supongo que tienen la misma máscara que yo, les sale la misma IP (80.x.x.1) al hacer el cálculo? Me parece mosqueante cuando menos. Lo malo es que llamé a terra para que me confirmasen mi máscara pública y sí, según ellos es 255.255.255.0.

                  Mi última esperanza: a ver si con el programita de Megavía ese...

                  Saludos.

                  • Cerrado

                    [Editado 20/01/06 19:25]

                    No te extrañe lo de la máscara 255.255.255.0 porque realmente…

                    No te extrañe lo de la máscara 255.255.255.0 porque realmente Terra y Telefónica la usan en muchos casos. Lo que pasa es que en los tutoriales suele ponerse 255.255.255.192 porque a los primeros ADSLs siempre se les daba esta máscara.

                    Todos los usuarios que están en tu segmento de red salís a través del mismo gateway (puerta de enlace remota) que no es la del +1, sino la del +2, por supuesto, eso es lo lógico.

                    Es decir, que si tu IP pública es, pongamos 80.25.41.122 con máscara pública 255.255.255.0, saldrás por el gateway 80.25.41.2 y también saldrán por ahi todos los usuarios cuya IP pública esté comprendida entre 80.25.41.3 y 80.25.41.254, ambas inclusive, estando reservadas (no asignadas a usuarios):

                    80.25.41.1 ->IP para monopuesto (ethernet del router)
                    80.25.41.2 ->IP router espejo del ISP o gateway remoto.
                    80.25.41.255 ->Reservada para Broadcast.

                    El "camino" para un router en monopuesto es (suponiendo tu caso, mascara pública 255.255.255.0):

                    Ordenador (IP pública 80.X.X.Y) ->Ethernet del router (80.X.X.1) ->Router espejo ISP (80.X.X.2)

                    Editado

                    P.D. No te recomiendo el empleo del Megavía porque te hará una configuración monopuesto con DHCP activado, cosa que complica la configuración un poco (me refiero a la del WRT, ya no te serviría lo dicho por mi).