Banda Ancha EU

Comunidad de usuarios
de fibra, móvil y ADSL

hosting en interdominios
79 lecturas y 30 respuestas
  • Impresora USB en comtrend?

    Hola. He estado mirando en los diferentes posts de firmwares del comtrend a ver si alguien había conseguido hacer del "puerto" usb del comtrend algo útil.

    Me explico: tengo que instalar una impresora usb en una red, y paso de tener que conectarla a un ordenador, para luego que los otros 4 que tengo puedan imprimir en esa impresora.

    He estado leyéndome por encima el post kilométrico de los firmwares modificados, clores remezclas remixes de USR con ASUS y demás cosas, y he visto que un muchacho consiguió imprimir a través del ruter.

    Se perdía la WIFI? Es posible obtener ese firmware? es estable?

    No necesito ninguna maravilla, ya que tengo 3megas contratados, y con el ruido que tiene mi linea llegan bastante justos, pero no necesito exprimir el ruter al 100%

    En fin, perdón por tanta vuelta como he dado. Resumiendo: ¿Hay alguna manera de conectar una impresora USB al ruter y conseguir imprimir?

    Muchas gracias

    Este tema lleva más de 6 meses inactivo. Es recomendable que abras un nuevo tema para retomar la conversación.
    1
    • BocaDePez BocaDePez
      6

      No hay manera de comunicarme con el router raulito. La unica…

      No hay manera de comunicarme con el router raulito. La unica luz que se me enciende es la de la Lan, La PWR esta apagada tambien. Probe a poner 192.168.1.1/upload.htm y cosas asi pero no hay manera. A ver si puedes ayudarme. Gracias

      • [Editado 21/03/08 11:19]

        De que Huawei estamos hablando y qué luces son? Si es el hg50…

        De que Huawei estamos hablando y qué luces son?

        Si es el hg50 te servirá ésto: http://www.bandaancha.st/foros.php?temid=1426284

    • En realidad lo que quiero es imprimir con una HP de estas de…

      En realidad lo que quiero es imprimir con una HP de estas de las mas perras, una HP deskjet 3745.

      El tema es que tenemos 2 portátiles en casa y 2 fijos, y apenas utilizamos los fijos, y los portátiles, como que no les vas a estar enchufando la impresora y tener que instalarte toda la mierda de controladores de HP....

      No es una multifunción, supongo que con esas claro que te tienes que olvidar, pero ya digo, es una super cutre, de las de 30e que terminas pagando a base de comprar cartuchos de tinta originales (el que los compre) a 40e....

      Muchas gracias por el interés, y que eso no muera, que creo que se podrá hacer....

      Por el tema de soldar, ya digo, el conector USB es una tontería instalarlo en el ruter, solo son 4 cables.

      Y sobre el NAS que dice el compañero líneas arriba, decirte que en estos momentos no veo la necesidad de comprarme un NAS, antes compraría un servidor de impresión WIFI y a volar, pero me mola el tema de cacharrear...

      Saludos!

      • [Editado 20/03/08 14:54]

        Yo hasta que alguien me venda un hawei de esos que da jazztel…

        Yo hasta que alguien me venda un hawei de esos que da jazztel ahora no me voy poner "cacharear" ,Lo de usb el comtrend tiene dos usb uno que en los firm esta configurado para poder usar usb como conexion (que funciona)y el otro que no lo probe de todo para conectar impresoras en teoria ,Lo que no doy terminado es lo de recuperacion via jtag devido ala poca velocidad que tenia bajo interfaz wingle y que no termina bootear por que se que tengo hace una conversion de las isos antes de poderlas suvir via jtag,lo bueno es que ya tengo la interfaz jtag usb (me costo un mes encontrar una barata) 37€ ...
        Ahora me falta un hawei para las pruebas para mutarlo en comtrend como meterme a termian lo de recuperacion via interfaz wingle si puedo mirare lo de el usb pero eso es mas tema de soft que de hard.
        PD:Esto puede abrir la caja de pandora a routers como los thomson y livebox de wanadoo.

        • [Editado 20/03/08 15:41]

          Lo del Huawei ya lo tengo yo arreglado. El problema que tiene…

          Lo del Huawei ya lo tengo yo arreglado. El problema que tiene el Huawei es que la placa está identificada como 96348GW-HG520-1, que creo que sabes de sobra que se puede cambiar en el CFE. Lo que pasa es que no todo el mundo tiene acceso al CFE, así que el "workaround" es modificar el firmware para que soporte ese nombre de placa, con los mismos parámetros que el 96348GW-11, que es el Comtrend.

          Obviamente, con ese nombre de placa, entonces el firmware no es capaz de acceder al switch ethernet y a la memoria, entonces lo que ocurre es que se queda tonto o se reinicia.

          Tienes que ponerle el driver ethernet del Huawei también, porque si no no detecta el cable y desactiva la interfaz ethernet. Lo malo es que los leds no funcionan como deberían...pero lo demás funciona bastante bien.

          Y respecto al tema principal, pues si el firm del asus no se puede, entonces el del usr 9107/9108 :)

          • Yo lo arregele metiendo la mac otra vez en los parametros de…

            Yo lo arregele metiendo la mac otra vez en los parametros de board parace que al migrar la mac vuela con lo que se queda esperando que la metas en el cfe pero al no tener acceso via enthernet a el cfe el resto valores los deje igual esto era con el comtrend pasando a firm de hawei tendria que ver con el hawei meterle el del comtrend y hacer un backup de todo ,volver al de hawei y desde ese probar el backup si funciona correctamente con lo que serian firms especiales comtrend para hawei y asi matamos de un tiro el problema de volver a firm originales hawei
            por eso necesito un hawei para los tests.

            • Pero si ya está, melón :P CFE version cfe.d010.2103 for…

              Pero si ya está, melón :P

              CFE version cfe.d010.2103 for BCM96348 (32bit,SP,BE)
              Build Date: Tue Oct 25 20:59:43 CST 2005 (z47214@server)
              Copyright (C) 2000,2001,2002,2003 Broadcom Corporation.

              Initializing Arena.
              Initializing Devices.
              Ethernet Network Device: External PHY
              CPU type 0x29107: 240MHz, Bus: 133MHz, Ref: 26MHz

              Total memory used by CFE: 0x80401000 - 0x80523020 (1187872)
              Initialized Data: 0x8041AFB0 - 0x8041C990 (6624)
              BSS Area: 0x8041C990 - 0x80421020 (18064)
              Local Heap: 0x80421020 - 0x80521020 (1048576)
              Stack Area: 0x80521020 - 0x80523020 (8192)
              Text (code) segment: 0x80401000 - 0x8041AFA4 (106404)
              Boot area (physical): 0x00524000 - 0x00564000
              Relocation Factor: I:00000000 - D:00000000

              Board IP address : 192.168.0.10:ffffff00
              Host IP address : 192.168.1.100
              Gateway IP address :
              Run from flash/host (f/h) : f
              Default host run file name : vmlinux
              Default host flash file name : bcm963xx_fs_kernel
              Boot delay (0-9 seconds) : 1
              Board Id Name : 96348GW-HG520-1
              Psi size in KB : 64
              Number of MAC Addresses (1-32) : 11
              Base MAC Address : xxxxxxxxxxxx
              Serial Number : 215008021xxxxxxxxx
              Ethernet PHY Type : Internal
              Memory size in MB : 16

              *** Press any key to stop auto run (1 seconds) ***
              Auto run second count down: 0
              Code Address: 0x80010000, Entry Address: 0x80188018
              Decompression OK!
              Entry at 0x80188018
              Closing network.
              Starting program at 0x80188018
              Linux version 2.6.8.1 (root@kitchensrv) (gcc version 3.4.2) #14 Wed Mar 19 18:58:32 UTC 2008
              Total Flash size: 4096K with 71 sectors
              ***Board is not initialized****: Using the default PSI size: 24
              Scratch pad is not used for this flash part.
              96348GW-HG520-1 prom init
              CPU revision is: 00029107
              mpi: No Card is in the PCMCIA slot
              Determined physical RAM map:
              memory: 00fa0000 @ 00000000 (usable)
              On node 0 totalpages: 4000
              DMA zone: 4000 pages, LIFO batch:1
              Normal zone: 0 pages, LIFO batch:1
              HighMem zone: 0 pages, LIFO batch:1
              Built 1 zonelists
              Kernel command line: root=31:0 ro noinitrd
              brcm mips: enabling icache and dcache...
              Primary instruction cache 16kB, physically tagged, 2-way, linesize 16 bytes.
              Primary data cache 8kB 2-way, linesize 16 bytes.
              PID hash table entries: 64 (order 6: 512 bytes)
              Using 120.000 MHz high precision timer.
              Dentry cache hash table entries: 4096 (order: 2, 16384 bytes)
              Inode-cache hash table entries: 2048 (order: 1, 8192 bytes)
              Memory: 14112k/16000k available (1307k kernel code, 1868k reserved, 193k data, 72k init, 0k highmem)
              Calibrating delay loop... 239.20 BogoMIPS
              Mount-cache hash table entries: 512 (order: 0, 4096 bytes)
              Checking for 'wait' instruction... unavailable.
              NET: Registered protocol family 16
              Can't analyze prologue code at 80155464
              PPP generic driver version 2.4.2
              NET: Registered protocol family 24
              Using noop io scheduler
              bcm963xx_mtd driver v1.0
              brcmboard: brcm_board_init entry
              bcm963xx_serial driver v2.0
              NET: Registered protocol family 2
              IP: routing cache hash table of 512 buckets, 4Kbytes
              TCP: Hash tables configured (established 512 bind 1024)
              NET: Registered protocol family 1
              NET: Registered protocol family 17
              Ebtables v2.0 registered
              NET: Registered protocol family 8
              NET: Registered protocol family 20
              VFS: Mounted root (squashfs filesystem) readonly.
              Freeing unused kernel memory: 72k freed
              init started: BusyBox v1.00 (2008.03.19-17:37+0000) multi-call binary
              Algorithmics/MIPS FPU Emulator v1.5

              BusyBox v1.00 (2008.03.19-17:37+0000) Built-in shell (msh)
              Enter 'help' for a list of built-in commands.

              Loading drivers and kernel modules...

              atmapi: module license 'Proprietary' taints kernel.
              blaadd: blaa_detect entry
              adsl: adsl_init entry
              Broadcom BCMPROCFS v1.0 initialized
              Broadcom BCM6348B0 Ethernet Network Device v0.3 Apr 21 2006 15:37:05
              Config Ethernet Switch Through SPI Slave Select 0
              eth0: MAC Address: xxxxxxxxxx
              Broadcom BCM6348B0 USB Network Device v0.4 Nov 18 2005 16:39:32
              usb0: MAC Address: xxxxxxxxxxxxxxx
              usb0: Host MAC Address: xxxxxxxxxxxxxxxxxxx
              PCI: Setting latency timer of device 0000:00:01.0 to 64
              PCI: Enabling device 0000:00:01.0 (0004 -> 0006)
              wl: srom not detected, using main memory mapped srom info (wombo board)
              wl0: wlc_attach: using main board MAC address base in NVRAM (wombo board)
              wl0 MAC Address: xxxxxxxxxxxxxxx
              dgasp: kerSysRegisterDyingGaspHandler: wl0 registered
              wl0: Broadcom BCM4318 802.11 Wireless Controller 3.91.41.0
              eth0 Link UP.
              BcmAdsl_Initialize=0xC0054208, g_pFnNotifyCallback=0xC0067374
              AdslCoreHwReset: AdslOemDataAddr = 0xA0FF74C4
              dgasp: kerSysRegisterDyingGaspHandler: dsl0 registered
              ip_tables: (C) 2000-2002 Netfilter core team
              ip_conntrack version 2.1 (125 buckets, 0 max) - 368 bytes per conntrack
              ip_conntrack_rtsp: falsely claims to have parameter setup_timeout
              ip_conntrack_rtsp v0.01 loading
              ip_nat_rtsp v0.01 loading

              ==> Bcm963xx Software Version: A101-302JAZ-C01_R05.A2pB018b3.d16f
              device usb0 entered promiscuous mode
              br0: port 1(usb0) entering learning state
              br0: topology change detected, propagating
              br0: port 1(usb0) entering forwarding state
              device eth0 entered promiscuous mode
              br0: port 2(eth0) entering learning state
              br0: topology change detected, propagating
              br0: port 2(eth0) entering forwarding state
              Setting country code "ES"
              device wl0 entered promiscuous mode
              br0: port 3(wl0) entering learning state
              br0: topology change detected, propagating
              br0: port 3(wl0) entering forwarding state
              pvc2684d: Interface "nas_8_35" created sucessfully

              pvc2684d: Communicating over ATM 0.8.35, encapsulation: LLC

              device nas_8_35 entered promiscuous mode
              br0: port 4(nas_8_35) entering learning state
              br0: topology change detected, propagating
              br0: port 4(nas_8_35) entering forwarding state
              br0: port 1(usb0) entering disabled state

              Queda claro que es el Huawei? :P

                • 6
                  Como siempre, y antes de colgarlo, vamos a esperar unos días…

                  Como siempre, y antes de colgarlo, vamos a esperar unos días a probarlo , a ver qué tal va. Si supera determinado tipo de problemas, se abre para pruebas para todos los usuarios del huawei. En principio hay que esperar aunque sea una semana antes de colgarlo ;)

                  Saludos

                • Hay varios problemas. El primero es que el led del adsl no…

                  Hay varios problemas. El primero es que el led del adsl no funciona correctamente(eso después de haber arreglado el del ppp y el del wifi). Y lo otro es que el botón del reset tampoco funciona. A ver si consigo arreglar el botón del reset y entonces ya veré si lo cuelgo.

                  • [Editado 21/03/08 12:19]

                    6
                    El botón de reset funciona, lo único que no lo ves porque los…

                    El botón de reset funciona, lo único que no lo ves porque los leds no se encienden, así que no se ve. Para resetear con este simplemente pincha en el botón de reset, apaga y enciende mintras lo pulsas y ya está :) Un hard reset light por decirlo de alguna manera...

                    Saludos

                    • Buenas!! Qué alegría!!!!!!!!!!!!!!!!! Que lástima que no esté…

                      Buenas!!

                      Qué alegría!!!!!!!!!!!!!!!!!

                      Que lástima que no esté en mi domicilio como estaba antes... ahora tengo el internet de prestado (me he tenido que mudar a casa de mis padres... :-| ) y di de baja mi otra conexión (por suerte en su día le convencí para que se pusiera jazz).

                      Pero el huawey lo tengo guardadito, para en un futuro (espero no muy lenajo), poder hacerle perrerías como en antaño... 8-) 8-) 8-)

                      Por otro lado, veo bien que os asegureis que el firmware funciona como es debido para publicarlo, pero... aún así deberíais ponerlo como beta o algo por el estilo y que cada cual, se apañe si funciona o no funciona...

                      Ya me gustaría meterle algún demonio torrent con un HD USB y dejar sólo el tiestito encendido... (que esa era mi idea originaria).

                      Recuerdo que me quedé en eso, que las luces del HUAWEY se quedaban idiotas... pero veo que no desististe y tiraste para alante con el proyecto.

                      A ver si al final obtienes el fruto y haces del cacharro algo menos que eso... un cacharro...

                      Me gustaría ver las caras de los de Jazz si derrepente la gente quiere los huawey en vez de los comtrend... :-D :-D :-D :-D ;-) ;-) ;-) ;-) ;-) ;-)

                • Jopetas que lenguaje!!! Como pilota aquí la peña..... Yo lo…

                  Jopetas que lenguaje!!!

                  Como pilota aquí la peña.....

                  Yo lo que ando buscando es ponerle un conector al ruter, soldar los 4 cables a la pcb y meterle un .bin que ya esté hecho.

                  Sé que no es fácil, pero si es muy complicado dejadlo.

                  Si la solución es pasar a alguno de los firms de los US Robotics, decidme cual, peculiaridades, y ya me apañaré la wifi con algún punto de acceso que tengo por aquí arrumbado.

                  Por mi parte, os doy las gracias por el interés suscitado, y mucho ánimo

        • Yo creo que no se puede, el Comtrend solo usa un determinado…

          Yo creo que no se puede, el Comtrend solo usa un determinado tipo de protocolos, los cuales solo tienen funciones concretas como transferir archivos de un sitio a otro pero no se vincula a otros protocolos, para ello estan los aparatitos para servidor de impresión, ya que cogen y adaptan la señal de la impresora para que se pueda comunicar a través de un RJ45.
          Los aparatos de servidor de impresión salen a muy buen precio, aunque debas de tener un cacharro siempre funcionando, o si hay un ordenador que casi todo el dia está encendido pues se puede configurar ese ordenador como servidor de impresión.
          Hay muchas posibilidades pero siempre hay que fiarse por lo que se sabe que funciona, no vaya a ser que por cualquier problema te cargues el comtrend.
          Saludos a todos!!!

          • [Editado 20/03/08 00:30]

            El firm de Asus NO sirve, ya que los asus llevan un…

            El firm de Asus NO sirve, ya que los asus llevan un controlador Usb VIA (USB 2.0), externo al chip Broadcom. Modificando el firm de ASUS conseguí imprimir, pero solo reconoce algunas impresoras. Si es una multifunción alvídate.

            El comtrend tiene 2 USB 1.1, uno de ellos Host, por supuesto hay que soldar los conectores.

            Hace tiempo jugué con los firms pero, conseguí instalar samba y conectar un HD y una impresora, pero me cepillé al ADSL y el WIFI.

            Si alguien está interesado puedo buscar los cambios que hice.

            Saludos

            PD:Raulito eres un crack montando firms

            • BocaDePez BocaDePez
              6
              como se monta samba en un ct 5631 no encuentro la info en…

              como se monta samba en un ct 5631 no encuentro la info en ningun sitio.

              Gracias por adelantado

        • Igual no tiene nada que ver, pero a lo mejor te vale como…

          Igual no tiene nada que ver, pero a lo mejor te vale como alternativa. Me compré hace un par de meses una NAS de conceptronic con dos discos, que tiene una salida USB con un servidor de impresión, para hacer lo que buscas, además está bastante bien de precio.

          Busca en google por CH3SNAS.

          Suerte