Banda Ancha EU

Comunidad de usuarios
de fibra, móvil y ADSL

hosting en interdominios
65 lecturas y 20 respuestas
  • Cerrado

    Hasta 6 Megas: "downgrade" de bajada-> downgrade de subida

    Debido a continuas pérdidas de sincronismo en mi servicio "Hasta 6 Megas", me han estado haciendo pruebas y han decidido probar hacerme una limitación de velocidad de bajada (un "downgrade"). Mención aparte de un técnico que hace poco me aseguraba que no era posbile hacerlo sin firmar un nuevo contrato, me ha sorprendido que, no sólo me han limitado en bajada a 4094 ("¡bien!"), sino que además me han limitado la subida entorno a 317 (en vez de los 512 del "hasta 6 megas": ¡horror!.

    Quien me atendió no parecía estar inicialmente del todo conforme, pero tras una llamada al equipo de gestión de red (tal es mi frustración que no sé si es el nombre exacto que les dio) me confirmó que sómo tienen perfiles fijos hecho para 2, 4, 6 y 8 megas con sus velocidades de subida predeterminadas. ¿Cómo puede estar la cosa tan limitada? ¿Acaso los DSLAM que usan son tan limitados que sólo permiten forzar unos sincronismos predefinidos, o es que el sistema de gestión que usa Jazztel es tan limitado que no permite definir valores a nivel individual?

    Por cierto, parece que la limitación a 4 megas no va a ser suficiente... toma 2 megas de bajada. :-( Por suerte no me seguirán bajando la subida.

    Este tema es antiguo y puede contener información obsoleta. Abre un nuevo tema para publicar tu mensaje.
    1
    • Cerrado

      6

      Pruebame esto por telnet: "adsl configure --snr 150" sin…

      Pruebame esto por telnet:

      "adsl configure --snr 150" sin comillas, te sincronizará a menos, a ver si se te corta así.

      En *teoria* (Tengo que hacer mas pruebas) esto hace que el router intente un SNR de 15.0dB.

      • Cerrado

        Jeje... Me precipité a probarlo y como mencionabas que creías…

        Jeje... Me precipité a probarlo y como mencionabas que creías que así forzaría un SNR de 15 dB, pasé como parámetro `--snr 15'. Soberbio en cuanto a ahorro de potencia del router, pero con 4 dB de margen de ruido te puedes imaginar la estabilidad de la conexión... :-o

        No consigo entender demasiado bien las unidades que se le está pasando. ¿Quizás sean dB/10 pero tenga la línea demasiado bailona como para comprobarlo? Es posible que esté omitiendo parámetros importantes (e.g. "D (interleave depth)" suele estar en 32, pero cuando el SNR es mejor, suele pasar a 16). Por si a alguien le interesa, aquí van algunas medidas parciales realizadas por el CT-536+:

        `--snr 70':
        SNR Margin (dB): 9.7 27.8
        Attenuation (dB): 39.5 20.5
        Output Power (dBm): 21.3 11.9
        Attainable Rate (Kbps): 5126 1145
        Rate (Kbps): 4094 317

        `--snr 100':
        SNR Margin (dB): 10.4 28.0
        Attenuation (dB): 39.5 20.5
        Output Power (dBm): 21.1 11.9

        `--snr 150':
        SNR Margin (dB): 12.4 28.2
        Attenuation (dB): 39.5 20.5
        Output Power (dBm): 20.1 11.8

        `--snr 150' (segunda vez):
        SNR Margin (dB): 14.0 27.2
        Attenuation (dB): 39.5 20.5
        Output Power (dBm): 19.9 11.9
        Attainable Rate (Kbps): 2678 1122
        Rate (Kbps): 2678 317

        `--snr 200':
        SNR Margin (dB): 15.6 27.6
        Attenuation (dB): 39.5 20.5
        Output Power (dBm): 19.6 12.0
        Attainable Rate (Kbps): 2453 1135
        Rate (Kbps): 2451 317

        • Cerrado

          Por cierto, ¿hay manera de ver si alguno de los canales está…

          Por cierto, ¿hay manera de ver si alguno de los canales está afectado por ruido de forma anormal? ¿`adsl show --SNR sirve para algo similar? No me resulta fácil interpretar los datos porque no tengo "scrollback" suficiente y ahora mismo no soy capaz de configurarlo...

          Y sin mucho que ver, PuTTY 0.58 me da un "connection reset by peer"... ¿hay algún problema en hacer ssh desde este programa al CT-536+?

          Para terminar, he decir que en media hora, con `adsl configure --snr 150', ya ha habido dos "ADSL link down" según dmesg, así que parece que no va a ser la solución. :-(

            • Cerrado

              Sobre telnet, teniendo ssh paso de usarlo. Tengo la red…

              Sobre telnet, teniendo ssh paso de usarlo. Tengo la red inalámbrica abierta a propósito, así que prefiero cubrirme las espaldas (aunque quien sea capaz de interceptar los paquetes Ethernet desde la red Wi-Fi seguro que puede ejecutar un ataque por intermediario... voy a tener que comprobar los estudios y aficiones de mis vecinos ;-)).

              En lo que se refiere al "connection reset", ahí va el texto que mandé a los desarrolladores. Básicamente:

              • CT-536+ se adelanta a PuTTY a la hora de elegir qué protocolos usar. No sé si esto está permitido en el protocolo.
              • PuTTY no responde con un subconjunto de las claves propuestas por CT-536+, sino que incluso incluye más. Esto no debería permitir el protocolo (al menos a largo plazo). Puede que PuTTY no esté respondiendo, sino directamente enviando el que cree que es el primer mensaje de negociación de protocolos.

              Lo que escribí (no incluí todas las observaciones anteriores :-|), por si alguien cree que debería hacer una corrección:

              Date: 25-oct-2005 14:45
              Subject: Bug?: "Connection reset by peer" when taliking to Busybox 1.0
              To: putty@projects.tartarus.org

              Hello.

              I am trying to connect via PuTTY's ssh to a Busybox 1.0 system (a
              Comtrend CT-536+ ADSL router). When I try to do so I get a "Network
              error: Connection reset by peer". Connection via Cygwin's ssh is
              successful.

              Comparing PuTTY and ssh, the key difference comes after the "Client
              Protocol" message. ssh first sends a "Client: Key Exchange Init" and
              receives back a "Server: Key Exchange Init", after which the key
              exchange proceeds naturally. However PuTTY first _receives_ a "Server:
              Key Exchange Init" and then sends a "Client: Key Exchange Init".
              PuTTY's answer is not a subset of the CT-536+'s announced
              capabilities, which might be wrong according to the standards (since
              it theoretically could give way to an endless loop). If not, it might
              be that the the CT-536+ is overly stringent, to the point that it
              might even expect the key exchange after its announcement, closing the
              connection upong any further "Client: Key Exchange Init" messages.

              Client: PuTTY 0.58 running on Windows XP SP2 Spanish. The same
              behaviour (without network dumps to prove it) have been observed with
              the latest development version.
              Server: A Busybox 1.0 system running on a Comtrend CT-536+ ADSL router.

              Attatched are the Ethereal dumps of two session establishements, one
              using PuTTY 0.58 [PuTTY.libpcap] and one using Cygwin's ssh
              (ssh-Cygwin.libpcap).

              • Cerrado

                Respondiéndome a mí mismo, tras leer el borrador sobre SSH y…

                Respondiéndome a mí mismo, tras leer el borrador sobre SSH y recibir respuesta a mi mensaje, las razones que daba sólo se pueden justificar si el Comtrend hace caso omiso al estándar.

          • Cerrado

            6
            a mi me funciona con openssh.. no he probado con ese.. por…

            a mi me funciona con openssh.. no he probado con ese..

            por telnet de windows es facil, en la barra de tareas le das a propiedades, y en screen buffer (no se como es en español) le pones muchas lineas de altura y ya está.. y si, en principio es el snr de cada tono.

            pero si sincronizando a 2.5mbps sigues teniendo cortes es que hay algo mu mal ahi..

            • Cerrado

              Por curiosidad, voy a poner un resumen del resultado del…

              Por curiosidad, voy a poner un resumen del resultado del `adsl info -SNR' tras un par ejecuciones separadas poco más de 30 minutos:

              0-32: 0: ¿Los de subida, que no mida el ruido ahí o qué?
              33-126: >= 20 dB, salvo tres o cuatro que rondan los 15 dB. Supongo que no está mal.
              127-133: Rápida disminución de 20 a 10 dB. Problemas...
              134-155: 156-185: 10-20 dB.
              186-189: 190-211: 10-20 dB.
              212-234: 235-243: 10-20 dB.
              244-385: > 10 dB todos, la mayoría >20 dB.
              385: 9 dB... Una excepción tempora, en vista a la segunda medida.
              386-396: 10-20 dB.
              397-402: 0-10 dB.
              403-511:
              ¿Alguien puede contrastar si los "socavones" presentes son algo habitual? (Por habitual me refiero tanto a la curva de atenuación teórica en este rango de frecuencias como a lo vivido por otros.)

              De paso, estaría bien saber si alguien ha tenido buenas experiencias seleccionando tonos con el CT-536+. Lo digo porque no acabo ver que el comando shell `adsl connection --tones ' me pueda ayudar (¿cómo selecciono varias franjas en bajada?), y porque la interfaz web no me ha dado buenos resultados (eliminar más de dos o tres tonos de subida me impide permanacer sincronizado más de pocos minutos, además de que le faltan los 256 tonos superiores de ADSL 2+).

              • Cerrado

                6
                yo creo que es normal.. interferencias por cualquier cosa. Yo…

                yo creo que es normal.. interferencias por cualquier cosa. Yo tambien tengo alguno

                 129 40.3750
                130 39.6875
                131 38.8125
                132 37.3125
                133 35.0000
                134 31.0625
                135 23.6250
                136 18.6875
                137 30.1875
                138 35.2500
                139 38.2500
                140 40.1875
                141 41.6250
                142 42.6250

                no tengo adsl2+ asi que solo llego hasta 255. Lo de desactivar tonos no creo que sea demasiada buena idea, a no ser que el ruido que tengas sea muy especifico.. pero aun asi tampoco deberia ser tanto problema ya que los bits por tono se intercambian sin resincronizar en teoria.. lo que no puede cambiar es la velocidad total pero se pueden intercambiar..

                • Cerrado

                  :-D Ya me gustaría que en mi caso el problema fuese que uno o…

                  :-D Ya me gustaría que en mi caso el problema fuese que uno o dos tonos bajasen se pusiesen entre 15 y 20 dB, aunque está claro que lo fundamenta son las bajadas de SNR de una serie de tonos relativos a los colindantes.

                  Viendo tu comentario respecto a que basta mantener la velocidad global me pregunto, ¿tus conocimientos sobre el funcionamiento del ASDL, vienen de uan fuente concreta a la que nos podamos referir quienes tengamos estómago para ellas, o a venido a base de leer un poquillo por aquí y otro por allá? Estaba pensando en echarle mano a los estándares (¿ITU?), pero estoy seguro que hay otras fuentes suficientemente precisas y sobre todo mucho más someras. :-)

                  • Cerrado

                    [Editado 25/10/05 19:58]

                    6
                    pues muchos pdfs he leido pero los tengo tan esparcidos que…

                    pues muchos pdfs he leido pero los tengo tan esparcidos que no se donde están... pero vamos, creo recordar que a lo que yo me refiero es el "Bitswap" que por cierto se puede activar y desactivar en el comtrend

                    edito: este por ejemplo? www.stanford.edu/group/cioffi/pdf/short.pdf

            • Cerrado

              Lo que está muy mal soy yo... Yo también uso OpenSSH bajo…

              Lo que está muy mal soy yo... Yo también uso OpenSSH bajo Windows, y me imaginaba que había que cambiar un buffer. El problema es que con las prisas el que modifiqué fue el del historial y no el de pantalla (que por cierto, en Windows XP, está en la pestaña "Diseño", algo no del todo intuitivo).

              Respecto a los cortes, no he tenido ninguno nuevo desde el citado, asi que se nota para bien el ajuste. Aparte de seguir buscando una mejor solución, creo que voy a pedir que cancelen el "downgrade" y apoyarme en el `adsl configure -snr 150'. ¿Hay alguna manera de realizar una configuración externa automática el reiniciar el Comtrend para aplicar este y otros comandos tras un reseteo?

              Una posible solución sería el compilar el firmware uno mismo con los parámetros que más le convengan. ¿Cómo van las iniciativas al respecto? Si me hago con otro router, añadiré gustosamente al CT-536+ como cobaya. ;-)

    • Cerrado

      A mi me paso lo mismo en cuanto pase de ya.com de 512 a…

      A mi me paso lo mismo en cuanto pase de ya.com de 512 a jazztel 4 megas por entonces el router cualquiera de los dos tanto el 3Com como el Comtrend me dejaba de sincronizar cada 10 o 15 min y en el mejor de los casos,
      y no m sincronizaba mas de 2 megas, así que leyendo en este foro probé a conectarlo directamente al PTR haber si mejoraba y tanto que mejoro ya me sincronizaba 6144/512 q fue cuando duplicaron asi que el problema era de la línea de mi casa que estaba mal de cojones así tire cable nuevo desde el PTR hasta mi cuarto sin q saliera de esa línea ninguna otra para ningún teléfono y guay ya desde que lo cambia ningún solo corte y siempre a 6144/512

      • Cerrado

        Gracias por puntualizar que uno de los pasos fundamentales…

        Gracias por puntualizar que uno de los pasos fundamentales para analizar problemas con la conexión es comprobar.

        Más arriba comenté mi procedimiento, en el que describí una variante de tu consejo. En casa tengo un splitter heredado de Infonegocio. El problema está en que el servicio técnico quiere comprobar que no haya ningún problema técnico con el mismo, sobre todo en la labor de filtrado que hace sobre la conexión dedicada para los teléfonos. Para evitar que Telefónica me cobrase por la verificación (el splitter es suyo y no hay problemas con el teléfono), desconecté los cables de entrada al splitter y los conecté directamente al módem (usando un frontal cualquiera de teléfono para no tener que trastear con el RJ-11). Como la cosa seguía igual, pude descartar cualquier causa de la instalación de la casa (que siendo nueva, más le valía funcionar bien ;-)).

    • Cerrado

      [Editado 24/10/05 21:30]

      ¿Tienes algún hilo en este u otro foro donde indiques todo lo…

      ¿Tienes algún hilo en este u otro foro donde indiques todo lo que has hecho para asegurarte de que no lo puedes solucionar por tu cuenta?

      Por ejemplo, ¿has probado con otro router, aunque sea prestado? ¿has probado a desconectar todos los teléfonos de tu casa? y un larguísimo etc...

      Que te limiten la subida no le veo absolutamente ninguna utilidad práctica...

      Si yo trabajara en Jazztel... o en cualquier otro ISP, ya hubiera hecho (publicable en web) una plantilla / flujo que pudieran seguir los clientes para depurar / optimizar la conexión ADSL. O varias plantillas (distintos niveles técnicos, desde el más simple, al más completo).

      Cuando el ADSL es de 512M ó 1 Mbps no tiene mucha importancia, pero con más de 1Mbps y ni te cuento 20Mbps, la cosa es bastante seria. Quiero decir que DENTRO de casa, con 20Mbps ó 6Mbps... tener todas las rosetas con el COBRE BRILLANDO y bien atornillados, el PCR ultra-revisado, control de ruido, etc, etc. cobra verdadera importancia.

      Pero el caso es que no trabajo en Jazztel...

      • Cerrado

        Si tu trabajaras en jazztel (o cualquier otro ISP) actuarias…

        Si tu trabajaras en jazztel (o cualquier otro ISP) actuarias de 2 formas posibles (al igual que la mayoria de nosotros):

        Si fueras jefe, te preocupariasde q la gente currara como capullos y atendieran cuantas mas llamadas mejor, las estadisticas son lo importante.

        Si fueras un currito, estarias mal pagado, hasta los webos de tu jefe, hasta el gorro de aguantar a los clientes, y buscando como un loco en la seccion de trabajo de los dominicales algo mejor.

        Esa es la triste realidad, los clientes solo somos para los ISP una fuente de ingresos. Si no somos rentables y deben invertir mas de la cuenta en retenernos, nos abandonan. Y todos los ISP son iguales en este aspecto, a nivel de clientes "mataillos".

        Salu2.

      • Cerrado

        El proceso lo especifiqué unas líneas más arriba en este…

        El proceso lo especifiqué unas líneas más arriba en este mismo hilo :-P. Conectando el router directamente al par de Telefónica (desconectándolo del PTR/PCR/splitter), creo haberme asegurado que sólo puede ser del router. Por eso pregunté en otro hilo acerca dela petición de un equipo de pruebas a Jazztel.

        Muy acertada la idea de publicar un proceso de pruebas, para evitar problemas fácilmente solucionables como el del RWIN y para que no te saquen cada vez una nueva idea para no atenderte en profundidad (que no es ese el motivo, pero sí el resultado).

    • Cerrado

      6

      Buenas pues yo tengo los 6 megas desde hace 3 meses aprox y…

      Buenas pues yo tengo los 6 megas desde hace 3 meses aprox y tambien los mismos problemas con los cortes, me habia planteado llamar para k me fijasen la bajada a 5000 kbps k es cuando todo va bien pero segun dices me pondran una subida menor de 512 asi k mejor sigo komo estoy.
      Tus problemas son por el ruido de la linea? o k te dijeron en el servicio tecnico

      • Cerrado

        Mis problemas son un tanto indefinidos y difíciles de tratar,…

        Mis problemas son un tanto indefinidos y difíciles de tratar, visto su carácter irregular (durante una sesión de atención remota fueron capaces de ver (indirectamente) que se había cortado la conexión, pero no me pudieron dar datos al respecto. Como es normal cuando se tiene que dar servicio a tantos clientes, les gusta asegurarse de que el problema no sea culpa del cliente, porque si lo es se ahorran mucho tiempo. Desafortunadamente, lo llevan al extremo, casi culpando al cliente del problema.

        Por ello, cada vez que se llama hay que "blindarse", mostrando que se han descartado (dentro del lo razonable) todas las posibles causas de fallo dentro del domicilio. Por eso, lo mejor desde un principio es armarse con cables de repuesto y hacer pruebas directamente sobre el par de entrada, para que no se pueda achacar el problema a ninguna parte de la instalación.

        Volviendo a la pregunta, creo (y algunos del servicio técnico también creen) que el problema tiene que ver con el ruido y la atenuación (sobre todo el ruido, que tiene a ser el factor más variable. Sin embargo, el solucionarlo bajando la velocidad es matar moscas a cañonazos. Lo razonable es que funcionase un sistema de ajuste dinámico de la sincronización. No sé si el problema es que es algo que no quieren activar o que no pueden (pero la tecnología existe, y el Comtrend 536+ la debería soportar, si no estoy equivocado acerca del SRA).