BandaAncha.eu

Comunidad de usuarios
de fibra, móvil y ADSL

Fibra

¿Se ha mantenido la configuración y el acceso admin en el ZTE H298A de Digi con firmware T16?

PezEnLaBoca

Tengo acceso admin y también tengo bloqueadas las actualizaciones de firmware.

Alguien que también tenía acceso admin ¿ha dejado que se actualizase y ha mantenido el acceso admin?

En teoría debería mantener la configuración pero nunca se sabe.

No sé que cambios trae o si corrige algún fallo de seguridad, pero me temo que la actualización sea solo para tapar el agujero que permite el acceso admin.

BocaDePez
BocaDePez

Este router ya está descontinuado.

🗨️ 4
kaleth

Tienen stock para aburrir, no te creas que cuando anunciaron los nuevos tiraron los demás a la basura.

🗨️ 3
onekame

ese modelo ya no se instala.

🗨️ 2
kaleth

Debe ser desde hace bien poquito, el mes pasado me pusieron uno a mí que tenía fecha de adquisición de julio del año pasado.

Meow

A mí me lo instalaron hace tres semanas en una nueva alta bajo fibra directa.

JoselitoPapito06

Con la T16 en este router ya no es posible sacar admin.

Yo lo saqué con la T12, y ahora tengo la T16 y sigo con el admin tranquilamente.

🗨️ 6
PezEnLaBoca

Gracias, así que en teoría puedo dejar que se actualice, no?

🗨️ 1
Ultrashricco

Puedes dejar que se actualice, no te va a cambiar la contraseña admin que personalizaste. :)

Ultrashricco

Con la T16 en este router ya no es posible sacar admin.

Podrías explicar qué fue lo que probaste y que fallo, por favor?

🗨️ 3
JoselitoPapito06

El servidor PPPoE simulado se conecta, solo que al ejecutar el script no da respuesta, hemos deducido que es que han hecho validación del certificado del tr-069

🗨️ 2
Ultrashricco

Interesante, gracias por la informacion,

Saludos,

Meow

Justo ahora que lo quería intentar… Qué mal…

Ultrashricco
1

Accediento por puerto serie se deberia de poder seguir arrancando el modem en boot mode para inyectarle un firmware mas antiguo y volver a conseguir cambiar la contraseña admin y bloquear el servidor TR-069, etc.

2021-05-14-01h31-44.webp2020-07-18-150116-1920x1080-scrot.webp
🗨️ 28
PezEnLaBoca
2

En routers viejos de ZTE no hacía falta conectarse por puerto serie: se podían encender manteniendo pulsado el reset para que saliese la pagina de carga del firmware, no sé si en el H298A funciona.

Por cierto, si no recuerdo mal en firmwares muy viejos no hacía falta hacer tantos malabarismos, si fuese posible cargar un firmware antiguo y que al actualizar mantuviese la configuración tendríamos un sistema sencillo de obtener acceso admin y las credenciales VoIP.

Por si alguien quiere experimentar tengo los firmwares T2, T3, T4, T6, T8, T10, T11, T12, T13, T14, T15 y T16.

🗨️ 6
Ultrashricco

Llevo mucho tiempo buscando un firmware anterior al T10, que ya está capado (no se puede bajar/subir el config.bin que contiene la contraseña Admin). Sería una manera muy sencilla de conseguir la contraseña admin y los datos VoIP.

Si pudieras subir esos archivos a la nube, ¡sería muy útil para la comunidad!

🗨️ 4
PezEnLaBoca

mira tu chat

🗨️ 3
Meow
🗨️ 1
AcoranTf

Veo en la captura que parece que te entro el router en modo boot, sin necesidad de logearte. Pero a mi cuando lo intento, me pide login y paasword.

He probado todos los que conozco y ninguno funciona.

¿Me podrias decir si realmente te dejo entrar sin logearte, que version de firmware tenias y como se le mete el firmware nuevo?

Otra cosa, ¿sabes si hay forma de sacar el firmware que tenga el router antes de meterle el nuevo, por si acaso hiciese falta?

Gracias anticipadas.

Saludos.

🗨️ 15
Ultrashricco

Para entrar en modo Boot, hay que pulsar la tecla "1" durante el inicio, a mí me entra en modo boot sin login ni contraseña. Los pide para entrar en "testing mode", pulsando la tecla 2, ¿a ver si no te estás confundiendo?

Mismo comportamiento sea cual sea la versión de firmware, ya que estamos hablando del bootloader, que se ejecuta al iniciarse el router, y procede a cargar el firmware. Las actualizaciones de FW de la T2 a la T16, por lo que he visto no reescriben el bootloader.

Cuando estés en modo Boot, accede a 192.168.1.254 desde un browser cualquiera, te saldrá la página TC Rescue Page donde seleccionar el FW a enviar al router. Recomendaría hacerlo desde una distribución GNU/Linux y con Firefox o IceWeasel, no me funciona desde Chromium.

Tal vez tu router sea más reciente y venga con un bootloader con el acceso al puerto serie protegido (login y contraseña para acceder al Boot mode).

No es necesario sacar el FW del router para volver a ponerlo después, a no ser que trastees con FW alternativos como OpenWrt, pero no creo que haya soporte para este router poco documentado.

🗨️ 5
AcoranTf

Gracias por la respuesta.

Debe ser lo ultimo que comentas, ya que lo he intentado varias veces y tanto en boot, como en testing, en ambos me pide login y contraseña.

He buscado por todas partes y no encuentro nada al respecto.

Otra cosa al margen del puerto serie:

¿Sabes que significan los "Level" que hay en los archivos config.bin y db_user_cfg.xml, en algunos apartados, como los usuarios de telnet, ssh, samba, etc.?

Yo he deducido que el Level = 0 es el que da mas poder, pero no estoy seguro.

Saludos.

🗨️ 4
AcoranTf
🗨️ 2
Ultrashricco

Hola @AcoranTf mira a ver en el menú de administración, que te indica qué versión de Bootloader tienes.

Yo tengo la 1.0.2 y me deja entrar al modo Boot por puerto serie sin login/contraseña.

Saludos,

2021-05-26-09h44-38.webp
🗨️ 8
AcoranTf

Hola de nuevo. Pues coincide todo salvo que yo tengo la T12 y tu la T16. El resto esta todo igual, pero me pide login y contraseña, tanto para boot, como para testing.

Es raro, pero es lo que hay. Como no sea que en la T16 lo hayan vuelto a dejar sin login, no se.

Saludos.

🗨️ 7
AcoranTf
🗨️ 5
Meow
-1
🗨️ 3
Ultrashricco
🗨️ 2
Meow
🗨️ 1
AcoranTf

Os dejo un script que hice para automatizar el cambio de contraseña de admin. Aunque en el firmware T16, ya no funciona.

Este script utiliza trozos, ideas y aportes de distintas personas y mi pequeño aporte en forma de automatizarlo.

Bueno pues no me deja subirlo, o yo no se hacerlo. ¿Se pueden subir archivos?

🗨️ 3
superllo

No, deberías usar otro servidor tipo Google Drive o, si es un script, pastebin.

🗨️ 2
AcoranTf

OK, bueno como no utilizo Google y para pastebin lo veo muy largo, adjunto aqui el enlace al grupo de Telegram donde lo puse.

t.me/RouterDigi/19820

🗨️ 1
Samu22

He intentado el procedimiento de downgrade de firmware, pero al entrar en modo boot (1), aparece el texto "### Please input boot password:###". ¿Alguien ha conseguido acceder como admin al router con la version T16?

BocaDePez
BocaDePez

A mi me han jodido el UPnP con la actualización de firmware a la t16…