Banda Ancha EU

Comunidad de usuarios
de fibra, móvil y ADSL

hosting en interdominios
28 lecturas y 9 respuestas
  • Cerrado

    BocaDePez BocaDePez
    6

    Como funcionan los filtros? Quiero servidor WEB

    Hola, he leído mucho este foro, pero no consigo demasiadas cosas con las "fórmulas mágicas" de config del router. Si alguien sabe bien cómo funcionan los filtros y el NAT, en qué orden, según si entran o salen los paquetes,.... me gustaría que me diera algunas pistas por lo menos. :-?
    Hay que reiniciar el router para que tengan efecto los cambios en los filtros?... no sé me gustaría aclararlo con alguien (yo ya lo controlo un poco), y si taal se hace un tutorial y nos dejamos de tanto post, que aquí estmos todos para encontrar soluciones! :-P
    Lo que más me urge es que quiero hacer que el servidor apache sea accesible desde el exterior. En SUA abro el puerto 80 a mi pc, pero es como el nabo...

    Alguien que abra puertos y que sepa lo que hace?

    Gracias

    Este tema es antiguo y puede contener información obsoleta. Abre un nuevo tema para publicar tu mensaje.
    1
    • Cerrado

      BocaDePez BocaDePez
      6

      Es que no lo estaba probando desde el otro lado del router!…

      Es que no lo estaba probando desde el otro lado del router! No tengo mucha experiencia con esto, pero estoy en ello :-P
      O sea, chicos, si queréis abrir un puerto de ftp(21), de web(80) o telnet(23) para pner un servidor, tenéis que hacer lo siguiente:

      1- Ir a los filtros (menú 21 entrando por telnet), y seleccinar al filtro webset (12), seleccionar la regla con DP=21,23 u 80 (al gusto) y ponerle Action Matched=Foward (con barra espaciadora).

      2- Ir a la config SUA/NAT (menú 15) y añadir una ínea que indique el puerto (21,23 u 80) y la ip del ordenador del servidor (p ej:192.168.30.3).

      3- Ir a la configuración de los accesos al router (menú 24.11) y en el acceso que ponga sever port=21,23 u 80 (al gusto) se le cambia por uno cualquiera (666 p ej).

      Si alguien quiere coger esto para publicarlo, me parecería muy bien, o si he puesto algo mal, o si se puede ampliar,...

      Gracias smuis, ers un krack! ;-)

      • Cerrado

        BocaDePez BocaDePez
        6

        He leido todos tus posts pero sigo tiniendo algunos…

        He leido todos tus posts pero sigo tiniendo algunos problemillas, me podrias pasar el apartado de filters??? me seria de gran ayuda gracias

        • Cerrado

          BocaDePez BocaDePez
          6

          Creo que hablais del zyxel 643, yo tengo un 941 y pensaba que…

          Creo que hablais del zyxel 643, yo tengo un 941 y pensaba que los menus eran los mismos pero despues de leer estos post pienso que no. O que las explicaciones no son completas, que tambien podria ser (si fuera esto y quereis hacer un manual, mas vale que expliqueis las cosas un poquito mas ya que no hay manual en castellano).
          Lo unico que he hecho hasta ahora es abrir un puerto para un servidor de counter y los puertos del NetMeeting. Y os oigo hablar de los filtros y alucino (debo ser muy pakete), me interesa poner un servidor en PHP y claro, me interesa lo que hablais porque tendre los mismos problemas, pero es que ¡NO ENTIENDO NADA!
          Por otro lado, esos puertos que he abierto solo me sirven en la ip que le ponga en el SUA, no se pueden configurar los puertos para que sirvan en todos los puestos de una red. Yo tengo conectado el servidor y los clientes a un switch y de ahi al router. ¿Se puede o no?
          A ver si hacemos algo, porque los de zyxel ni traducen.
          Y gracias.
          Raul.

    • Cerrado

      BocaDePez BocaDePez
      6

      De todos modos ya había hecho lo que me dices, pero nada, no…

      De todos modos ya había hecho lo que me dices, pero nada, no accedo al apache ni de coña, sólo localmente. En la config SUA pongo: puerto 80 a mi ip local; y en lo de los filtros solo hay uno que se refiere al 80 (pr= 6 SA=0.0.0.0 DA=0.0.0.0 DP=80 N D N) : en webset, y está desactivado hace tiempo.... ni idea, vamos.
      Sabéis qué significa pr=0 (será cualquier protocolo?).

      • Cerrado

        [Editado 15/10/02 04:09]

        la D esa que hay al final, entre las dos letras N, es la de…

        la D esa que hay al final, entre las dos letras N, es la de DROP (tirar paquete a la basura). tienes que sustituirla por F de FORWARD (dejar pasar)

        tienes que cambiar

        pr= 6 SA=0.0.0.0 DA=0.0.0.0 DP=80 N D N

        por

        pr= 6 SA=0.0.0.0 DA=0.0.0.0 DP=80 N F N

        es decir:

        que deje pasar paquetes de cualquier ip - cualquier puerto hacia cualquier ip - puerto 80.

        conio, que lio.

        Prueba a cambiarlo y luego activar el filtro (yo lo tengo asi y va de lujo)

        Y no te olvides de poner LAN ONLY en las tres partes de configuración de acceso al router (que no me acuerdo que opción es)

        :-P

        • Cerrado

          BocaDePez BocaDePez
          6

          el caso es q he borrado los filtros 1,2,12. O sea que ya no…

          el caso es q he borrado los filtros 1,2,12. O sea que ya no tengo; en un tutorial salia para poder abrir los puertos, pero sigue sin funcionar el ftp.

        • Cerrado

          BocaDePez BocaDePez
          6

          Entiendo lo que me dices, cada vez entiendo más de o de los…

          Entiendo lo que me dices, cada vez entiendo más de o de los filtros, que si protocolo 6=IP, source address, destination port, match case, drop, foward, next rule,... un paquete tiene que pasar todos los filtros hasta un foward para poder pasar. Bien
          Lo de nat es solo redireccionar a un pc un puerto (en este caso). Bien
          Lo de poner los accesos al router en lan only... pues leí en el manual que hay que cambiar el puerto por el que va el acceso que bloquea el puerto que quieres utilizar, en este caso el de web, pero lo cambio y nada....
          Ya no me quedan más recursos :-(

          Buen foro, este; gente enrollada, si :-P

    • Cerrado

      Si tienes bien configurado el NAT es que tienes algún filtro…

      Si tienes bien configurado el NAT es que tienes algún filtro tocando los mondongos :-| .

      Mira los filtros que toquen el puerto 80, (si tienes telefonica seran el 1 (filtro) y el 12 (webset).

      no te los pulas (por si acaso!) sino simplemente, métete en cada uno de ellos y deshabilita los que toquen el 80 (creo que es poniendo ACTIVE a no).

      puede que sea eso.

      en cuanto a lo de reiniciar el router.... para nat no hace p**a falta pero para filtros... nose.

      salIdos. 8-)

      • Cerrado

        Hola a todos. A mi me pasa un poco como a todos, problemas…

        Hola a todos.

        A mi me pasa un poco como a todos, problemas con los puertos pero leyendome el manual de ZyXEL y con algunos conocimientos que tenia ya consegui que andase el route medio bien. Y para los filtros comprobé perfectamente que no hace falta reiniciar te los actualiza en unos segundos despues de cambiarlos.

        Un saludo.