Banda Ancha EU

Comunidad de usuarios
de fibra, móvil y ADSL

Fibra

No consigo que entren o salgan llamadas con FreePBX en O2

Spanska

¿Alguien sabe si últimamente han cambiado algo en O2?

Llevo varios días intentando configurar FreePBX con mi nueva línea de O2 y después de seguir varios tutos en los que prácticamente se siguen los mismos pasos no hay manera de que eche a andar (ni entrantes ni salientes), sólo se comunican entre sí las extensiones.

El router que me han puesto es un MitraStar GPT-2541GNAC.

Gracias de antemano.

bunibuni

Creo que sigue siendo exactamente igual a Movistar.

🗨️ 1
Spanska

Pues no sé que narices estaré haciendo mal pero no hay manera… y tampoco veo que sea un procedimiento tan difícil.

manolito1998

Creo recordar que solo se podía tener una sesión abierta.

En la configuración del router, en el apartado VoIP, pon una contraseña inventada, así el router no se conectará al servidor y prueba a ver si se registra FreePBX

Un saludo.

🗨️ 2
Spanska

Nada. La contraseña en la configuración original ya estaba en blanco. Tengo sin habilitar "Enable SIP Account" y de hecho en el router no está encendido el piloto del teléfono, pero ni con esas.

Muchas gracias por el consejo.

BocaDePez
BocaDePez

Diría que puedes poner cualquier cosa en la contraseña que se loga igual. Por otra parte, al menos dos sesiones SIP segurísimo que se pueden tener al mismo tiempo.

BocaDePez
BocaDePez

¿Has probado con los parámetros de O2 a registrarte en un softphone a ver si te registra?

Si va todo ok, traslada esa configuración a FreePBX.

Sino comprueba tb algún tema de puertos o reglas de firewall en el servidor pbx.

🗨️ 1
Spanska

He probado con Zoiper desde el móvil y tampoco se registra…

Auténticamente desesperante…

calanor

Algo pasa. Llevo varios días batallando con un softphone y no hay manera de que funcione al 100%. Consigo que se registre pero mirando los logs lo hace después de bastantes reintentos. Cuando hago una llamada al móvil me sale un "Not Acceptable Here" y en el móvil me aparece como llamada perdida. Yo pensaba que era problema a la hora de decidir un codec pero en los logs se ve como acuerdan el PCMA que todo el mundo soporta, y se ve que el servidor devuelve un 500 (Internal server error) que puede ser cualquier cosa. En cambio si llamo a otro softphone detrás de una centralita la llamada se establece perfectamente. He hecho decenas de combinaciones pero no hay manera, sigue teniendo problemas a la hora de registrase y las llamadas no funcionan.

El mismo softphone lo llevo usando meses en MásMóvil funcionando a la perfección.

🗨️ 3
BocaDePez
BocaDePez

A ver si O2 va a tener algún tipo de capado en el fijo con respecto a Movistar.

NeroGC

Yo tengo Movistar y lo mismo.

No consigo que funcione la configuración en un terminal VoIP.

y en Softphone tan solo me funciona sobre el de Movistar,… :(

BocaDePez
BocaDePez

No es tema entonces de FreePBX.

Yo en su día probé con varios softphones y no recuerdo con cuál pero desde el móvil lo conseguí con los parámetros que te han puesto, sin entrar en detalles.

daveric

Prueba esto en la troncal SIP, solo meter tu teléfono correcto donde puse asteriscos.

SALIENTES (esto es el título que le puse, no forma parte del contenido de la configuración)

type=peer
fromuser=9********
secret=9********
fromdomain=telefonica.net
host=telefonica.net
outboundproxy=10.31.255.134:5070
port=5070
NAT=yes
insecure=port,invite
dtmfmode=auto
disallow=all
allow=alaw,ulaw

ENTRANTES (título que le puse a la pestaña de llamadas entrantes)

type=peer
username=9********
secret=9********
fromdomain=telefonica.net
host=10.31.255.134
port=5060
outboundproxy=10.31.255.134
qualify=no
NAT=yes
insecure=port,invite
dtmfmode=auto
canreinvite=no
disallow=all
allow=alaw,ulaw
NAT=yes
outboundproxyport=5070

REGISTER STRING (apartado)

9********@telefonica.net:9*********@10.31.255.134:5070

Ahora te vas al directorio /etc/hosts y agregas esta linea. (editando con nano /etc/hosts):

10.31.255.134 telefonica.net

Reinicias todo y a ver quer tal te va

Spanska

Gracias por vuestros consejos. Los he probado todos pero nada de nada, no hay manera.

Anoche me dediqué a sustituir el MitraStar por una ONT y un router neutro que tengo como punto de acceso en otra parte de la casa (Asus RT-AC68U).

Con la conexión a internet ningún problema (a la primera) pero nada de teléfono; ni con el asistente de configuración (diciéndole que ponga los requisitos de Movistar) ni de forma manual.

Estoy alucinando porque no es que con algunas configuraciones me de algún fallo (como cuenta por ejemplo calanor), es como si no tuviese contratado el servicio de telefonía).

Cambiando parámetros solo consigo que me devuelva diferentes errores (502, 503).

También he probado diferentes softphones en Windows, Mac, iPhone y Android con los mismos resultados…

Desesperante…

🗨️ 3
BocaDePez
BocaDePez

¿Desde FreePBX haces ping a 10.31.255.134:5070 o te resuelve telefonica.net?

Echa un vistazo a las respuestas de aquí:

comunidad.movistar.es/t5/Soporte-Fibra-y…td-p/3453771

Otra cosa que puedes revisar es el puerto PBX que tiene que ser el 5060 y el 5070 es el del proxy.

daveric

Jope macho, pues cuando tengas la solucion, que espero que eso sea asi, comenta por aqui lo que sea.

Tu post crea incertidumbre porque siempre pense cambiar a 02 por el echo de poder usar mi freepbx con ellos, yo tambien lo uso pero en este caso con Netelip y lo tuve con Vodafone sin problema durante algunos años.

La configuracion que te pase fue porque cambie de operador y tenia previsto aplicarla porque alguie que la estaba usando con normalidad con ellos me la paso, pero realmente no la he usado.

Estare pendiente a ver el desenlace de esto.

BocaDePez
BocaDePez

Gracias por editar el mensaje.

Otra idea que he tenido es poner una IP estática al servidor FreePBX, sino la tiene ya.

Ya nos vas comentando los avances.

En este enlace tienes la tipología de errores SIP:

voipforo.com/SIP/SIP_mensajes_error.php

Spanska

Alucinando… Os cuento:

Anoche (tarde porque tengo que esperar a que nadie necesite conexión en casa y poder trastear a gusto) me disponía a probar con una ONT Huawei HG8240H que tengo de una antigua instalación de Jazztel y como router el Asus RT-AC68U que os comenté que tambien tenía por ahí…

Mi intención no era sacar la línea telefónica de la ONT (en Jazztel salía por el router) pero al disponerme a configurarlo me encontré con este post de BocaDePez:

Configurar ONT Huawei HG8240H en Movistar FTTH

Y sorpresa!!! El téléfono levantó a la primera!!! Se deduce que los parámetros de configuración SIP son los correctos pero por alguna razón, al configurarlos en un softphone detrás del MitraStar no funcionan…

No configuré el RT-AC68U porque ya era tarde y tenía más sueño que curiosidad. Eso sí, intenté habilitar las dos salidas de teléfono pero sin suerte. En Jazztel lo había conseguido y tenía dos líneas con el mismo número.

Lo de FreePBX lo tengo de momento aparcado ya que si no consigo conectar con un simple softphone… imagínate con una centralita. Si consigo la parte "fácil" entonces pasaré a romperme la cabeza con FreePBX

Por cierto, os comento que al hacer pruebas con softphones desde Windows he deshabilitado el Firewall para asegurarme de que no estuviese fastidiando de fondo…

¿Qué opináis del resultado obtenido con esa ONT?

Por cierto BocaDePez, he hecho ping, traceroute, lookup a 10.31.255.134 y a telefonica.net y nada, ninguna respuesta, hasta con el firewall de router deshabilitado. Lo de ping no me sorprende porque (según tengo entendido) es una prueba para TCP y los puertos de estas direcciones son UDP… Lo mismo estoy en un descomunal error.

🗨️ 2
BocaDePez
BocaDePez

Hacer ping a 10.31.255.134 te tiene que funcionar.

¿Has registrado el softphone internamente/local, es decir, con la configuración SIP y con la conexión Wifi?

raxor
1

Mírate esto que explico aquí. Necesitas enrutar el trafico VoIP para que lo gestione el MitraStar por la VLAN correcta (lo hace solo). Yo conecto desde O2 cualquier Softphone y Centralita IP sin problemas, simplemente le digo que ese trafico el Asus se lo mande al MitraStar. Desde hace mucho tiempo que funciona sin problemas. Y luego al usar VPN TAP también me va cuando estoy fuera de casa. Otra cosa es que no lo uso para casi nada, salvo para gastar bromas. jeje

VoIP funcionando en Movistar/O2 con router neutro Asus sin tocar VLAN

Como veo que te ponen otra dirección proxy 10.31.255.134 ajusta el script para incluir las dos direcciones, duplica la linea.

Lo usé en un AC68U, AC86U y ahora en un AX88U.

Saludos

Spanska

Gracias también a daveric por su configuración y por haberla editado y ponerla "chula"