BandaAncha.eu

Comunidad de usuarios
de fibra, móvil y ADSL

¿Estan mal diseñadas las redes virtuales en este escenario de VmWare?

antey

Buenas,

Ando tratando de recrear un escenario mediante VmWare, pero no se si las redes virtuales que he creado, estan bien creadas, sospecho que puede haber algun fallo... por que lo cierto es que no me funciona el escenario. Si algun forero, - que aqui hay gente que controla mucho - viese alguna anomalia, agradeceria que me lo dijera.

Vamos al grano.

Como os he dicho estoy tratando de crear en VmWare lo siguiente, ( voy a ir a lo esencial):

Router <-----(Ip1)----> Srv1 (linux)<----(Ip2)---- Firewall ----(Ip3)-----> Srv2 (linux)<------(Ip4)------------(Ip5)---->Cliente1 (WinXP)

__________________________________________________________________________________ |---------(Ip6)---->Cliente2 (WinXP)

Hay como os he dicho:

Un router ( dara conectividad fisica)

1 maq. virtual Srv1 (OpenSuse) . Con dos interfaces. Una de ellas, vamos a llamarla Ip1, apunta al Router y es la que da conexion a Internet a toda la infraestructura. Esta parte seria la parte exterior de la la infraestructura. A partir de la unión mediante la tarjeta Ip2 del Srv1 con el Firewall, empieza la parte interna de la infraestructura. La dirección Ip1 es 192.168.1.121 y la Ip2: 172.17.0.100 .

*Nota: No se trata de entrar en el debate sobre la idoneidad de usar una direccion Ip de una clase u otra. Lo que falla, no va a por ahi.

La maquina virtual Srv2 (OpenSuse) tiene como direcciones Ip3: 172.17.2.19 y la Ip4: 10.19.0.100

La tarjeta de red del Cliente1 ( maquina virtual) tiene como dirección Ip5: 10.19.0.1 y el Cliente2 ( maquina virtual) Ip6 : 10.19.0.2

¿Como he creado yo la infraestructura en VmWare?

La parte del Router <-----(Ip1)----> Srv1 (linux) , la he puesto en modo bridge

La parte del Srv1 (linux)<----(Ip2)---- Firewall ----(Ip3)-----> Srv2 (linux) , la he puesto en modo Host-Only utilizando para ello la VmNet1 , donde le he dicho que como Subnet Ip empiece por la 172.17.0.0

Para la parte de Srv2 (linux)<------(Ip4)------ hacia los clientes, he creado otra subnet (porque la Ip4 (10.19.0.100) es una dirección de un rango distinto de las Ip2 y Ip3 (172.17. ) ) llamada VmNet2 en modo Host-Only y como Subnet Ip le he dicho que empiece por la 10.19.0.0

Evidentemente, ademas esto he echo mas configuraciones en los Servidores Linux, registrando las direcciones Ip en las interfaces de red, habilitando zonas internas y externas en el Firewall de los Servidores..., pero creo que el fallo puede venir por el diseño de las redes virtuales. Porque no consigo hacer ping desde una maquina cliente a la direccion 10.19.0.100 (Ip4) del Srv2 . Si el diseño estuviera bien entonces ya profundizaria en los detalles de los servidores.

Un saludo cordial y gracias de antemano.

BocaDePez
BocaDePez

Pregunta:

las redes por si misma se intercnoectan??

es decir el cliente xp ve al primer linux.

el primer linux ve al firewall.

el firewall ve a linux 2

y finalmente el linux 2 ve a router ( per por cierto no se para que lo pones en modo pasarela cuando el reuoter ya lo hace).

si no dices si los segmentos de red funcionan mal se te podra ayudar.

Primero comprueva que cada segmento funciona y ve subiendo.

para detectar el trafico usaria whiteshark para ver si hay trafico.

No intentes que la red funione a la primera primero certifica que cada segmento funciona.

Porque lo que falla es la forma de analizar fallos de red no vmware.

🗨️ 1
BocaDePez
BocaDePez

Sólo te ha faltado ponerle "haber 'estudiao' el modelo OSI" :D

JoeDalton

Entiendo que esto tratas de reproducirlo en un pc, con un vmware player, workstation o similar.

Por partes, las redes host-only sólamente son visibles entre el mismo equipo con las vms, en teoría, cualquier vm de ese host (pc físico) tiene conectividad.

Salvo que quieras dar visibilidad contra internet (digamos el rango de Ip1? que deberías de configurarlo vinculado al interface ethernet como bridge), el resto sería suficiente host-only ya que son todas internas.