BandaAncha.eu

Comunidad de usuarios
de fibra, móvil y ADSL

Error al instalar software, por favor ayuda!!!

BocaDePez
BocaDePez

Hola amigos tengo instalado ubuntu 6.10 y he intentado instalar un programa, mas concretamente Webmin, y durante la instalacion el asistente me da un error que dice: Error: Dependency is not
satisfiable: libauthen-pam-perl.

No se lo que significa ni como solucionarlo para poder instalar el programa y es que me hace falta urgentemente, por favor si alguien pudiera ayudarme...

Este tema está cerrado a nuevas respuestas. Abre un nuevo tema para retomar la conversación.
campi

instala webmin con aptitude o synaptics, ellos solos resuelven los problemas de dependencias

🗨️ 6
BocaDePez
BocaDePez

Hola he abierto synaptics e intento seleccionar el paquete que quiero instalar pero no me deja añadirlo, el nombre del paquete es webmin_1.300_all.deb y synaptic no me deja seleccionarlo para instalarlo

🗨️ 5
Gand1

El programa que quieres instalar necesita el paquete libauthen-pam-perl, por eso te da el error.

Para solucionarlo ábrete una consola y escribe:

sudo apt-get update

y cuando termine de actualizar:

sudo apt-get install libauthen-pam-perl

Con esto tendras el paquete que te falta. A continuación intenta volver a instalar el webmin.

Si tienes algun problema, comentalo e intento ayudarte.

Suerte!

campi

pero bajatelo directamente de synaptics no utilices el deb de la web de webmin

🗨️ 3
Gand1

A mi el apt no me lo encuentra. Quizá no tenga las fuentes apropiadas.

🗨️ 2
campi
🗨️ 1
Gand1
anthrax

Mirando las dependencias del paquete del webmin (que según la web sirve para Debian & Ubuntu) se necesitan cumplir las siguientes:

Depends: bash, perl, libnet-ssleay-perl, openssl, libauthen-pam-perl, libpam-runtime, libio-pty-perl, libmd5-perl

Si en tu caso solo falta el paquete libauthen-pam-perl, bastaría con que lo instalaras mediante el comando (en una consola):
sudo aptitude install libauthen-pam-perl

Saludos 8)
P.D1: Para obtener la información del paquete basta con ejecutar (desde consola y físicamente desde el mismo directorio donde está el paquete):
dpkg --info ./webmin_1.310_all.deb

P.D2: Para poder instalar el paquete libauthen-pam-perl necesitas tener activado el repositorio universe ( y de paso el multiverse )