Banda Ancha EU

Comunidad de usuarios
de fibra, móvil y ADSL

hosting en interdominios
158 lecturas y 1 respuestas
  • Cerrado

    Empujoncito con VPN

    Hola! A ver si alguien puede resolverme un problemita que tengo y que impide que mi VPN funcione del todo. Lo primero decir que no soy un entendido en redes ni mucho menos así que intentaré dar la mayor información posible sobre la configuración de los equipos. El problema es que, aunque los equipos conectan sin problemas, es decir el cliente hace login en el server y se valida correctamente, no son capaces de verse mutuamente. Además lógicamente el server asigna una IP privada válida dentro de la red al cliente. Aunque los equipos no se ven en Mis sitios de red, no tengo problemas en realizar pings a la IP asignada ya que responden correctamente. Sin embargo si realizo un ping al nombre del equipo remoto este no me responde, aunque si hago pings a los nombres de los equipos de la misma red local (no la virtual) sí que responden. Así pues creo que el problema es que no se resuelven los nombres de los clientes remotos correctamente y la verdad agradecería alguien me indicase cómo solucionarlo ya que estoy muy pez en el tema de WINS o DNS (y supongo que no seré el único interesado ;-) ). Bueno la configuración es la siguiente:

    1ª RED (a la que pertenece el server). Solo daré la configuración del Server ya que el resto de componentes de la red no afectan en absoluto.

    Sistema Operativo: Windows XP.
    Router: Efficient 5660.
    Puertos mapeados: 1723 (TCP) y 47 (GRE ya que si ponía UDP no permitía el login de los clientes). Ambos puertos estan mapeados a la ip privada del equipo que es: 172.26.0.2
    La puerta de enlace del Router es: 172.26.0.1
    Nombre del equipo: Server.
    Grupo de trabajo: Local.
    Se ha configurado una nueva conexión de red para que permita las conexiones entrantes (Servidor VPN). La configuración de esta conexión es la siguiente:

    Permitir a otros hacer conexiones privadas con mi equipo por túnel a través de internet u otra red.
    Los usuarios están dados de alta correctamente y se requiere que todos aseguren sus datos y contraseñas.
    En propiedades de TCP/IP se permite a quienes llaman tener acceso a mi red local y se asigna un rango de IPs para los clientes que conecten. Este rango no entra en conflicto con las de la red local, ya que son consecutivas a la última utilizada.
    También se ha añadido el protocolo de transferencia compatible con NWLink IPX/SPX/Netbios. Dentro de su configuración tenemos marcadas las opciones:

    Permitir a quienes llaman tener acceso a mi red local.
    Asignar el mismo numero de red a todos los equipos.
    Asignar numero de red automáticamente.
    Permitir a los usuarios que llaman especificar sus números de nodo.

    Compartir archivos e impresoras.
    Cliente para redes Microsoft.
    Programador de paquetes Qos.
    Netbios de NWLink.

    Y creo que con esto es suficiente, pero si me dejo algo necesario, no dudéis en preguntármelo.

    Respecto a la red que se quiere conectar a la mía, citare la configuración de un cliente:

    Sistema Operativo: Windows XP.
    Router: 3Com 812.
    Puertos mapeados: 1723 (TCP) y 47 (UDP). Ambos puertos están mapeados a la IP privada del equipo que es: 192.168.0.1
    La puerta de enlace del Router es: 192.168.0.100
    Nombre del equipo: Cliente.
    Grupo de trabajo: Local.
    Se ha configurado una nueva conexión de red para conectar con el Servidor VPN. La configuración de esta conexión es la siguiente:

    En nombre del host se pone la IP pública del Server: 217….etc.
    Mostrar el progreso al conectar
    Pedir nombre y contraseña, certificado, etc.
    Seguridad: Típica (Requerir una contraseña segura).
    Requerir cifrado de datos (desconectar si no hay)
    Tipo de VPN: Automatico. En su pestaña configuración:

    Habilitar extensiones LCP
    Habilitar la compresión por software

    Protocolo de transferencia compatible con NWLink IPX/SPX/Netbios
    TCP/IP. En sus propiedades:

    Obtener dirección IP y del servidor DNS automáticamente.
    En propiedades avanzadas:

    Desmarcamos la casilla Usar la puerta de enlace predeterminada en la red remota.
    En DNS las opciones por defecto
    En WINS habilitamos la búsqueda de LMHOSTS y Netbios sobre TCP/IP.

    Programador de paquetes Qos.
    Compartir archivos e impresoras.
    Cliente para redes Microsoft.

    Y con esto creo que el cliente también queda bien explicado. Así pues explico de nuevo el problema; los ordenadores conectan y Server (172.26.0.2) asigna a Cliente una IP entre 172.26.0.5 y la 10. Si hago un ping a Cliente desde server (Ping Server) no responde. Pero si hago un ping a 172.26.0.5 o la que le haya sido asignada, ya que varía, me responde correctamente. Los ordenadores no se ven en la red aunque si ven al resto de componentes dentro de su red propia.

    Bueno perdonad por lo largo del mensaje, pero es que ya no se donde puede estar el fallo. Además supongo que no soy el único interesado en crear una VPN sobre WIN XP, de lo cual no he podido encontrar ningún manual en condiciones. Por ello, me comprometo a crear uno cuando mis problemas se arreglen. Agradeciendo vuestra atención y paciencia, aprovecho la ocasión para mandar un saludo al foro!

    Este tema es antiguo y puede contener información obsoleta. Abre un nuevo tema para publicar tu mensaje.
    1