BandaAncha.eu

Comunidad de usuarios
de fibra, móvil y ADSL

DDNS que no está online responde a ping

Solospam

Tengo 2 DDNS en NO-IP, actualmente solo una funcionando y la otra no está conectada.

La duda me surge cuando hoy actualizo el DDNS para que no me caduque y veo que los dos DDNS han resuelto una IP que responde a ping.

¿Cómo puede ser que una DDNS que no está online responda a ping?

vukits

hombre, responderá la IP antigua registrada, digo yo.

para que no haya problemas, puedes hacer que apunte a 127.0.0.1 , p.e.

BocaDePez
BocaDePez
🗨️ 1
josvic
Solospam

El router donde se registra la DDNS destacada está en su caja de momento, pero alguien está usando mi DDNS… como puede ser eso posible?

imagen.webp
🗨️ 1
cowass

Porque como te coment antes @vukits, en tu DDNS queda esa IP registrada. Como no usas ese router, tu operador habrá acabado liberando esa IP y asignándosela a otro usuario, que es el que realmente te responde.

BocaDePez
BocaDePez

Usa duckdns en vez de no-IP. Sus dominios no caducan.

BocaDePez
BocaDePez

¿Resolvido? ¿En serio?

Cuando el operador te quita tu IP no se la guarda como oro en paño, simplemente se la asigna a otro.

Si tu no has actualizado el registro, esa entrada de DNS esta apuntando a tu antigua IP que ahora la tiene otro CPE, nada extraño que conteste a ping.

La próxima vez que quieras dejar un registro "en barbecho" actualízalo a algo evidente como ese localhost que apunta en compañero.

🗨️ 11
Solospam

La próxima vez que quieras dejar un registro "en barbecho" actualízalo a algo evidente como ese localhost que apunta en compañero.

Y eso como se hace?

🗨️ 10
vukits

desde la propia página web de noip se debería poder hacer. (no sé, por lo menos yo en DynDNS tengo esta posibilidad).

O desde el script de actualización… haz uno modificado que en vez de mandar la IP pública, mande siempre 127.0.0.1

🗨️ 9
Solospam

El script es

# No more changes need

:global previousIP

:if ([/interface get $inetinterface value-name=running]) do={
# Get the current IP on the interface
   :local currentIP [/ip address get [find interface="$1inetinterface" disabled=no] address]

# Strip the net mask off the IP address
   :for i from=( [:len $currentIP] - 1) to=0 do={
       :if ( [:pick $currentIP $i] = "/") do={ 
           :set currentIP [:pick $currentIP 0 $i]
       } 
   }

   :if ($currentIP != $previousIP) do={
       :log info "No-IP: Current IP is not equal to previous IP, update needed"
       :set previousIP $currentIP

# The update URL. Note the "\3F" is hex for question mark (?). Required since ? is a special character in commands.
       :local url "http://dynupdate.no-ip.com/nic/update\3Fmyip=$currentIP"
       :local noiphostarray
       :set noiphostarray [:toarray $noiphost]
       :foreach host in=$noiphostarray do={
           :log info "No-IP: Sending update for $host"
           /tool fetch url=($url . "&hostname=$host") user=$noipuser password=$noippass mode=http dst-path=("no-ip_ddns_update-" . $host . ".txt")
           :log info "No-IP: Host $host updated on No-IP with IP $currentIP"
       }
   }  else={
       :log info "No-IP: Previous IP is equal to current IP, no update needed"
   }
} else={
   :log info "No-IP: $inetinterface is not currently running, so therefore will not update."
}

Que tendría que cambiar por 127.0.0.1?

🗨️ 8
vukits
🗨️ 7
Solospam
🗨️ 4
BocaDePez
BocaDePez
🗨️ 3
Solospam
🗨️ 2
BocaDePez
BocaDePez
🗨️ 1
Solospam
🗨️ 1
vukits