Banda Ancha EU

Comunidad de usuarios
de fibra, móvil y ADSL

ADSL

¿Cómo alojar un servidor web desde una conexión de Jazztel?

pqangel

Quiero hacer un servidor en mi PC pero cada vez que intento conectarme con la URL del dominio que tengo registrado me direcciona al router y si me trato de conectar por el puerto 25 (también es un mail server) me da error de conexión.

No recuerdo donde lei que si intentabas conectarte desde tu propia red era como si no te pudieras conectar.

El caso es que si me conecto al servidor vía localhost me conecto sin problemas, tanto al mail server como http, pero cuando pongo la URL me da el error.

He deshabilitado el acceso WAN por http del router y he añadido las excepciones en la configuración del NAT para que los puertos que me interesan me los redirecciones a mi servidor.

Cuando hago un port scan en mi url y en mi IP me sale que tengo los puertos abiertos pero si me intento conectar no me deja.

Estoy con el comtrend CT-5361 con el firmware de fabrica.

vukits

Cuando mapeas puerto 21, 80 etc al ser puertos que corren servicios del router, te avisa de que a partir de ese momento los servicios del router serán accesibles a través del 2121 y 8080 (y demás), para que sigan disponibles. Es decir te deja mapear puertos que normalmente están en uso por el router y mueve sus servicios a otro puerto

por otro lado, el puerto 25 no lo usa ningun servicio del router... me temo que tienes algo mal configurado..

además... si tu conexión al servidor SMTP va por SSL, no se usa puerto 25 por defecto, creo..

para cualquier duda, pasate por aqui.. ;)

BocaDePez
BocaDePez

Prueba a poner como servidor DMZ la IP del PC donde tienes esos servicios y prueba de nuevo a ver.

Y comprueba el firewall del router.

Saludos

Mocho
1

Las pruebas no las puedes hacer desde tu propio pc, no va a funcionar. O las haces a través de un proxy o desde otra conexión. Si por localhost funciona y en el scan los puertos salen abiertos lo lógico sería que funcionase, pero la prueba final tiene que ser desde fuera de tu red.

AguilaRoja
1

El Comtrend no tiene la característica de NAT Loopback, por lo que cualquier referencia a la IP externa tendrá que realizarse desde fuera de la red, nunca desde dentro.

Ningún firmware oficial ni alternativo para este aparato implementa NAT Loopback. Necesitarás otro router, o realizar las pruebas desde fuera en alguna máquina exterior a la que tengas acceso.

pqangel

deerhunter: de momento estoy haciendo la conexion sin SSL, para trabajar con lo basico..

bocadepez: intentare lo q me comentas a ver como va, no conocia para que servia el DMZ pero una busqueda en google y la wikipedia me hacen pensar q a lo mejor funciona...

aguilaroja: si lo q dices es asi entonces estoy en un problema pues ahora estoy haciendo tests en mi maquina pero el servidor real se encuentra detras de un comtrend 5361 de telefonica en el cual tiene q tener acceso al mail server desde la red local y utilizando la URL... yo se que en su momento hice funcionar el servidor HTTP desde la red local configurando el router a traves de telnet... pero no se si sera lo mismo en este caso.

saludos y gracias por contestar

🗨️ 42
vukits

acceso al mail server desde la red local y utilizando la URL

comprate u router neutro que soporte NAT loopback...

los wrt54gl (para Tomato) los venden a cuatro duros :D

AguilaRoja

Un parche sería la posibilidad de meter una entrada fija hacia el servidor de correo local en el DNS interno o en los ficheros HOSTS de los equipos.

🗨️ 40
pqangel

y esto no daria ningun tipo de problemas??

porq claro, esto deberia de hacerlo en todos los ordenadores q se quieran conectar desde dentro de la red interna, verdad??

casi me decanto mas por el NAT loopback antes q por este tipo de parches porque si se compra una maquina nueva y se quiere conectar no va a ser posible sin antes configurar los hosts..

🗨️ 39
AguilaRoja

Por eso hablo de tener un servicio de DNS interno. ¿Disponéis de él?

¿Trabajáis en dominio con un Windows Server? ¿Cuántas máquinas?

🗨️ 38
pqangel
🗨️ 37
AguilaRoja
🗨️ 1
Ari
JoeDalton
🗨️ 33
pqangel
🗨️ 32
JoeDalton
🗨️ 31
pqangel
🗨️ 30
JoeDalton
🗨️ 27
pqangel
🗨️ 26
AguilaRoja
🗨️ 25
pqangel
🗨️ 6
AguilaRoja
🗨️ 5
pqangel
🗨️ 4
AguilaRoja
🗨️ 3
pqangel
🗨️ 2
AguilaRoja
🗨️ 1
pqangel
JoeDalton
🗨️ 17
pqangel
🗨️ 16
JoeDalton
🗨️ 15
pqangel
pqangel
🗨️ 13
JoeDalton
🗨️ 12
pqangel
🗨️ 11
JoeDalton
🗨️ 10
pqangel
🗨️ 9
JoeDalton
🗨️ 8
pqangel
🗨️ 7
JoeDalton
🗨️ 6
pqangel
🗨️ 5
JoeDalton
🗨️ 4
pqangel
🗨️ 3
JoeDalton
🗨️ 2
pqangel
🗨️ 1
AguilaRoja
🗨️ 1
pqangel
inar

Desconozco como funcionará el tema en Jazztel. Te cuento como lo hicimos nosotros con Telefónica por si te sirve de algo.

El problema era el mismo. Al intentar acceder desde dentro al servidor web o ftp a través de la IP en internet, no respondía. Pero en cambio externamente (fuera de la empresa) funcionaba sin problemas. Y al intentar acceder internamente a su dirección local, también sin problema.

La razón: el no soporte del router ADSL de NAT loopback como te comentan.

Solución: (que es lo que no sé si se podrá hacer en Jazztel, pero imagino que sí)
Configurar el router ADSL en lo que en Telefónica se conoce como modo 'monopuesto'. Es decir, con NAT deshabilitado, en modo bridge.
Tras el modem ADSL (ya no funciona como router), colocar un router neutro que soporte NAT loopback y redirigir los puertos correspondientes al servidor.

Luego ya, configurar adicionalmente un DNS no te es estrictamente necesario, pero si te animas, tampoco tiene mayor problema.

Saludos.

🗨️ 5
pqangel

en ultima instancia supongo q seria la unica solucion, sin embargo prefiero intentar solucionarlo sin la necesidad de tener que adquirir hardware nuevo...

🗨️ 4
BocaDePez
BocaDePez

(link roto) esto es

Esa página sale en blanco. Debes tener mal el mapeo porque escribe el código phpinfo en texto plano.

Veamos, escribo aquí porque me interesa saber si vas a montar roundcube cómo te funciona al final sobre IIS6x. Yo uso hmailserver con horde (no ajax), y estoy pensando en si usar DIMP (que es un interface ajax para horde) o meter roundcube 0.2.

También quiero aportar que usar o no SPF no deberia bloquear correos porque no es de uso común aunque sea fácil de implementar en la zona DNS. En mi caso, le doy un pequeño score a no tenerlo, igual que al msgid y al contenido del HELO, pero que ni mucho menos llegan a rebasar el score minimo para spam.

En el tema de IPs dinámicas, pues lo veo complicado de decidir. Pero, salvo que seas un grande, rechazar correos por un test fallido me parece una política muuuuuuy mala. Ya que el spam lo vas a cazar en una acumulación de fallos que siempre tienen, no sólo por la IP.

🗨️ 3
pqangel

daba en blanco porque tenia el short_open_tags en modo off, que se me habia olvidado activarlo :)

pues te voy a ser sincero, roundcube fue siempre mi primera opcion pues me parece que tiene una interfaz bastante chula, pero el problema es que una vez instalado, cuando intento acceder al server me responde con un error de violacion de acceso de php, para ser exactos me dice:

PHP has encountered an Access Violation at 02652B6B

y a partir de aqui me lo repite siempre que intento acceder aunque sea a la pagina principal de roundcube (en mi servidor), he puesto un mensaje en el foro de la aplicacion pero nadie me responde, la verdad es que es una lastima porque el soporte de la comunidad que se le da a esta interface es muy pobre en comparacion con otros...

si a ti se te ocurre algo comentamelo porque si no lo consigo al final me tendre que ir con kerio mail server que me integra el servidor de webmail con https en la misma aplicacion y no me da ningun fallo.

saludos y gracias

🗨️ 2
BocaDePez
BocaDePez
🗨️ 1
pqangel
pqangel

El servidor ya esta montado, de momento funciona bastante bien :)

Estoy tirando con gene6 para el FTP server kerio mail para el mail server y las IIS para HTTP.

muchas gracias por la ayuda a todos, si no hubiera sido por vosotros esto no hubiera sido posible :)

ahora vengo con una ultima duda.

despues de haber configurado los registros SPF me encuentro con el problema de que hotmail manda todos mis emails a la carpeta de correos no deseados, he leido por ahi que añadiendo el registro "spf2/pra" en un nuevo registro TXT el problema se soluciona, lo que no se es si unicamente debo poner estas lineas en el registro TXT o si debo añadir algo mas, no quiero hacer muchas pruebas pues he leido que hotmail puntua tu email en base a lo que recibe y si me manda muchos correos a correos no deseados bajara mi puntuacion llegando a tomarme como spam.

muchas gracias una vez mas y saludos :)

🗨️ 1
BocaDePez
BocaDePez

Soy el bocapez ultimo. Me alegro de que hayas podido hacerlo correr. Pero me apena que hayas tenido que recurrir a soluciones propietarias de pago. En cuanto a lo que dices del SPF sólo hay que configurar la regla en el TXT www.kitterman.com/spf/validate.html

La puntuación debería depender de más cosas que el SPF. Debes comprobar el HELO, si la ip está en listas,...