Banda Ancha EU

Comunidad de usuarios
de fibra, móvil y ADSL

DNS 1.1.1.1 interceptada por el router FG284CD de Vodafone al acceder desde el navegador

  • Fibra/Cable

    [Editado]

    BocaDePez BocaDePez

    DNS 1.1.1.1 interceptada por el router FG284CD de Vodafone al acceder desde el navegador

    Tengo el usuario admin en este router y tengo desactivado el DNS seguro y DNS proxy. Desde el WAN le he puesto que me asigne el 1.1.1.1 y 1.0.0.1 como DNS principales.

    En DNS leak hago la prueba y me sale que todo esta bien por Cloudfare pero si meto 1.1.1.1 en el navegador me sale esto, como si la conexión fuera escuchada interceptada.

    screenshot-20200403-155140.png

    ¿Alguna sugerencia para conseguir que esto no pase? También tengo desactivado el firewall del router y tengo unos TP-Link decos configurados en modo router y con la dmz a una IP estática fuera del DHCP.

    Me trae loco estas cosas que hace Vodafone con los routers.

    • [Editado]

      BocaDePez BocaDePez

      A mí me sucede lo mismo que a ti, en mi caso con el router…

      A mí me sucede lo mismo que a ti, en mi caso con el router Sercomm H500-S en Vodafone, me secuestra todos los paquetes que van al rango 1.1.1.1/8

      Si hago ping a 1.1.1.1, el router responde directamente, no envía las peticiones al servidor de cloudflare, se observa fácilmente porque la latencia es menor de 1ms:

      ~$ ping 1.1.1.1
      PING 1.1.1.1 (1.1.1.1) 56(84) bytes of data.
      64 bytes from 1.1.1.1: icmp_seq=1 ttl=64 time=0.616 ms
      64 bytes from 1.1.1.1: icmp_seq=2 ttl=64 time=0.456 ms
      64 bytes from 1.1.1.1: icmp_seq=3 ttl=64 time=0.392 ms
      64 bytes from 1.1.1.1: icmp_seq=4 ttl=64 time=0.418 ms

      El problema está comentado ya en este hilo: Cómo usar el servidor DNS 1.1.1.1 con Vodafone y el router Sercomm H-500-s

      Hay workaround, entrando por ssh con el pass admin e introduciendo el comando ifconfig br0:0 down . El problema de esta solución es que se pierde al reiniciar el router.

      Es una cagada bastante grande no poder conectar con ninguna IP de ese rango, la verdad. Estaría bien que Vodafone lo arreglara en una actualización de firmware, es bastante fácil de solucionar.

      • BocaDePez BocaDePez

        por casualidad eres fibra NEBA Movistar? me sonaba que podia…

        por casualidad eres fibra NEBA Movistar? me sonaba que podia ser eso pero claro este router es el ''nuevo'' vemos que tambien le pasa, podria hacer el mismo metodo en este? esto es un secuestro total, por cosas como esta me iria a o2 con el HGU o Yoigo que seguro que va mil veces mejor.

        Gracias por no hacerme volverme loco con el tema.

        • BocaDePez BocaDePez

          Hola, mi acceso es Vodafone directo. De todas maneras eso no…

          Hola, mi acceso es Vodafone directo. De todas maneras eso no es relevante para el caso, porque el problema está en el firmware del router, que se reserva ese rango de IPs públicas para uso propio, como si fueran privadas.

          Lo de reservar la IP 1.1.1.1 sucede en bastantes routers. El HGU de Movistar daba el mismo problema, y en Orange también pasaba. La diferencia está en que, ante las quejas de los clientes. tanto Orange como Movistar han actualizado los firmwares de sus routers para solucionarlo y actualmente funciona bien. Ya podría Vodafone hacer lo mismo. Es que además no sólo secuestran una IP, sino un rango /8 completo, lo cual es una burrada.

          • ¿El firmware de ese router está actualizado? Yo tuve que…

            ¿El firmware de ese router está actualizado?

            Yo tuve que forzar un hard reset a un HGU que tenía secuestrado el 1.1.1.1 para que se actualizara solo. A las pocas horas se instaló un nuevo firmware que liberó el 1.1.1.1.

            El Sercomm H500-S creo que también se distribuye en Lowi FTTH y que yo sepa, el último firmware no secuestra el 1.1.1.1.

            • BocaDePez BocaDePez
              Hola pepejil. Estoy en Finetwork, el firmware es el…

              Hola pepejil.

              Estoy en Finetwork, el firmware es el w1-h500s-v3.4.23, no es exactamente el mismo que el de Lowi, porque no aparecen los dibujitos de Lowi, sino el logo de Sercomm, pero me parece que Lowi también usa la versión v3.4.23. ¿Podrías comprobar la tuya?

              Resetee mi router hace 3 semanas aprox, y no actualizó a ninguna versión nueva.

              Por cierto, cuando haces ping a 1.1.1.1, ¿qué valor te da?

              Y la IP 1.0.0.1 , ¿ te responde a ping?

              Gracias.

              • Tengo dos líneas de Lowi fibra, pero ambas son HFC. La…

                Tengo dos líneas de Lowi fibra, pero ambas son HFC. La primera con un Technicolor TC7230 y donde estoy actualmente, con un Sagecom ST3686 y en ambas tengo conectividad plena con 1.1.1.1/8.

                Decia lo de Sercomm porque juraria que fue de los primeros routers que Vodafone actualizó cuando empezó Cloudflare a poner en marcha su servicio DNS y como no habia quejas de ello, me extrañaba.

                Sobre los ping, en HFC y en Wi-Fi 5Ghz:

                Haciendo ping a 1.1.1.1 con 32 bytes de datos:
                Respuesta desde 1.1.1.1: bytes=32 tiempo=14ms TTL=55
                Respuesta desde 1.1.1.1: bytes=32 tiempo=13ms TTL=55
                Respuesta desde 1.1.1.1: bytes=32 tiempo=15ms TTL=55
                Respuesta desde 1.1.1.1: bytes=32 tiempo=14ms TTL=55
                
                Estadísticas de ping para 1.1.1.1:
                    Paquetes: enviados = 4, recibidos = 4, perdidos = 0
                    (0% perdidos),
                Tiempos aproximados de ida y vuelta en milisegundos:
                    Mínimo = 13ms, Máximo = 15ms, Media = 14ms

                Y si, a 1.0.0.1 tengo los mismos valores.

                Tengo un amigo con Lowi FTTH y juraria que tiene el Sercomm, le preguntaré.

    • Por cierto, han sacado nuevos DNS: 1.1.1.2 y 1.1.1.3 (bloqueo…

      Por cierto, han sacado nuevos DNS: 1.1.1.2 y 1.1.1.3 (bloqueo malware y bloqueo de sitios para adultos), pero ya me he encontrando que con el HGU no chutan, como pasaba cuando sacaron el 1.1.1.1. Unos auténticos lumbreras los de los firmwares.