BandaAncha.eu

Comunidad de usuarios
de fibra, móvil y ADSL

Fibra

Sin IPv6 al sustituir router Digi ZTE H298A por MikroTik

diamuxin1

¿Alguien que esté en Digi tiene instalado un router MikroTik? Yo lo tengo instalado sustituyendo al ZTE H298A pero observo que antes con el ZTE si hacías la prueba en test-ipv6.com obtenía un resultado de 10/10.

image.webp

Ahora con el MikroTik:

image.webp

No se como configurarlo para que trabaje tanto con IPv4 como IPv6 (dual stack) como el de Digi. ¿Alguna ayuda?

SOLUCIÖN

BocaDePez
BocaDePez

Metele los DNS de Digi para IPv6.

diamuxin1

¿Cuales son?

diamuxin1

ok, gracias.

fendergetafe

Hola:

El mikrotik por defecto trae IPv6 deshabilitadaaudience-mikrotik.webp

diamuxin1

Si, es cierto, ya le activé el paquete IPv6. He conseguido que en DHCP Client obtener por PPPoE una dirección IPv6 pero desde mi LAN no puedo llegar a Internet y en la página test-ipv6.com aún sale como 0/10 en las pruebas. Soy novato en Mikrotik, a ver si hay algún compañero que controle esos routers me puede echar una mano.

S@lu2.

🗨️ 3
Solospam

Pregunta en el foro de telegram de mikrotik

"mikrotik en español" por allí ya estan los resellers de Digi tocando los bemoles, quizás puedan ayudarte

BocaDePez
BocaDePez
1
  1. Revisa en RouterOS que está configurado el anunciamiento del prefijo. Dicha opción la tienes en IPv6 > Address.
  2. Revisa que tu sistema operativo está debidamente configurado para obtener direccionamiento IPv6.

Espero que te pueda ser de ayuda.

MT

🗨️ 1
diamuxin1

Si, mi sistema operativo (Windows 10) coge una IPv6.

Con router de Digi y con un HGU configurado con IdONT y la VLAN de Digi, sin problema, pero con MilroTik no (hay que configurarlo a mano)

Gracias por responder.

BocaDePez
BocaDePez
1

Efectivamente, debes configurar el cliente DHCPv6 como ya te han comentado, meter el bloque /56 que te da Digi en un pool y a partir de ese pool puedes añadir un /64 en la pestaña de direcciones de IPv6 y anunciarlo para que tengas SLAAC funcionando correctamente.

JavI DJ Compu

Conseguiste algo? , yo esque tengo el Ubiquiti edgerouter ER-X SFT , y no ahi manera de que coja la IPv6 . lo que veo esque al tener VLAN 20 , nose como configurar la VLAN 20 con el ppoe y ala vez todo lo del IPv6

JavI DJ Compu
2

He podido porfin por fin tener todo con el EdgeRouter X. Tengo el archivo de configuración para Digi lógicamente, solo haría falta sustituir los datos del PPPoE por los vuestros, pero vamos estoy super feliz.

Tengo IPv6 + IPv4 + 1 Gb Simétrico funcionando todo.

Gracias a esto:

set interfaces ethernet eth0 vif 20 PPPoE 0 dhcpv6-pd pd 0 interface switch0 host-address '::1'
set interfaces ethernet eth0 vif 20 PPPoE 0 dhcpv6-pd pd 0 interface switch0 prefix-id ':1'
set interfaces ethernet eth0 vif 20 PPPoE 0 dhcpv6-pd pd 0 interface switch0 service slaac
set interfaces ethernet eth0 vif 20 PPPoE 0 dhcpv6-pd pd 0 prefix-length 56
set interfaces ethernet eth0 vif 20 PPPoE 0 dhcpv6-pd rapid-commit enable
set interfaces ethernet eth0 vif 20 PPPoE 0 IPv6 dup-addr-detect-transmits 0
set interfaces ethernet eth0 vif 20 PPPoE 0 IPv6 enable
set firewall options mss-clamp6 mss 1432

Con esos únicos comandos, (una vez pasado el Wizard) ha funcionado a la primera.

BocaDePez
BocaDePez
1

Una vez que ya tienes la conexión de Digi funcionando con PPPoE en IPv4 , activas el paquete IPv6 en Mikrotik y luego haces esto:

/IPv6 DHCP-client add add-default-route=yes interface=PPPoE-out1 pool-name=loquesea pool-prefix-length=56 request=address,prefix
/IPv6 nd set [ find default=yes ] hop-limit=64 interface=bridge1 managed-address-configuration=yes other-configuration=yes ra-interval=20s-1m
/IP set DNS servers=2620:119:35::35 (IPv6 de opendns)
/IPv6 firewall filter add action=drop chain=forward comment="Drop external" in-interface=PPPoE-out1 (regla de firewall para prevenir accesos desde internet)

Y ya está, cualquier equipo en la red local que soporte IPv6 le puedes poner las DNS en formato IPv6 y funcionará bien. Ajusta los nombres de interfaces a tu configuración.

🗨️ 2
diamuxin1

Muchas gracias amigo.

diamuxin1

Disculpa, pero por temas laborales lo acabo de probar, pero no funciona esa configuración en Mikrotik.

Alguna idea más??, supongo que se puede hacer por que con el router de Digi, Asus, HGU y demás transmiten sin problema las IPv6.

Saludos!

diamuxin1

Hola amigos, por fin he conseguido tener IPv6 de Digi en mi router Mikrotik.

He intentado ponerlo aquí pero da muchos problemas poner imágenes.

El que le interese, puede ver los pasos por aquí

Un saludo.

🗨️ 2
vukits
-1

Preferiría traer dicha info aqui.

¿Puedo copiarla?

🗨️ 1
diamuxin1
1

Si, sin problema.

Una vez que la tengas puedes borrar el enlace, gracias.

vukits
2

Autor: @diamuxin1

Debido a que en internet hay muy poca información al respecto, os dejo la configuración necesaria para transferir el IPv6 nativo que ofrece Digi. Hasta ahora sólo se había visto con el propio router de la compañía, ZTE H298A, y en los routers Asus tanto en el sw oficial y en las versiones de tomato firmware.

Lo he probado tanto en el modelo hAP Ac2 como en RB750Gr3 y funciona igual que en el de Digi, teniendo direcciones IPv6 diferentes en todos los hosts de la LAN y accediendo a Internet.

  • En primer lugar, hay que activar el paquete IPv6 en el router que por defecto viene desactivado.
  • Metemos los siguientes comandos por Terminal:

Creamos un interfaz específico en ND

IPv6 - ND (Neighbor Discovery)

# En "add interface" pones el nombre que le has dado a tu interfaz Bridge.
/ipv6 nd
set [ find default=yes ] disabled=yes hop-limit=64 other-configuration=yes
add interface=bridge

Creamos un cliente DHCP

IPv6 - DHCP Client

# En "interface" pones el nombre de tu interfaz PPPoE que creaste.
# En "pool-name" le das el nombre que desees al Pool de IPv6 que se creará automáticamente al obtener el Prefijo.
# En "interface" dentro del script, pones el nombre que le has dado a tu interfaz Bridge.
# En "from-pool" dentro del script, pones el nombre que le has dado en "pool-name".
/ipv6 dhcp-client
add add-default-route=yes interface=pppoe-out1 pool-name=pool6 request=prefix script=\
    ":delay 5s;\r\
    \n/ipv6 address remove [find advertise=yes] \r\
    \n/ipv6 address add interface=bridge address=::1/64 from-pool=pool6 advertise=yes"

Creamos las siguientes reglas de Firewall IPv6

IPv6 - Firewall - Filter Rules

# En "in-interface" y "out-interface" pones el nombre de tu interfaz PPPoE que creaste, en mi caso "pppoe-out1".
/ipv6 firewall filter
add action=drop chain=input comment="Drop (invalid)" connection-state=invalid
add action=accept chain=input comment="Accept (established, related)" connection-state=established,related
add action=accept chain=input comment="Accept DHCP (10/sec)" in-interface=pppoe-out1 limit=10,20:packet protocol=udp src-port=547
add action=drop chain=input comment="Drop DHCP (>10/sec)" in-interface=pppoe-out1 protocol=udp src-port=547
add action=accept chain=input comment="Accept external ICMP (10/sec)" in-interface=pppoe-out1 limit=10,20:packet protocol=icmpv6
add action=drop chain=input comment="Drop external ICMP (>10/sec)" in-interface=pppoe-out1 protocol=icmpv6
add action=accept chain=input comment="Accept internal ICMP" in-interface=!pppoe-out1 protocol=icmpv6
add action=drop chain=input comment="Drop external" in-interface=pppoe-out1
add action=reject chain=input comment="Reject everything else"
add action=accept chain=output comment="Accept all"
add action=drop chain=forward comment="Drop (invalid)" connection-state=invalid
add action=accept chain=forward comment="Accept (established, related)" connection-state=established,related
add action=accept chain=forward comment="Accept external ICMP (20/sec)" in-interface=pppoe-out1 limit=20,50:packet protocol=icmpv6
add action=drop chain=forward comment="Drop external ICMP (>20/sec)" in-interface=pppoe-out1 protocol=icmpv6
add action=accept chain=forward comment="Accept internal" in-interface=!pppoe-out1
add action=accept chain=forward comment="Accept outgoing" out-interface=pppoe-out1
add action=drop chain=forward comment="Drop external" in-interface=pppoe-out1
add action=reject chain=forward comment="Reject everything else"
  • Una vez finalizado, nos vamos al DHCPv6 Client y en pocos segundos, el Status pasaría de "searching" a "bound". Obteniendo de Digi un prefijo /56.
imagen.webpimagen.webp

Puede ocurrir que a veces se queda el Status en "searching" y no hay forma de obtener ningún prefijo, esto para mi fue un verdadero quebradero de cabeza y es que Digi con cada nueva IPv4 te vuelca un prefijo IPv6 nuevo, como es normal, entonces probé lo siguiente: nos vamos a la interfaz PPPoE que tenemos creada y la deshabilitamos, dejamos unos segundos y volvemos habilitarla hasta que sincronice de nuevo.

Ahora ya el DHCPv6 Client ya lo tenemos como "bound" y con un nuevo prefijo. Tras este paso, se crean solos el Pool y el Route List.

  • Ya solo nos queda, añadir una nueva dirección IPv6 a la interfaz Bridge, con los siguientes datos:
imagen.webp

Donde ::192.168.88.1/64 es la dirección IP de nuestro Bridge pero en formato IPv6.

Pulsamos en "Apply" y obtenemos del Pool automáticamente el prefijo que recibimos de Digi.

imagen.webpimagen.webp
  • Comprobamos ahora si nuestro PC ha obtenido direcciones IPv6 del router:
imagen.webp

Y probamos si hay conectividad nativa IPv6

imagen.webpimagen.webp

Pues bien, ya tenemos nuestro Mikrotik funcionando como un proveedor de direcciones SLAAC.

El siguiente video me ha aclarado bastante los pasos a seguir:

🗨️ 1
Aeri

Buenísima info, gracias por compartirlo ;)

Stetco

A mi desde ayer me ha desaparecido la IPv6… Ya no me asigna más que IPv4…