BandaAncha.eu

Comunidad de usuarios
de fibra, móvil y ADSL

Degradación paulatina del funcionamiento del DNIe

Andin53A

Hola, el uso del DNIe se degrada a medida que actualizo el software en Windows. Os explico. Mi DNIe funciona perfectamente en el ordenador de mi trabajo , donde los encargados de TIC ha optado poner un teclado con lector de tarjetas y el módulo criptográfico antiguo 2.53 sobre un ordenador con w7 32bit.

El primer ordenador que utilicé en casa hace unos 7 años ( WinXP ) con un lector de Bit4id y módulo criptográfico 2.53 me funcionó perfectamente hasta que tuve la funesta idea de actualizar a la versión 10. El comportamiento era errático: en Mozilla me funcionaba correctamente, pero en el entorno de Windows me pedía el PIN pero no muestra ningún certificado en el panel de Opciones de Internet --> contenido --> certificados.

Tuve que desinstalar en instalar la versión 6 del módulo criptográfico después de pedir al departamento de soporte que me proporcionasen el enlace a una versión mas antigua, ya que en ese momento no había enlaces al histórico de descargas.

Pensé que las cosas irían a mejor con windows 7, pero me equivoqué. Tengo ahora un ordenador con un lector multitarjetas de Coolbox , ese modelo que además de tarjetas de memoria permite leer SIM y tarjetas como el DNIe.

Pues las cosas han ido a peor con el módulo versión 11 para 64 bit. En el entorno de windows opciones de internet muestra un vez solo uno de los 2 certificados que contiene el DNI, una vez la firma, otra vez el certificado de autentificar , otra vez no muestra nada. Otra vez si saco mi DNIe y pongo el de mi mujer muestra los datos del DNIe anterior, etc.. Y en el entorno de Mozilla Firefox casi lo mismo.

¿ Alguna idea de como solucionar el problema ?

Este tema está cerrado a nuevas respuestas. Abre un nuevo tema para retomar la conversación.
BocaDePez
BocaDePez

Gracias por la info.

yo no consigo que me salga el puto cuadro de dialogo pidiendome el puto PIN... y se supone que esta todo correctamente configurado.. y en el lector de DNIE cuando lo introduzco aparecen los iconos verdes, entendiendo que esta instalado de forma correcta...

probare a desinstalar, y a instalar de nuevo...

que suplicio

Andin53A

Reinstalar suele ser la respuesta estándar que dan todos, incluidos la policia. De hecho me he bajado todas las versiones para probarlas de una en una.

Pero no es tan fácil como parece, ya que el módulo criptográfico que se instala por el sistema plug and play solo sirve para Internet Explorer y Java. Si quieres que además funcione en el entorno de Mozilla Firefox o Seamonkey que utilizan el sistema PKCS11 desarrollado en su tiempo por Netscape y que sigue utilizándose en los productos Mozilla , no tienes mas remedio que descargar el software de la policía para instalar ambos módulos.

De hecho, en mi trabajo el departamento de TIC es muy conservador y migró hace poco los ordenadores a Windows 7 32bit ( fundamentalmente por mantener aplicaciones desarrolladas en casa y que por falta de presupuesto no se han podido migrar a sistemas de windows mas recientes ) siguen implementando el módulo del DNI antiguo 2.53.

Lo que me da a pensar que las nuevas versiones de la policía no son tan fiables como parece

Para vuestra información mi lector multitarjeta también es Coolbox CR-600V2

BocaDePez
BocaDePez

Yo tengo el SCR3310v2.0 bajo Windows 10 64bits y me va todo perfecto. Haz caso al compañero, desinstala todo el software y controladores viejos, y deja que Windows te instale el último controlador (de Windows 7 en adelante)

Cuando he tenido problemas (rara vez) no ha sido por el driver o el s.o., sino por el complemento java que usan muchas páginas (a veces no están actualizados, tienen los certificados de seguridad caducados o problemas con los permisos).

🗨️ 1
Andin53A

Hola,

Ya se que los applets de java dan muchos problemas, pero el problema se da tanto a nivel del módulo para el entorno de windows ( Internet Explorer , Chrome o java ) como en Mozilla Firefox ( incluso cargando manualmente los módulos por si el instalador no lo ha hecho correctamente )

vukits

hmm.. quizás interese usar Chrome por algun tiempo.

pero vamos, eso del DNI-e es una patata..

Es muchisimo más comodo usar certificado software de la FNMT ;)

🗨️ 2
Andin53A

Pero te recuerdo que Chrome ha dejado de soportar el plugin de java, lo que ha obligado en mi trabajo, donde se tiene que utilizar la plataforma de firma electrónica de la ACCV ( estamos en Valencia y ya sabes con tal de hacerle la puñeta a la FNMT vale todo ) a dejar de utilizar Chrome.

En cuanto a los certificados de la FNMT tienes toda la razón , es mucho mas cómodo, pero hay muchas entidades que no la reconocen, por ejemplo los ayuntamientos de la comunidad valenciana y la Generalitat Valenciana.

Como ya dije en otra intervención, la primera versión del módulo de hace 7 u 8 años, la 2.53 funcionaba perfectamente enWinXP, solo que era un coñazo las veces que pedía el PIN. Parece que al querer solucionar ese problema lo han cagado.

Tengo otro ordenador con XP y el mismo lector, pero solo lo uso en fines de semana, no lo tengo aquí a mano. Investigaré los problemas que tengo ahí y ya comentaré los resultados dentro de unos días.

🗨️ 1
BocaDePez
BocaDePez

Veo que este tema de hace cuatro sigue vigente hoy en día, soy absolutamente incapaz de instalar el DNIe y lo que es peor, he borrado el contenido del DNIe (los certificados personales) al querer desinstalar el controlador Minidriver for Smart Card de la DGP UMPass v.1.026. No entiendo cómo es posible fulminar de esa manera el contenido de una supuesta tarjeta inteligente que sólo puede ser sobreescrita en las oficinas del DNI de la Policía Nacional.

BocaDePez
BocaDePez

Yo he arrancado el chip a mi dni.

No se para que llevan ese chip, para tenerte controlado

🗨️ 3
BocaDePez
BocaDePez

Tu eres pero que mu toooonto !!!

🗨️ 2
mceds

Se venden carteras que bloquean las comunicaciones inalámbricas, no hace falta ser tan drástico.

BocaDePez
BocaDePez

para que quiero el chip, si no lo uso nunca?