Banda Ancha EU

Comunidad de usuarios
de fibra, móvil y ADSL

Fibra

Mi calvario para definir puertos TCP y UDP concretos con NAT en LiveBox+ e IPv6

Lionel Dobie

Histórico de cambios

  • 20/12/18: Esta vez parece que sí que se queda IPv4. Reinicio router y ONT dos veces y las dos me da IPv4, y puedo abrir puertos. A ver si dura.
  • 19/12/18: Sigo igual, a la espera de IPv4. Aunque Jazztel me dice que la tengo, no es verdad. Esto es de pena.

Estoy quemadisimo con el router LiveBox + que me ha puesto Jazztel al cambiar a la fibra de 600 en vez de la de 300 que tenía, porque no hay manera de abrir puertos por haberme cambiado a IPv6, al parecer (lo digo por lo que 'intuyo' que me ha pasado después de leer a otras víctimas en distintos foros).

No puedo abrir un puñetero puerto bien. Porque cuando pones uno por NAT, él te pone otro externo sugerido por PCP, y como no coinciden, le pongas el que le pongas en tu programa (el que le has puesto tú, o el que te sugiere por PCP) no va, ya que son diferentes. Si le dices sin más que no te sugiera por PCP, no te acepta nunca la regla (la odiada crucecita roja).

Conseguí una vez (ahora ya no me funciona) que fuesen iguales (externo e interno) haciendo el truco, en la configuración NAT, de poner un puerto cualquiera, borrando la regla y creando otra nueva usando el external port que te sugirió antes el router con la regla borrada cuando permites que te proponga uno por PCP.

El truco en cuestión lo encontré aquí: LiveBox Fibra no abre puertos.

Dice algo así:

2. Te aparecerá un nuevo número en la casilla Puerto externo. Quédate con el y borra la regla que hay añadida.

3. Añade una nueva regla así: ts3UDP | ElNuevoPuerto | ElNuevoPuerto | UDP | 192.168.1.3 | Aceptar propuesta de puerto PCP desmarcada y pulsa Añadir.

Si sigue sin añadirse bien… Intenta reiniciar el router y repite de nuevo. Prueba también con un navegador diferente. A veces Chrome da problemas de compatibilidad con el LiveBox Fibra. Esta mañana he podido echar una mano a alguien el IRC y ha podido abrir los puertos de esa forma sin problema. Suerte y paciencia.

Dejo este video como prueba de que el método no funciona a veces:

dropbox.com/s/ypj1bc5119vb9y7/Livebox%20…tos.wmv?dl=0


Otra cosa: si UPnP está activado y pones una regla NAT, te dice que es válida y que sobreescribirá una de las que se ven en el apartado UPnP (pero no dice cual), y sin embargo en UPnP sigue saliendo la antigua, lo que añade más follón a la jarana…

Por UPnP me ponía que tanto el tráfico tcp como el udp iban por ese puerto sugerido, hacia mi IPv4 interna pero ahora ha cambiado y no se me abren los puertos.

Alguien con IPv6 EN LiveBox +, me puede decir cómo leches configuro por ejemplo:

  • el Emule por NAT, con su puerto TCP y otro diferente UDP y que me funcione bien ?
  • el cliente de bittorrent qbittorrent con un solo puerto, y usando tcp y udp que vayan los dos protocolos al mismo puerto ? (porque ni siquiera cuando conseguí que me aceptase poner el puerto sugerido a mano, me dejaba repetir el mismo puerto para tcp y udp, porque salía la crucecita roja de marras cuando repetía el puerto)

Además, claro, cuando llamas no suelen tener ni idea y te marean a pruebas y sugerencias con poco sentido, para decirte al final QUE NO TE DAN SOPORTE PARA ESTAS COSAS.

¿Por qué ahora no deja poner los puertos sugeridos si desmarco "sugerir PCP" y me pone la cruz roja, ponga el puerto que ponga?

¿Por qué no puedo definir el mismo puerto para dos protocolos?

1. Añade una regla así: ts3UDP | 9987 | 9987 | UDP | 192.168.1.3 | Aceptar propuesta de puerto PCP marcada y pulsa Añadir.

Pero ahora nada, ni por esas conecta. Además, cuando intento hacer como cuando me funcionó con el truco, le pongo el puerto sugerido por PCP de nuevo y quito el check de la propuesta por pcp, me sigue saliendo la cruz roja de que no ha sido aceptado. Incluso reiniciando el router.

Kalimist

Una aclaración: tu problema no es IPv6 (con IPv6 no se usa NAT), el problema es que te han activado el CGNAT y compartes la IPv4 con varios clientes, de ahí que tengas que abrir puertos por PCP, con todos los problemas que conlleva.

Creo que te pueden sacar del CGNAT si lo solicitas y cuando te asignen una IP para ti solo podrás abrir puertos como se ha hecho siempre.

Por curiosidad, que router tenias antes? No entiendo por qué te lo han cambiado al duplicar velocidad.

🗨️ 1
Lionel Dobie

Hola, y muchas gracias por la respuesta !

Esta mañana ya he solicitado que me quiten el CGNAT y que me vuelvan a pasar a ipv4; Me han dicho que estará en 72 horas...

Antes tenía el ZXHN H218N, y cuando me cambiaron de 300 a 600, no me llegaban ni de coña. Incluso me bajó a 200 de bajada, mientras que la subida se mantuvo entre 300 y 400. Me dijeron que al cambiar al nuevo ésto se arreglaría, y fue así. Aunque ahora esté pasando por el problema del CGNAT...

BocaDePez
BocaDePez

Soy la persona que escribió el mensaje al que haces referencia y la forma que expliqué es la única que da resultado. A veces el servidor PCP y el router fallan como una escopeta de feria y a los días, tras reiniciar el router, vuelve a funcionar todo bien por sí mismo sin cambiar nada. No hagas caso al símbolo, frecuentemente el router marca el símbolo rojo como que no ha podido abrir el puerto pero realmente sí lo abre sin problemas. Añade un puerto, quédate con el sugerido como puerto externo, borra la regla y añade una nueva con el puerto externo sugerido tanto como puerto interno como puerto externo con la casilla de la propuesta PCP desmarcada. Después, usa ese puerto que has añadido para el servicio que necesites. Borra las reglas que tengas en la tabla e inténtalo de nuevo desde cero. No uses UPnP, porque dará problemas en tu caso.

No puedes hacer mucho más al respecto, salvo seguir intentándolo, tener paciencia, reiniciar el router o pedir a Orange que te desactive el protocolo IPv6. Suerte y paciencia, porque sé lo que quema el asunto...

🗨️ 3
Lionel Dobie

Hola, y gracias por la respuesta ...

Como le decía a Kalimist, he solicitado que me vuelvan a poner con ipv4 a ver si funciona. Vaya desastre de montaje, es bochornoso... Aún haciendo lo que comentas, y no haciendo caso al símbolo, no abre puertos. No sé si es que he perdido la paciencia después de marear con la perdiz durante dos días, pero no estoy dispuesto a tener esta porquería de montaje y pasar por el tubo.

Gracias de nuevo por tu ayuda.

Lionel Dobie

@Boca de pez: Tela... Otros días lo había intentado y no iba ni de casualidad, excepto la primera vez y por poco tiempo que duró...

Hoy lo he vuelto a intentar (con tu método - deberías patentarlo) y ha funcionado... A saber hasta cuando.

Lionel Dobie

@Boca de pez:

He editado el post principal para añadir un link con el vídeo en donde se ve cómo lo pruebo y cómo no funciona la apertura de puertos: dropbox.com/s/ypj1bc5119vb9y7/Livebox%20…tos.wmv?dl=0

He vuelto a llamar a los mangantes de Jazztel, para saber cómo iba la re-reclamación que hice ayer por la noche explicando que pasaban de mi cara cuando les reclamé volver a ipv4. Esta vez, me han dado un número de incidencia y ME HAN CONFIRMADO que 'en este caso', sí que me podrán pasar a ipv4 en un plazo de 24/72 horas.

Me lo debería creer ? pfff

para más cachondeo, añado que he estado hablando con 4 personas, una de ella me ha hablado con tal nivel de peloteo que resultaba ridículamente absurdo. Lo que pido es sólo abrir puertos hosstia.

Uno de los técnicos además me ha admitido que "se quedaba corto de palabras" para darme su opinión, cuando le explicaba lo que nos pasaba a miles de usuarios. Ya nos entendemos...

mceds

Tanto eMule como los clientes Bit Torrent permiten escoger los puertos que te dé la gana. Y no tienen por qué coincidir. Reserva un puerto TCP y dos UDP para eMule y lo mismo (1 TCP y 2 UDP) para tu cliente de torrents. Una vez el sistema PCP te los confirme, apúntalos y ponlos en la configuración de esos dos programas.

🗨️ 14
Bramante

reserva un puerto TCP y dos UDP para eMule

eMule solo necesita un puerto TCP y un UDP, que pueden ser perfectamente el mismo para ambos protocolos.

🗨️ 7
Lionel Dobie

Ya ya, pero los clientes torrent también pueden usar UDP que optimiza ciertas cosas, que es a lo que me refería... Y no he encontrado ninguno que deje especificar TCP y UDP en dos puertos separados (diferentes).

🗨️ 6
mceds

Qué raro. Tranmission me deja sin problemas.

🗨️ 3
BocaDePez
BocaDePez
mceds
Bramante

Sí, sí, solo comentaba que para eMule con usar un único puerto para ambos protocolos, es suficiente.

De Torrent tengo poca idea porque apenas lo he usado.

🗨️ 1
Lionel Dobie

Hola 'mr. Galaxian, (por cierto, era el juego fetiche de mi niñez, me marcó mucho !!!)

Como comentaba, poniendo los puertos propuestos por PCP en los clientes qBittorrent y eMule, no funciona. Los siguen dando como cerrados.

Y sobre el tema de que los clientes bittorrent permiten escoger puertos, no he logrado encontrar ningún cliente que te permita escoger los puertos tcp y udp POR SEPARADO. Es el caso por ejemplo, de qBittorrent, donde sólo te deja poner uno, aunque le pongas la opción de usar TCP Y UDP. El caso es que había pensado en algún cliente de torrents compatible con myanonamouse, que dejara ponerlos por separado dado que el puñetero router roñoso este no deja poner el mismo puerto para TCP y UDP (el combo para escoger protocolo no incluye una opción para poner ambos, y cuando lo haces por separado siempre sale el odiado símbolo de prohibido que indica que no se puede poner)...

Total, que como decía, he vuelto pedir a mis orígenes, back to my roots, al ipv4 sin inventos para el tercer mundo, a ver si funciona el tema.

🗨️ 5
mceds

No estaba muy al tanto de las facilidades que daban para volver a IPv4 "puro". Siendo así, ni te lo pienses. Y así puedes escoger el cliente BT que quieras.

Ya veo que eres viejuno como yo, las Galaxian son de los primeros ochenta.

🗨️ 4
Lionel Dobie

Siii, viejunos al poder ! 😅... Ahora con tantos juegos, la ilusión se disipa por saturación...

sjlopezb

Lo hay OnLine...pero...se usa JAVA.

P.S.: 1980-games.com De nada.

🗨️ 2
vukits

a ver...

pon el Livebox en modo birdge, y usa tu propio router...

El firmware del Livebox es una patata

🗨️ 16
Lionel Dobie

Vaya ! gracias por la respuesta, no había pensado en esa opción. Aunque haya pedido el cambio a ipv4 de nuevo, sería posible hacer esto aún a sabiendas de que incorporaría a los 'trastos siempre encendidos' uno más como por ejemplo, un viejo Comtrend 536+ (que és lo único de lo que dispongo, no me pienso gastar más pasta) ?

Realmente sería posible esta rocambolesca opción, aún a sabiendas (me repito) de que mi mujer me pueda echar de casa al ver el simulacro de central de comunicaciones en el comedor ?!

Hala, a seguir luchando contra las operadoras. Salud !

🗨️ 15
vukits

hay routers de segunda mano que valen 30€

que és lo único de lo que dispongo, no me pienso gastar más pasta)

🗨️ 14
Lionel Dobie

Vale, aceptamos barco, pero sería el último al que me subiría (más bien sería una patera). Como te preguntaba, sería realmente posible ? Lo que me planteas es una teoría o un hecho comprobado por tu augusta persona ?

🗨️ 13
vukits
🗨️ 12
BocaDePez
BocaDePez
🗨️ 11
vukits
🗨️ 10
EmuAGR
🗨️ 8
BocaDePez
BocaDePez
🗨️ 1
vukits
🗨️ 5
Kalimist
🗨️ 1
EmuAGR
1
Kalimist
1
🗨️ 1
Lionel Dobie

Actualización de mi calvario con Jazztel:

Como contaba, pedí a Jazztel que me volviesen a poner ipv4 por el problema de no poder abrir los puertos.

Ayer por la tarde les llamé de nuevo para saber el estado de mi cambio a ipv4. Para mi asombro (iba a decir sorpresa, pero NO me sorprende), el técnico me dice que va a abrir una NUEVA incidencia para reclamarlo (o sea que sospecho = aseguro que se habían pasado por el forro mi primera petición de pasar a ipv4).

Como me enviaron por SMS un link para seguir esta nueva reclamación, esta mañana me he levantado y he visto que ya la cerraron a las 23:00 de ayer.

Entro al router y veo que sigo con ipv6, y que el tema puertos sigue sin funcionar.

Vuelvo a llamar por teléfono y vueeelvo a explicar el rollo a la persona que me atiende.

Inicialmente me dice que el técnico que me atendió, en teoría apuntó lo que reclamaba, pero que el técnico que resolvió la incidencia, al ver ‘QUE EL SERVICIO IBA BIEN’, que según el técnico con el que estaba hablando, equivale a decir ‘que me llegue internet’, la cerró sin más, no haciendo caso de la reclamación de pasar a ipv4.

Insistiendo con él, al final me confiesa que, si abrimos una nueva incidencia, “lo más probable es que vuelva a pasar lo mismo”, con lo que afirmo que:

- Nos engañan haciendo ver que tienen en cuenta lo que pedimos: NO es verdad.

- Estamos indefensos ante la actitud de Jazztel de pasar de nuestra cara, porque no podemos hacer nada (o casi nada) para aclarar la grandísima jeta de Jazztel para hacer que el técnico que dio por resuelta la incidencia tomase otra actitud.

Total, que luego pido que me pasen con el departamento de reclamaciones.

Les he explicado mi caso: Que nos engañan, que los técnicos tienen supuestamente directrices de mirar sólo si nos llega internet, pasando del resto de detalles. Y también le he explicado, aparte del periplo personal, los detalles, o sea: Que es concretamente lo que pido: ipv4 y poder abrir puertos bien. RE-explicado por enésima vez, y supuestamente anotado por la señora que me ha atendido.

Ahora estoy esperando cual cordero degollado la respuesta por parte de Jazztel, que con mucha probabilidad consistirá a decirme de nuevo que “ellos no dan soporte para abrir puertos”, y que consideran que, si me llega internet, el servicio es correcto.

¿Qué voy a tener que hacer al final, hacer una puñetera reclamación al defensor del consumidor o algo así? Manda cojones.

¿Qué os parece el tema?

Alguien realmente ha conseguido que le vuelvan a poner ipv4 con las condiciones comentadas (fibra indirecta, router livebox+ ipv6) …

🗨️ 2
BocaDePez
BocaDePez

Contrata jazztel, y te quedarás por su servicio técnico.😀

🗨️ 1
Lionel Dobie

no me piqueeees xd

Lionel Dobie
1

No me lo puedo creer Kalimist... !!! FUNCIONA !!! 😀😀😀 😮😮😮

Alucino como Jazztel todavía tiene mi incidencia como pendiente de resolución, cómo después de innumerables llamadas nadie allá haya sabido decirme, que con una acción tan simple como esta, todo funcionaba.

He desactivado la opción siguiente:

Configuración avanzada, pestaña DHCP

Dentro de la sección "configuración de DHCP", la última opción dice así: "servidor IPv6 DHCP": Hay que desactivarla y reiniciar el router.

Una vez reiniciado he visto varias cosas:

- Como tenía configurado que me enviase un mail cada vez que cogiese una ip al encenderlo, la ip que me ha dado ha sido sólo ipv4

- Al asignar puertos por upnp, los ha asignado a la primera

- Al desactivar upnp y asignarlos manualmente por NAT, ha funcionado también a la primera

- Cuando defines entradas por NAT de esta manera, la opción "Aceptar propuesta de puerto PCP" aparece marcada, PERO DESHABILITADA, con lo que entiendo que no se tiene en cuenta aunque aparezca marcada.

- También definiendo entradas por NAT, ahora en el combo para elegir protocolo aparece una nueva opción que echaba en falta: "Ambos".

- El programa Transmission ya me reporta que el puerto estaba abierto, antes era imposible, aunque desde sitios como www.canyouseeme.org me dijese a veces que SI estaba abierto, porque Transmission igualmente no lo interpretaba como abierto... Algo faltaba. Ahora no, todo parece correcto.

Bueno, pues espero que todo esto sirva para mucha otra gente, y también por si lo ve alguien de Jazztel, para que sepan que falta invertir en formación a sus técnicos y empleados. Alucino, de verdad...

Gracias de nuevo, Kalimist !

🗨️ 14
Kalimist
1

Me alegro! Un placer ayudar, lo vi de casualidad, es bueno saber que se puede aprovechar el Livebox pese a estar tan capado. Entiendo entonces que al deshabilitar IPv6 se habilita el NAT tradicional (port forwarding) y se deshabilita PCP.

Al deshabilitar IPv6 te asigna una IP fuera del CGNAT (no compartida) al igual que pasa con el ZTE F680 por ejemplo.

BocaDePez
BocaDePez

Hola buenas como has conseguido solucionarlo?? tengo el router livebox fibra he desactivado la opcion servidor IPv6 DHCP he reiniciado el router y sigue sin funcionar. Podrías indicar todos los pasos que has hecho en el caso de que tengas el router livebox fibra??

🗨️ 10
Lionel Dobie

Hola,

Lo he detallado en el post de ayer a las 21:54. Tengo el Livebox +

🗨️ 9
BocaDePez
BocaDePez
🗨️ 1
mceds
ice2k2
🗨️ 2
BocaDePez
BocaDePez
🗨️ 2
BocaDePez
BocaDePez

En un router Livebox + con Orange este método no ha dado resultado. Sigue asignando una IPv6 y la IPv4 sigue tras CG-NAT.

🗨️ 1
Lionel Dobie

Efectivamente, como digo a Boca de Pez, me tiró de nuevo a ipv6. Sigo esperando a que me pongan la ipv4

EmuAGR
1

La verdad es que me gustaría tener IPv6, pero la quiero con Dual Stack, no con DS-Lite. ¿Por qué a la gente que quiere una IPv4 sin CGNAT les quitan la IPv6? Así lo que consiguen es no expandir la conectividad v6 y la gente siga pidiendo v4...

🗨️ 1
Lionel Dobie

Supongo que porque no tienen infraestructura preparada para tener los dos...