Banda Ancha EU

Comunidad de usuarios
de fibra, móvil y ADSL

debian lenny

invitado

Hola buenas, me instalado debian lenny y tengo problemas para poder instalar los drivers de la 8800 gt.

¿como podria hacerlo para poder instalarle los drivers?

saludos

BocaDePez
BocaDePez
  • Primero desinstala todos los módulos de Nvidia que tengas instalados, aptitude remove --purge nvidia-glx nvidia-settings y nvidia-kernel-common.
  • Bajate los drivers oficiales de Nvidia: wget es.download.nvidia.com/XFree86/Linux-x86….12-pkg1.run (estos son para 32 bits)
  • Instala las herramientas y fuentes para instalar el módulo: aptitude install build-essential linux-headers-$(uname -r)
  • Entra en modo texto Ctrl+Alt+1
  • Para el servidor gráfico /etc/init.d/gdm stop (kdm si usas KDE)
  • Instalas los drivers: sh ./NVIDIA-....run
  • Reinicia: reboot now
🗨️ 1
ronko

Invitado este método que menciona el bocadepez al que respondo es el mejor, los drivers de la web van mucho mejor que los de los repositorios.

añadir que a lo mejor tienes que instalar también el libc6-dev aun así lo que te falte te lo va diciendo al instalación, sales de ella instalas lo que te ha dicho y vuelves a intentar.

No se si pasará en lenny pero puede que haya algun problema con la version del gcc que el kernel fue compilado con una (la 4.1) y el sistema use otra más nueva (la 4.2).
Solo serían dos comandos con variables (solo si lo mencionase la instalación)
set CC (esto crea la variable)
export CC=gcc-4.1 (y esto le da valor)
echo esto lanzar la instalación y con los paquetes necesarios que ya te han dicho y listo ;) .

melomano

añade a los repositorios el conjunto de paquetes contrib y non-free, así te aparecerán los drivers como un paquete descagable. una vez descargados, sólo tienes que modificar el xorg cambiando el driver nv por nvidia

🗨️ 29
invitado

ok gracias y como lo hago para añadir a los repositorios lo que me dices?

saludos

🗨️ 28
BocaDePez
BocaDePez

Lenny no es lo que la gente de Debian entiende por estable... Pero que es estable, lo es. Es la que estoy usando yo, y va perfectamente, ni cuelgues, ni errores gordos. El compromiso perfecto entre estabilidad y versiones nuevas de los paquetes (la Debian "estable" debería llamarse "Debian prehistórica").

🗨️ 26
melomano
🗨️ 9
BocaDePez
BocaDePez
🗨️ 7
BocaDePez
BocaDePez
BocaDePez
BocaDePez
🗨️ 4
BocaDePez
BocaDePez
🗨️ 2
BocaDePez
BocaDePez
BocaDePez
BocaDePez
🗨️ 9
BocaDePez
BocaDePez
🗨️ 7
BocaDePez
BocaDePez
🗨️ 5
superllo
🗨️ 4
BocaDePez
BocaDePez
🗨️ 3
superllo
🗨️ 2
BocaDePez
BocaDePez
BocaDePez
BocaDePez
ronko
🗨️ 4
vukits
🗨️ 3
ronko
🗨️ 2
BocaDePez
BocaDePez
BocaDePez
BocaDePez