Banda Ancha EU

Comunidad de usuarios
de fibra, móvil y ADSL

Fibra/Cable

dd-wrt con ono

BocaDePez
BocaDePez

Buenas, se ha estropeado mi router y he tenido que desempolvar un viejo belkin que funciona bien(f5d7230-4), pero para ponerlo un poco mas dificil he probado a ponerle el firmware de dd-wrt. Y el problema que estoy teniendo es que parece que no hay forma que coja una ip del modem(un motorola sb5100). De las cosas que se me ocurrian he probado todas, primero a reiniciar el modem, despues reinicio modem+router, reset a valores de fabrica del firmware dd-wrt, probar a conectar directamente al modem un pc para conseguir una ip y con la mac clonada en el router sacar el cable del pc y conectarlo al modem. Pero nada de nada. También en la pestaña Estado/Wan he intentado en Renovar DHCP para ver si fuerza al modem para obtener una ip.

Ademas la version del dd-wrt es de la ultima estable v24-sp2, y detecta que la configuracion de la conexion a internet es dinamica por dhp del isp.

No sé si se me pasa algo importante por alto pero no he conseguido que funcione todavia... se agradecen sugerencias o preguntas si falta algun detalle importante :D

Un saludo!

vukits

asegurate de haber enchufado el cable al puerto wan, jeje..

prueba otro cable wan también.

cuando enchufes el router al cablemodem... resetea el cablemodem (mantén pulsado el botón reset durante 15s. )

saludos

🗨️ 12
Sammi

Con un soft reset de 1 pulsación mas que suficiente, la cache de mac está en el modem y es volátil con un simple reseteo.

Debes tener otro problema porque no se distingue lo que se conecta al modem. si con un pc funciona, con otro equipo cualquier también.

BocaDePez
BocaDePez

Gracias por las sugerencias pero el modem solo tiene un boton de standby xD mi sistema es mas rudimentario, quitar el enchufe, esperar un minutillo o algo mas y volver a conectar. El cable funciona bien, ya que conectando el modem directamente a un pc funciona sin problemas, y el que va del router al pc tambien esta bien, se accede sin problemas a la administracion del router. Me quedo sin ideas de cual puede ser el fallo...

🗨️ 10
BocaDePez
BocaDePez

Tampoco funciona en estatico copiando al router la configuracion que se obtiene en el pc(ip publica, mascara, dns's, puerta de enlace) mientras se navega. Teniendo la mac del pc clonada en el router para que el modem no cambie de ip.

Pego una captura del interfaz wan del router donde se ve un "pico" al conectar el cable del modem.

Imagen original en http://img823.imageshack.us/img823/8424/wanjj.jpg

🗨️ 9
vukits

Antes de nada, ¿ qué versión de hardware es? (lo pone en la pegatina en la base)

🗨️ 8
BocaDePez
BocaDePez
🗨️ 7
vukits
🗨️ 6
BocaDePez
BocaDePez
🗨️ 5
vukits
🗨️ 4
BocaDePez
BocaDePez
🗨️ 3
Malisno
🗨️ 2
BocaDePez
BocaDePez
🗨️ 1
vukits
BocaDePez
BocaDePez

Yo tengo un access point lynksis con ese mismo firmware de ddw-rt y funciona con los diferentes cable modem que los paletos de Ono me han ido dando. Cuando llegue a casa si me acuerdo miro como está condigurado

vukits

segun dice este tío..

una versión más antigua le funcionó .(no te olvides de restaurar a valores de fabrica, después de flashear)

sólo me limité a buscar el termino "F5D7230-4 wan" en el foro de dd-wrt.

saludos

🗨️ 3
BocaDePez
BocaDePez

Wow, después de la cantidad de horas que me he chupado de leer el foro del dd-wrt(entre otros) y sin conseguir nada concreto, gracias a tus enlaces vukits se ha solucionado. Debe haber algun problema por lo visto con la combinacion de modem Motorola Surfboard y router Belkin viejuno. Ya está funcionando sin problemas, aunque parece que al ser antiguillo el firm está menos pulido y se ha bloqueado un par de veces al conectar al router el modem. Pero al momento de reiniciar ha conseguido por fin que funcione simplemente en configuración automática de DHCP. Mil gracias vukits!!!! El openwrt me parecia demasiado lio, que bien que ya esté solucionado :D

Pongo imagen del final feliz!!

La versión final que ha funcionado ha sido: DD-WRT v24 (05/20/08) mini (SVN revision 9517M Eko)

🗨️ 2
vukits

no, no es por el modem.

es que muy a menudo los drivers para el switch (si existen, claro) son penosos..

por eso hay gente que aboga por 'hardware abierto',... para que uno no tenga que perder el tiempo haciendo ingeniería inversa o mendigandolos al fabricante :D

saludos

🗨️ 1
BocaDePez
BocaDePez
1

Habia leido alguien que tenia los mismos problemas con identicos modem y router, por eso creia que podria ser algun problema especifico entre ellos.

Parece que se bloquea a veces el acceso a la pagina de administración del router, aunque la conexion sigue funcionando sin problema. Gracias vukits!!