BandaAncha.eu

Comunidad de usuarios
de fibra, móvil y ADSL

Curiosidad

SuPRiMaZo

Buenas tardes.

Se me plantea el siguiente problemilla con mi red doméstica, os planteo la topología:

Router ASUS RT-AC66U (LAN 1 Gbps) - Puerto WAN conectado a CISCO EPC3928 (Salida a internet)

3 equipos conectados por Ethernet al router ASUS (PC1, PC2 y PC3) con cables Cat5E (Cables probados e intercambiados, están OK).

===============================================================================================

Resulta que... no consigo darle explicación a que, cuando realizo una transferencia de archivos en mi red local, ocurre lo siguiente:

Si la transferencia es entre el PC1 y el PC2:

Sentido PC1 HACIA PC2

Imagen original en http://puu.sh/7qmBv.jpgImagen 1

Sentido PC2 HACIA PC1:

Imagen original en http://puu.sh/7qjZ2.jpgImagen 2

Todo va bien, ningún problema.

Si la transferencia es entre el PC2 y el PC3:

Sentido PC2 HACIA PC3:

Imagen original en http://puu.sh/7qk22.jpgImagen 3

Todo va bien, ningún problema.

Sentido PC3 HACIA PC2:

Imagen original en http://puu.sh/7qmBv.jpgImagen 4

Todo va bien, ningún problema.

Si la transferencia es en sentido PC1 HACIA PC3:

Imagen original en http://puu.sh/7qk48.jpgImagen 5

La conexión a internet DE PC1 se resiente, pasa de los 20ms a los ~300ms en el momento en el que la transferencia comienza a realizarse siguiendo en los ~300ms hasta que esta finaliza:

Imagen original en http://puu.sh/7qkpC.jpgImagen6

Si la transferencia es en sentido, PC3 HACIA PC1, la conexión a internet de PC1 NO SE RESIENTE y va a 1Gbps, no a los 300Mbps máximo que se obtienen en sentido PC1 HACIA PC3.

Y aún rizo más el rizo:

Si hago una transferencia PC1 HACIA PC3 (Supuesto antes comentado y que sí afectaba a la conexión a internet), pero el destino en PC3 es un HD conectado por USB a ese PC3, sigo en los 300Mbps PERO la conexión a internet no se resiente.

El resumen sería:

La transferencia es correcta y a 1Gbps entre PC1 y PC2 en ambos sentidos. También es correcta en ambos sentidos si hablamos de PC2 y PC3.
Si la transferencia ocurre desde PC1 HACIA PC3 con destino un disco SATA de PC3, la tasa de transferencia oscila entre 300 y 400Mbps y la conexión a internet de PC1 SE RESIENTE.
Si la transferencia ocurre desde PC1 HACIA PC3 con destino un disco USB de PC3, la tasa de transferencia oscila entre 300 y 400Mbps y la conexión a internet de PC1 NO SE RESIENTE.
Si la transferencia ocurre desde PC3 HACIA PC1 independientemente del destino en PC1, la tasa de transferencia es de 1Gbps y la conexión a internet de PC1 NO SE RESIENTE.

Las preguntas serían:

- #1 ¿Por qué si el sentido de la transferencia es PC1 HACIA PC3 sólo se alcanzan 300/400Mbps y en sentido PC3 HACIA PC1 se llega a 1Gbps?

- #2 ¿Por qué cuando el destino de la transferencia PC1 HACIA PC3 es un HD SATA la conexión a internet de PC1 se resiente (Imagen 6) y si el destino es un HD USB no? (Aquí la bajada en la tasa de transferencia tendría sentido ya que el HD va conectado por USB2.0)

Siento mucho el liazo, pero no sé plantear el problema para que quede más claro :S, a ver si alguien tiene alguna explicación para esta curiosidad...

Me rompe los esquemas que el tráfico LAN con destino HD SATA de PC3 afecte a la salida a internet de PC1 y en el resto de supuestos NO... además de que la tasa de transferencia varíe según el sentido de la misma...

Muchísimas gracias de antemano.

txuspe

Parece un problema interno de PC1. Inicialmente pensaría en la tarjeta de red, pero el hecho de que usando el USB la red parezca estar menos saturada me hace pensar en algún problema en un bus, posiblemente por culpa del chipset. ¿La tarjeta de red es PCI? Si es así, podrías intercambiarla con otro PC por descartar ese punto.

🗨️ 2
SuPRiMaZo

Gracias txuspe por tu respuesta.

PC1 tiene dos tarjetas de red integradas en placa (ASUS Rampage II Extreme):

Imagen original en http://puu.sh/7qswV.png

Ahora mismo está el cable en la 1, probaré si con la 2 ocurre exactamente lo mismo.

SuPRiMaZo

Ya decía yo que no podía haber planteado bien el problema xDDDD

He editado el mensaje original, ahora sí explico exactamente lo que pasa.

Entonces, digamos que el posible problema que tu planteas txuspe, no sería coherente con la situación ¿no? Es decir, suponiendo que la NIC de PC1 estuviese mal, siempre que PC1 estuviese en alguno de los escenarios algo fallaría, y no es así ¿no?

PD: Con el cable conectado en la NIC2 de la placa, ocurre lo mismo.

vukits

aahhh... Windows 8 .. bueno en tantas cosas y malo en otras tantas ...

Windows 8 tiene el rollo ese de IPV6 .. evidentemente el router no va dar salida a IPV6 .. ¿lo tienes activado en todo los ordenadores? (compruebalo)..

por otro lado, haz las pruebas de transferencia sin conectar el router y comentanos , para descartar colisiones ..

🗨️ 14
SuPRiMaZo

No es Windows 8, es Server 2012 :/

No se me ocurriría instalar Windows 8 xD

Si, mañana haré más pruebas, ahora estoy dándole al Network Analyzer a ver si veo algo...

🗨️ 13
BocaDePez
BocaDePez

Te cuento una cosa que me he encontrado una vez en casa de un amigo, y que tal vez pudiese ser una explicación, pues el efecto era similar al tuyo.

Resulta que en la red de mi colega, uno de los 2 equipos es un portátil que tenía conexión de cable y también WiFi. Una vez, se le olvidó desconectar la WiFi antes de pinchar el cable Ethernet, y el router le dio 2 direcciones IP, una a cada interfaz. Resulta que el equipo era alcanzable por ambas, y el recurso compartido se anunciaba por ambas.

Unas transferencias llegaban por la Ethernet a la velocidad correcta, pero en otras, dependiendo cuál de los 2 equipos había sido encendido antes, resulta que escogía ir por la WiFi... con la consiguiente pérdida de velocidad.

Comprueba que no te pase lo mismo, ya que la única otra razón que le veo a esos 36 MB/s sería el cuello de botella de un disco duro USB 2.0

🗨️ 12
SuPRiMaZo

Muchísimas gracias por tu respuesta.

Lo cierto es que tenía lógica, porque en el PC1 salto bastante de WIFI a conexión por cable, pero he quitado el adaptador y verificado en el servidor DHCP (Que está montado en el PC3) que no había concesión al adaptador y sigue ocurriendo lo mismo :/

🗨️ 11
BocaDePez
BocaDePez
🗨️ 10
SuPRiMaZo
🗨️ 9
BocaDePez
BocaDePez
🗨️ 7
SuPRiMaZo
🗨️ 6
BocaDePez
BocaDePez
🗨️ 5
SuPRiMaZo
🗨️ 4
BocaDePez
BocaDePez
🗨️ 3
SuPRiMaZo
🗨️ 2
BocaDePez
BocaDePez
🗨️ 1
BocaDePez
BocaDePez
1
SuPRiMaZo

He probado a eliminar el router ASUS de la ecuación, es decir, conectar todos los equipos al CISCO que también es GIGABIT.

El problema persiste... dándose exactamente las situaciones descritas en el post original.

Me dispongo ahora a probar un LIVE CD en el PC1...

🗨️ 3
LineBenchmark

Me dispongo ahora a probar un LIVE CD en el PC1

Y/o en PC3. Es raro de narices. Parece cómo si al S.O. (o driver de Lan) en PC1 o PC3 se le va la pinza, pero... Imagino que ya probaste a cambiar de puerto, tanto de PC1 cómo de PC3 y/o no tener conectado PC2. Incluso probar con otra tarjeta de RED en PC1.

Saludos.

🗨️ 2
SuPRiMaZo

Gracias por tu respuesta Donovan.

Sí, he cambiado de puertos en el router, he probado las dos tarjetas de red que tiene integradas en placa el PC1 y obtengo el mismo resultado.

He conseguido un resultado diferente antes... Dejé conectados al router ASUS el PC1 y el PC3, conecté al router CISCO el PC2. Con esa topología, no había ningún problema de transferencia, fuese cual fuese el sentido de la transferencia entre las 3 máquinas siempre se alcanzaba 1Gbps, ahora bien, siempre que PC1 era el que enviaba a cualquier destino, la conexión a internet de PC1 se resentía, no tanto como antes, pero sí se resentía...

Voy un poco mal de tiempo ahora y no podré hacer más pruebas, pero la verdad es que se está convirtiendo en algo personal jajajaja

Gracias de nuevo a todos por vuestros comentarios.

🗨️ 1
LineBenchmark

Si, es hacer pruebas y pruebas, porque casi no hay por dónde cogerlo. Incluso puede ser por alguna inconsistencia en el propio registro. Del tema de la tarjeta de Red, me refería a que instalases otra, dejando deshabilitadas las que lleva la Rampage. Incluso ya, que pruebes con otra máquina diferente en PC1 o PC3 que es por dónde seguiría. Todo por delimitar dónde puede estar el problema que en algún sitio estará. :D

Ánimos. ;)

Saludos.