BandaAncha.eu

Comunidad de usuarios
de fibra, móvil y ADSL

Crear varias VLAN con rango IP diferentes

GALIZA2010

Tengo un switch Cisco-Linksys SRW248G4P y he creado 2 VLAN (V1 y V2) . Cada VLAN tiene asignado sus puertos en modo ACCESS y Membership = UNTAGGED.

Lo que quiero hacer es que la VLAN V1 asigne a sus bocas la subred 192.168.0.x y la VLAN V2 la subred 192.168.1.x.

El problema es que no encuentro en todo el menu, ni por telnet, dónde configurar el DHCP para cada una de las VLAN.

¿Alguien sabe como hacerlo?

BocaDePez
BocaDePez

A bote pronto te diría que el error está en pretender que un switch te haga funciones de router.

Incluso en DHCP te diría que un router te va a dar problemas para hacer dos subredes. Pero bueno, supongo que CISCO estas cosas las contempla, y tal vez más modelos de routers, por lo que seguramente esté confundido. Lo que nos lleva a considerar de momento sólo el primer párrafo, en espera de una mejor solución aportada por otro forero.

Roglecas
1

Primero ke todo debes ver si tu Switch soporta DHCP server, de ser así y si tienes iOS (Interwork Operating System) el OS de cisco pues es muy sencillo configurarlo, si no a través de alguna GUI (Graphic User Interface), primero ke todo es un grave error configurar la VLAN 1 en un Switch cisco debido a que es la VLAN por default ke traen los Switch Cisco y no sería conveniente por cuestiones de seguridad usar esta VLAN1 asi ke te recomiendo ke uses otra para tus segmentos, ya ke todo equipo que se conecte a un puerto del switch sin este estar configurado el Switch cisco le dará la VLAN1 como default VLAN. asi ke si es una persona no autorizada tendría acceso a tu segmento de red ke tendrias configurado en la VLAN1

Una vez asignados los bloques de IP ke kieres darles a tus VLAN lo ke debes hacer es tener en cuenta kien sera tu DHCP server, si el switch cisco soporta esta función y es un Switch L3 no hay problemas, si no debes conectar este Switch a un router o a un server para que estos hagan la función de DHCP y rutee entre las VLAN si kieres ke se vean entre ellas.

En caso ke tu switch sea un switch L3 (Layer 3) (ke trabaje en la capa de red) o sea que pueda desencapsular los paquetes tcp/IP y leer el destination IP address y source IP address, deberas crear subinterfaces virtuales en tu switch para ke este sepa donde se encuentra cada VLAN y pueda dar bien los rangos de direcciones IP que has escogido, si el Switch no es L3 deberás entonces conectar una interfaz de red (NIC) en el server ke hara de DHCP a cada segmento de la red, en tu caso sería dos tarjetas de red en el server una a cada VLAN y el switch conectado al un router para ke pueda rutear entre las VLAN si kieres ke estas se vean entre si

EJEMPLO

en este ejemplo ke te dejo a continuación configurare 2 VLAN en un switch cisco, VLAN10 y VLAN20.

SWITCH CISCO

Switch>enable
Switch#config t
Switch(config)#vlan 10
Switch(config-vlan)#name VLAN-NOMBRE
Switch(config-vlan)#exit
Switch(config)#vlan 20
Switch(config-vlan)#name VLAN-NAME
Switch(config-vlan)#exit
Switch(config)#interface range fastEthernet 0/1-10
Switch(config-if-range)#switchport mode access
Switch(config-if-range)#switchport access vlan 10
Switch(config-if-range)#exit
Switch(config)#interface range fastEthernet 0/11-21
Switch(config-if-range)#switchport mode access
Switch(config-if-range)#switchport access vlan 20
Switch(config-if-range)#exit

hasta aki todo lo ke conectes en los puertos del 1 hasta el 10 pertenecerán a la VLAN10 y todo lo ke conectes en el puerto del 11 al 21 pertenecerán a la VLAN20

Ahora para crear sub-interfaces virtuales para asignar las dirección IP de la siguiente manera

Switch>enable
Switch#config t
Switch(config)#interface vlan 10
Switch(config-if)#ip address 192.168.0.1 255.255.255.0
Switch(config-if)#no shutdown
Switch(config-if)#exit
Switch(config)#interface vlan 20
Switch(config-if)#ip address 192.168.1.1 255.255.255.0
Switch(config-if)#no shutdown
Switch(config-if)#exit

Para configurar tu DHCP server en el Switch si lo soporta

Switch>
Switch>enable
Switch#config t
Switch(config)#ip dhcp excluded-address 192.168.0.1 192.168.0.10
Switch(config)#ip dhcp excluded-address 192.168.1.1 192.168.1.10

Hasta aki para excluir estas direcciones si keires reservarlas a lo ke sea siempre es conveniente tener un rango de IP excluidas

Switch(config)#ip dhcp pool VLAN10
Switch(dhcp-config)#network 192.168.0.0 255.255.255.0
Switch(dhcp-config)#default-router 192.168.0.1 (SUB-INTERFACE-DEL-SWITCH)
Switch(dhcp-config)#dns-server 192.168.0.2 (IP-DE-TU-DNS-SERVER)
Switch(dhcp-config)#exit

hasta aki creas el primer pool de IP a repartir por el DHCP ke es para la VLAN10 con el rango ke kerias de 192.168.0.X el defualt router sera el default gateway para este segmento de red, o sea todo lo ke no sea enviado para tu segmento 192.168.0.X/24 se enviara a tu gateway en este caso la suibterface del switch y este lo reenviara a su destino y deberas hacer lo mismo para la VLAN20 192.168.1.X

Switch(config)#ip dhcp pool VLAN20
Switch(dhcp-config)#network 192.168.1.0 255.255.255.0
Switch(dhcp-config)#default-router 192.168.1.1
Switch(dhcp-config)#dns-server 192.168.1.2 (IP-DE-TU-DNS-SERVER)
Switch(dhcp-config)#exit

Pues ya con esto esta resuelto el problema de tus VLAN, DHCP para cada una de ellas y ruteo entre las VLAN

para finalizar

Switch#copy ru st

Para que guardes tu configuración y todo listo.

En caso que tu switch no soporte estas funciones de L3 como te dije tendrás que conectarlo a un router y la configuracion seria otra o en el server tendrias ke conectar una tarjeta de red a la VLAN10 entre los puertos 1 y 10 y otra tarjeta en el mismo server a la VLAN20 entre los puertos 11 y 21 según la configuración ke te hice aki, y crear tu DHCP server en tu server y cada VLAN se iría por separado a cada tarjeta de red en tu server.

🗨️ 1
GALIZA2010

Muchisimas gracias por la aportación. Estos dias lo pruebo y os digo como ha quedado. Muchas gracias :D :D

BocaDePez
BocaDePez

Hola buen dia, ya hice todo lo que tu nos comentas, muchas gracias de antemano por eso, funciona todo bn, ahora el problema que tengo es que los equipos de mis vlan no navegan y no se comunican con pcs que esten fueras de la vlans.

Que me falta por hacer?

Gracias

🗨️ 1
BocaDePez
BocaDePez

Obviamente, para eso se definen VLANs, para que no haya comunicación directa entre ellas. :D

Necesitas poner un router para gestionar el tráfico más allá, digo yo ;)

BocaDePez
BocaDePez

Y si quiero hacer que las vlans no se vean, es decir, no hagan ping entre los computadores que estan conectadas en cada una de ellas, como hago?

🗨️ 1
BocaDePez
BocaDePez

hasta donde se ese switch es de capa 2 necesita un router con la configuracion necesaria para hacer lo que el necesita

BocaDePez
BocaDePez

gracias estaba buscando como loco estos comandos muchas gracias.