Banda Ancha EU

Comunidad de usuarios
de fibra, móvil y ADSL

hosting en interdominios
36 lecturas y 8 respuestas
  • Cerrado

    BocaDePez BocaDePez
    6

    contrend ct 536+ Servidor FTP

    hola wenas,

    tengo el router contred ct536+ con jazztel 20 megas y no consigo hacer funcionar mi servidor ftp. Uso el programa serv-u y se pueden conectar a mi servidor pero no acceder a ver lo que hay dentro. He entrado en la configuracion del router y al intentar abrir el puerto 21 me dice que esta en uso por el router y que el servidor ftp pasa a ser el 2121, lo configuro asi en el serv-u pero tampoco funciona. Llegan a conectarse pero no a ver lo que hay dentro, dice que o bien el contenido ha sido movido o que no tienen permisos, cosas que no son asi, esta todo revisado.
    A ver si alguien sabe por que puede ser y me echa un cable.. gracias.

    Este tema es antiguo y puede contener información obsoleta. Abre un nuevo tema para publicar tu mensaje.
    1
    • Cerrado

      BocaDePez BocaDePez
      6

      wenas.. pues no se segun el mensaje que me salia parecia todo…

      wenas..

      pues no se segun el mensaje que me salia parecia todo lo contrario, que el puerto 21 era el que usaba el router y el 2121 el que tendria que usar yo, pero si es eso ya lo he cambiado.
      Ahora lo de modo pasivo y tal... lo tengo puesto por defecto.. o sea "Regular FTP only, no SSL/TLS sessions" pero antes con el modem huawai me iba perfectamente sin tocar esto. Asi que me recomendais que lo ponga en "Alow SSL/TLS and regular sessions" o en "Alow only SSL/TLS sessions" ?
      Tambien he mirado que coincida el home directori de la cuenta del usuario que creo con el dir acces.. asi que no se muy bien porque falla, cuando antes con el modem ya digo que iba perfecto.

      saludos

      • Cerrado

        6

        el router huawei controlará trafico ftp.. el problema es que…

        el router huawei controlará trafico ftp.. el problema es que en la conexion de control se envian ips privadas, si el router no las cambia no funciona. Pero como va en texto directamente no todos los routers lo hacen.

        para activar el pasivo es aquí

        • Cerrado

          BocaDePez BocaDePez
          6

          ok solo una duda mas.. la ip que se pone en passive mode es…

          ok solo una duda mas.. la ip que se pone en passive mode es la publica o la privada.. y si es la publica se puede poner un nombre de dominio, lo digo porque yo tengo ip publica..

          • Cerrado

            6
            es la publica, y que yo sepa, no se puede poner un dominio :(…

            es la publica, y que yo sepa, no se puede poner un dominio :( es un rollo porque cada vez que cambia hay que andar modificando la configuracion. Es algo que no me gusta del serv-u, pero bueno

            • Cerrado

              Ok lo acabo de actualizar entonces.... a ver si funciona…

              Ok lo acabo de actualizar entonces.... a ver si funciona asi..
              si no otro programa que funcione mejor que el serv-u y que no sea muy complicado de configurar???

              gracias

                • Cerrado

                  BocaDePez BocaDePez
                  6
                  Buenas tenia un problema paraecido con el mismo router…

                  Buenas tenia un problema paraecido con el mismo router gracias a ti lo he solucionado por que la verdad lo que me fallaba era eso del pasive mode, pero solo despues de trastear un monton por que al final solo lo he conseguido solucionar desactivando el modo pasive de los clientes que se conectaban al servidor parece ser que este router en si no deja pasar las conexiones tipo pasive mode bien, aunque abras el puerto y configures software del servidor ftp con la ip publica no me preguntes por que por que yo tampoco entiendo mucho.

                  muchas gracias por tu ayuda indirecta je je...

    • Cerrado

      6

      no.. el que pasa al 2121 es el servidor interno del router,…

      no.. el que pasa al 2121 es el servidor interno del router, no el tuyo. Deja el tuyo en el 21

      pueden ser dos cosas: 1 que los clientes tengan el modo pasivo activado y el serv-u no (hay que activarlo en settings-advanced del dominio) y otra que los clientes estén usando modo activo estando detrás de router que no monitoriza ftp.