Banda Ancha EU

Comunidad de usuarios
de fibra, móvil y ADSL

Congelación de Debian Sid/Buster

sjlopezb

¿Habéis notado algo? Yo estoy en la rama inestable, debido a paquetes que necesito, porque en la estable no están o no funcionan correctamente y sí en la inestable.

Por lo que voy viendo estos días, ahora mismo, que tengo 3.942 paquetes (antes tenía 3.989 paquetes y tengo 44 paquetes del LibreOffice, pero de su versión web con paquetes DEB. Versión 6.1.1.2-2).

Pues parece que se van a congelar paquetes ya, el kernel es la versión 4.18.10, pues se va a quedar ahí, como estable para marzo del 2019.

Hay una purga de paquetes impresionantes, entre las LLVM 3.8, 3.9, 4.0 y 5.0. Solo quedan ya, las LLVM 6.0 y 7.0, que son los que aparecen hasta ahora. Incluso, unos cuantos paquetes que ya no deberían ni estar en la versión, ni nada.

Funcionar, funciona bien, incluso, con los controladores de la tarjeta de vídeo que tengo integrada en el portátil (bueno, también vía web, de la geforce.com. Es la versión 340.107). En estos momentos, con GCC 8.0.

La Debian 8 ya terminó su ciclo:

debian.org/News/weekly/2018/02/

De momento, tienen 1.301 paquetes huérfanos:

debian.org/devel/wnpp/orphaned

Y hay ya 158 paquetes en adopción:

debian.org/devel/wnpp/rfa

Hay una hoja de ruta de Debian Buster:

lists.debian.org/debian-devel-announce/2…sg00006.html

Por tanto, para marzo del 2019, Debian Buster será ESTABLE. Espero que no retrasen.

La próxima versión que va a ser como TESTING/UNSTABLE, va a llamarse 'Bullseye'.

Y la Debian 12, va a ser llamado como 'Bookworm'.

¿Qué os parece todo esto?

vukits

A ver..

Si necesitas paquetes mas nuevos que en la estable, usa los epositorios backports

🗨️ 7
sjlopezb

No necesito las BackPorts. Ya tengo yo necesariamente de los sitios y páginas web's para eso. ;-) De todos modos, no tengo necesidad alguna.

¡Gracias, de todas formas!

🗨️ 6
mceds

Otra opción es tirar de chroot.

🗨️ 5
sjlopezb

Jeje... Pero eso es para cuando se tiene servidor... :-)

Aps...¿qué haces a esas horas despierto?

🗨️ 4
mceds
🗨️ 3
sjlopezb
🗨️ 2
mceds
🗨️ 1
pepejil

Debian 8 sigue con paquetes de seguridad hasta el 6 de junio del 2020 y según el calendario de lanzamiento de Buster, no se empezará a congelar hasta entrado el 2019.

No sé si lo congelarán con el Kernel 4.18... Hasta enero tienen tiempo. De todas formas la última longterm es la 4.14 y Debian lo tendrá que congelar en la última longterm del Kernel.

wiki.debian.org/LTS
wiki.debian.org/DebianBuster

🗨️ 1
sjlopezb

Y lo sé, el caso es, ahora que ya lo estuve viendo, es que, han quedado ahí quietos al kernel 4.18.10 (aunque hay la 4.18.17. También ya hay la 4.20-rc1).

Puede que se queden con la 4.14 como comentas, pero no me lo creo. Es que, curiosamente, el viernes mismo, vi que habían actualizado el kernel de Linux, pues han puesto la 4.18.10-2+b1. De ahí, ya se congeló. No darán más actualizaciones hasta que queden congelados por completo.

La 4.18, la empecé a tener desde este mismo verano.

Ahora, no sé si será lo que tú digas, que sea la 4.14, veo la 4.19.1 en kernel.org.

De momento, no descarto que saquen a que sea la 4.18.10 como Longterm, de ahí, quedan congelados hasta poner nuevos parches de seguridad.

Desde luego, que en marzo del 2019, será la nueva 'Bullseye', que entrará como Testing/Unstable.

Y como comentas, sí, así es...hasta el 2020 en el 8.

Habrá que ver qué es lo que van a sacar ahora.